Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Where can I find 'FormsHelper API' as described in 'AEM 6.0 Forms Help / Writing custom Submit action for adaptive forms'

Avatar

Level 3

Hi 

1) https://helpx.adobe.com/aem-forms/6/custom-submit-action-form.html refers to the 'FormsHelper API'. 

2) A google search on 'FormsHelper' reveals https://docs.adobe.com/content/docs/en/cq/5-6-1/javadoc/com/day/cq/wcm/foundation/forms/FormsHelper....

3) Searching FormsHelper's package 'com.day.cq.wcm.foundation.form' on http://localhost:4502/system/console/depfinder I've found following dependency:
 

<dependency> <groupId>com.day.cq.wcm</groupId> <artifactId>cq-wcm-foundation</artifactId> <version>5.8.52</version> <scope>provided</scope> </dependency>

4) But on https://repo.adobe.com/nexus/content/repositories/public/com/day/cq/wcm/cq-wcm-foundation/ the latest available maven package is 5.6.4.

So my question is how can I use 'FormsHelper API'?

Thank you,

Urs

1 Accepted Solution

Avatar

Correct answer by
Level 3

I've found the dependencies I need to add to the pom.xml so that FormsHelper class is available:

         <dependency> <groupId>com.adobe.granite</groupId> <artifactId>com.adobe.granite.xssprotection</artifactId> <version>5.5.62</version> <scope>provided</scope> </dependency> <dependency> <groupId>com.day.cq.wcm</groupId> <artifactId>cq-wcm-foundation</artifactId> <version>5.8.52</version> <scope>provided</scope> </dependency>

View solution in original post

0 Replies

Avatar

Correct answer by
Level 3

I've found the dependencies I need to add to the pom.xml so that FormsHelper class is available:

         <dependency> <groupId>com.adobe.granite</groupId> <artifactId>com.adobe.granite.xssprotection</artifactId> <version>5.5.62</version> <scope>provided</scope> </dependency> <dependency> <groupId>com.day.cq.wcm</groupId> <artifactId>cq-wcm-foundation</artifactId> <version>5.8.52</version> <scope>provided</scope> </dependency>