this.resolveNode("Hyphen").presence="hidden" not respected in Render at Server

Avatar

Avatar

GPhillips58

Avatar

GPhillips58

GPhillips58

08-06-2018

We are trying to implement the OUTPUT module to generate pdf's after user fill them out.  I understand most of the differences between render at client and render at server.  What I am stuck on is the template has a text field "Hyphen" which displays a hyphen when there is a value for the 4 digit ZipPlus.  In designer when I run at Client the code works fine, when I run at Server (same as Output) it ignores "this.resolveNode("Hyphen").presence="hidden"".  I put an "xfa.log.message(1, "Hide Hyphen");" right after that line to verify the code is being hit and it is.  The code is on a fragment:

Page1.#subform[1].Addressee_Fragment_V1.AddresseeAddress::initialize

                if (this.resolveNode("Zip2").rawValue!=null)

                {

                 this.resolveNode("Zip2").presence="visible";

                 this.resolveNode("Hyphen").presence="visible";

                 xfa.log.message(1, "Show Hyphen");

                }

                else

                {

                 this.resolveNode("Zip2").presence="hidden";

                 this.resolveNode("Hyphen").presence="hidden";

                 xfa.log.message(1, "Hide Hyphen");

                }

Anyone have any ideas on how to make this work?

View Entire Topic

Avatar

Avatar

GPhillips58

Avatar

GPhillips58

GPhillips58

14-06-2018

Well, this started working all of a sudden, both in Designer and through Output.  Maybe I just needed to close it and take a break.