Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Lazy loaded panels not displaying data when selecting Preview with data option in the form

Avatar

Level 3

hi all, 

 

I have a form bound to xml schema, it contains 3 panels , the second and third panels are fragments which are lazy loaded. When i select preview with data option and select a data file, the data on the panels which are lazy loaded are not displayed. When disabling lazy loading option in the form, the data is visible in those panels. All fields are bound to elements in xml schema. Is there something else that needs to be done to prefill data in lazy loaded panels?

 

kindly let me know.

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

@UserSD I hope it's not a single-page layout, if yes convert to a tabbed layout and enable the below check box 

 

Mayank_Gandhi_0-1707899885543.png

 

View solution in original post

3 Replies

Avatar

Correct answer by
Employee Advisor

@UserSD I hope it's not a single-page layout, if yes convert to a tabbed layout and enable the below check box 

 

Mayank_Gandhi_0-1707899885543.png

 

Avatar

Administrator

@UserSD Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.



Kautuk Sahni

Avatar

Level 3

Thank you @Mayank_Gandhi , and @kautuk_sahni , I have been away for sometime so have not been able to get back here. thank you for your answers.

I can see the data now in the lazy loaded panels. It was some script on the panels which was failing. however i do have a follow up question. Please help me if you can. When i move into a lazy loaded panel, i can see it loaded in the network tab, when i move away from a lazy loaded panel ( Panel structure is "tabs on left")  the lazy loaded panels are unloaded (also from the dom?) . Is there a way to stop this unloading of lazy loaded panels, once it is loaded in the form?

 

thanks again.