Highlighted

error when opening up xdp template in AEM forms osgi

LittleBigFeet

10-02-2017

hi,

 

I have a xdp created in AEM forms designer . I saved the xdp file and uploaded it to AEM forms OSGI through Forms-> forms and Documents-> Create -> files from local storage

 

the file gets uploaded, but when i try to open the xdp template. I get the error which says

 

"

Internal Server Error

Cannot serve request to /content/dam/formsanddocuments/test/PurchaseOrder.xdp/jcr:content in /libs/xfaforms/render/GET.jsp

 

Does anyone know what might be causing this.?

Replies

Highlighted

anshikagarwal

10-02-2017

Hi,

I am afraid it could be failing with this message for multiple reasons. It would be helpful if you can share the error logs / exception trace. Also, which version of AEM are you using.

Thanks,

Anshika

Highlighted
Highlighted

LittleBigFeet

10-02-2017

Ok, here is the entry from the error log. I have attached it in the file.

 

Also something i would like to mention to you. I get this error only when trying to view it on a particular machine ..OSGI author installed on linux box.  I have a OSGI author in a windows box where this XDP is opened and displayed correctly.

Can you suggest what might be happening here.?

Thank you..

Highlighted

LittleBigFeet

10-02-2017

Also I am not sure if this helps...

but when i execute the script highlighted in green it gives me the result highlighted in yellow which says error while loading   shared library..libxmlformagnet.so  ...What does this mean.? Any pointers.?

thank you...

Highlighted

workflowuser

Employee

10-02-2017

Looks like your installation of aem Forms may not be correct.have you installed the 32 bit RPM for Linux. They are mentioned in the documentation and then did you install the aem FD package!

Highlighted

LittleBigFeet

10-02-2017

Hi - Can you point me to the correct documentation for installation and configuration in linux. environments?

Thank you..

Highlighted

LittleBigFeet

17-02-2017

It is a 64 bit  Red Hat Enterprise Linux Server release 7.2 (Maipo)  setup.

Also verified that all  rpms are setup.

the aem fd package is  aemfd-linux-pkg-3.2.50.zip

Only creating an adaptive form using xdp as form model fails in this set.  Is it supported in 64 bit setups.?

 

 

Thank You..