Clicking submit button blocked by validation run

Avatar

Avatar

hariaem

Avatar

hariaem

hariaem

07-02-2018

I am facing an issue during submission of a form. The steps to reproduce are as follows

- create a form with few fields. Make sure the last field has a validation configured through Rules Editor (lets say email format validation)

- on page load, click on submit. Validations fire and the email field has a validation error that it is a required field

- now type the email in the field. Donot tab out yet.

- directly click on the submit button

So what happens is that, the validations fire on the email field and the error disappears . This is good. But the submit click action is gone and now user has to click on submit again. The click on submit button is intercepted and the validation execute, but it doesnt continue with the submission of the form. Is there a workaround for this issue?

Thanks

Accepted Solutions (0)

Answers (3)

Answers (3)

Avatar

Avatar

TundraSteve

Avatar

TundraSteve

TundraSteve

07-02-2018

I've recreated the issue and it's understandable why it's working the way it is but can understand the confusion with clicking twice.  I'll raise it with engineering and see if there is anything we can do

Avatar

Avatar

James_R_Green

Avatar

James_R_Green

James_R_Green

20-02-2018

TundraSteve​ - Did engineering get back to you? I would be interested in a workaround for this as well

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

07-02-2018

Thanks Steve for providing great community input!