Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Checkbox doesn't change value using xpd template binding on adaptative form

Avatar

Level 1

Hi,

 

I am working on Aem forms designer and AEM 6.5, I have created a xdp template on Designer and using it with an adaptive template when I drag a check box from the Data source tab but the value of the checkbox never changes always is 1. I have defined two-state values on Designer.

1 Accepted Solution

Avatar

Correct answer by
Employee

I did a quick test and I can reproduce your issue - btw it not only keeps the value=1 but also after one toggle the checkbox will not change any more. Instead of value we get new properties in the DIV section (checked=true) but the visuals do not show the state. This seems to be a bug and you may want to open a case with Adobe support to see if there is a fix.I run on AEM Forms 6.5.5 - maybe 6.5.6 has that resolved?

The only workaround was to do away with the binding as it then works again - but that may produce issues when you submit the form. Has anyone here seen this before and got a working solution?

Kosta_Prokopiu1_0-1603874463436.png

 

View solution in original post

0 Replies

Avatar

Correct answer by
Employee

I did a quick test and I can reproduce your issue - btw it not only keeps the value=1 but also after one toggle the checkbox will not change any more. Instead of value we get new properties in the DIV section (checked=true) but the visuals do not show the state. This seems to be a bug and you may want to open a case with Adobe support to see if there is a fix.I run on AEM Forms 6.5.5 - maybe 6.5.6 has that resolved?

The only workaround was to do away with the binding as it then works again - but that may produce issues when you submit the form. Has anyone here seen this before and got a working solution?

Kosta_Prokopiu1_0-1603874463436.png

 

Avatar

Level 10

@adolfos35734979  I similar fix will be delivered in the upcoming release of 6.5.7 and 6.4.8.