Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Bad CPU on OSX

Peter127
Level 2
Level 2

Hello,

 

I'm creating a form using AEM Forms (AEM 6.5.5.0 and appropriate forms addon from https://experienceleague.adobe.com/docs/experience-manager-release-information/aem-release-updates/f...).

Everything worked fine - I was able to create a form. The issue is with the Document of Record Preview. When I click "Generate Preview" I'm getting an error and stacktrace shows:

 

09.04.2021 08:33:40.674 *INFO* [127.0.0.1 [1617950020051] GET /content/xfaforms/profiles/default.print.pdf HTTP/1.1] com.adobe.service.ProcessResource Service XMLFormService: Starting native process with command line "/Users/osx.user/projects/forms-poc/aem/.gradle/aem/localInstance/instance/author/crx-quickstart/bedrock/svcnative/XMLFormService/bin/XMLForm.exe" -MyPath /Users/osx.user/projects/forms-poc/aem/.gradle/aem/localInstance/instance/author/crx-quickstart/bedrock/svcnative/XMLFormService -IOR IOR:000000000000002249444C3A636F6D2F61646F62652F736572766963652F4D616E616765723A312E30000000000000010000000000000074000102000000000D3139322E3136382E312E31340000EE2E00000019333037353334393934312F42522D32382F0100000000000000000000000000020000000000000008000000004A41430000000001000000200000000005010001000000010001000100010109000000020501000100010100 -AppServer Adobe-OSGi
09.04.2021 08:33:40.685 *ERROR* [127.0.0.1 [1617950020051] GET /content/xfaforms/profiles/default.print.pdf HTTP/1.1] com.adobe.forms.aem.impl.XFANativeServiceImpl Exception:
java.lang.IllegalStateException: Connection to failed service.
at com.adobe.service.ResourcePooler.allocateResource(ResourcePooler.java:104)
...

Full stacktrace is available here: https://pastebin.com/h9F9QT0j.

 

(Actually I started investigation from Signature step not working - it generates PDF as well and the stacktrace looks the same so I suppose that there is something wrong with PDF generation)

 

In logs, I can see the command XMLForms.exe which is called and failed. When I execute the same command, I'm getting "Bad CPU type in executable". I'm on macOS Catalina.

 

I found similar issues and the closest is this: https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager-forms/adaptive-form-with-x.... The solution was to install every missing library. But I'm getting this nasty bad CPU error instead of missing library error.

 

I'm new to macOS, but I've read that Apple dropped support for 32bit apps in Catalina, and looks like the XMLForms binary (called by XMLForms.exe bash script) is 32bit app:

❯ file XMLForm
XMLForm: Mach-O executable i386

 

I searched the docs (this one: https://experienceleague.adobe.com/docs/experience-manager-65/forms/install-aem-forms/osgi-installat...) and it mentions "UNIX based" OSes (which I believe macOS is? 🤔). But some of the dependencies which should be installed are Linux only - like glibc. MacOS isn't mentioned there explicitly.

 

My question is: is macOS fully supported for forms?

Or maybe the issue is in a totally different place?

 

Thanks in advance 🙂

1 Accepted Solution
PulkitJain
Correct answer by
Employee
Employee

@Peter127 

Please be informed that PDF generation or Mobile forms are not feasible on MAC. That's why we haven't specified any 32-bit libs substitute for MAC os in the official documentation.

View solution in original post

2 Replies
PulkitJain
Correct answer by
Employee
Employee

@Peter127 

Please be informed that PDF generation or Mobile forms are not feasible on MAC. That's why we haven't specified any 32-bit libs substitute for MAC os in the official documentation.

View solution in original post

Peter127
Level 2
Level 2
That's what I was afraid of. Thank you for very quick response!