Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

AEM FORMS - Core component - Invalid form identifier

Avatar

Level 1
<"moved from using the community">

Hi everyone,

I got an issue it seems no-one has already encounter and I am not able to understand why ..

Context :

Instance with AEM SP 6.5.17 and forms (adobe-aemfd-osx-pkg-6.0.968.zip)

 

I got an issue on my form with core components and I tried to create an OOB instance without custom code and I got the same issue.

 

I followed this tutorial : https://experienceleague.adobe.com/en/docs/experience-manager-65/content/forms/adaptive-forms-core-c...

 

I created an OOB instance with service pack 6.5.17. I installed forms package on it, and then deploy the artifact created.

The artifact was created like this :

mvn -B org.apache.maven.plugins:maven-archetype-plugin:3.2.1:generate \
-D archetypeGroupId=com.adobe.aem \
-D archetypeArtifactId=aem-project-archetype \
-D archetypeVersion=48 \
-D appTitle="My Form" \
-D appId="myform" \
-D groupId="com.myform" \
-D includeFormsenrollment="y" \
-D aemVersion="6.5.17"

 

I deploy it on my new instance, I create a form with the template "Blank with core component" and when I click on "preview as html" on my form, I got this issue :

 

07.05.2024 16:07:39.074 *ERROR* [qtp128015682-1778] com.adobe.aem.forms.af.rest.internal.servlets.AdaptiveFormModelServlet Invalid request during form submission

com.adobe.aem.forms.af.rest.exception.InvalidRequestException: Invalid form identifier

 

I didn't try to submit, just display the form. If I put some components in the form and try to submit it, I got a NPE.

 

Could someone can help me on this subject ? I d'ont understand what i'm doing wrong.

 

Thansk a lot,

 

Emilie

1 Reply

Avatar

Employee

@rey91 If you're using the local cloud-ready SDK to preview the form, you'll need to restart it. The log message appears to be incorrect, but we'll address this in the next release.