AEM 6.2 - Managing Translation Projects. Process of "Create and Translate" - Target Languages

julianh55493871

15-12-2016

Hello guys!

I have to do a work-around in my current project, nowadays we are using the Touch UI process called "Create and Translate"  Link: https://docs.adobe.com/docs/en/aem/6-2/administer/sites/translation/tc-manage.html#par_title_4

We have our assets structured in /content/dam/project/assets

And inside assets folder, we have the languages that we are supporting

1. /content/dam/project/assets/en

2. /content/dam/project/assets/fr

3. /content/dam/project/assets/es

4. /content/dam/project/assets/ru

5. /content/dam/project/assets/ja

We are only using the process OOTB in AEM 6.2 to copy the asset and paste to each of the target languages.  According to the documentation, after select the asset, select the "Create Structure Only" and select the target languages. 

This is the quote:

  • Use the Languages drop-down to select a language copy for which you want to translate. Select additional languages as required. Languages that appear in the list correspond with the language roots that you have created.

However, in the Target Languages I am seeing all the languages supported by AEM and not the language root for each of our locales. (See image attached).

My question is how I can make that the Target Languages for that OOTB workflow only shows the languages supported by our project?

Let me know if you may need more information in order to help with this

Thanks and regards

Accepted Solutions (1)

Accepted Solutions (1)

Ankur_Sial

10-01-2017

Hi Julian,

Please review the JSP[0] used for loading the languages. This would ideally be ideally be overloaded in /apps

Hope that helps,

Ankur

[0] dam/gui/components/admin/datasources/assetlanguagecopy/translatelanguages/translatelanguages.jsp

Answers (6)

Answers (6)

Ankur_Sial

10-01-2017

Hi Julian,

It looks like the new JSP got compiled (for the first time) post your actions. Till then, the older one was getting served.

Thanks.

julianh55493871

10-01-2017

Thank very much Ankur, It was very helpful, I re-save again that JSP file and now is working correctly, maybe was because the JSP was not compiled correctly at the first time, I do not know, is my guess.

Let me know your thoughts on this just to be sure.

Thanks!

julianh55493871

09-01-2017

Hello Ankur sial, I just validated and for "Create new project" and "Add to existing project" I am also seeing all the target languages.  Can you please provide me instructions about how to validate if an custom overlay exist in the environment for this AEM 6.2 instance?, I know that in our project we migrate to AEM 6.2 from AEM 6.1, so this can be the cause.  Also, do you know what service o servlet are retrieving the target languages in the dropdownlist ?

Thank you very much!

Ankur_Sial

08-01-2017

Hi Julian,

Could you please verify if the same behaviour exists for "Create new project" and "Add to existing project" as well.

Also, as we used to list all langauges in AEM 6.1, a custom overlay (from AEM 6.1) could be the reason for this behaviour. Please reveiw.

Thanks

julianh55493871

06-01-2017

Hello Ankur sial, thank you for your answer.  I verified and validated that the languages root exists in my AEM instance according to this guide:

https://docs.adobe.com/docs/en/aem/6-2/administer/sites/translation/tc-prep.html#par_title

I have the languages already created with the name property in ISO format (en, fr, es, etc) however, anyway I am seeing all languages in the target languages and not only the language which root language exist.

I wonder if I need to install a hotfix or a service pack ? 

Thanks

Ankur_Sial

02-01-2017

Hi Julian,

AEM 6.2 lists (only) the languages whose langauge root exist. Also, it would show the langauges in the dropdown whose langauge copy does not exist.