Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

The XML page cannot be displayed

nicolletta
Level 2
Level 2

Hello,

 

I have this error on Adobe Campaign when I'm trying to visualize workflow tab on a campaign  in “Targeting and workflows” tabs.

I’ve try figuring out but I cannot see where the error source is.

 

 

 have two platforms of Adobe Campaign, testing and production and in production when I try to go to this url: https://xxxxxxxxxxx-prod1.campaign.adobe.com/xtk/xsl/dhtml/targetPreview.xsl I get « Forbidden. You don't have permission to access /xtk/xsl/dhtml/targetPreview.xsl on this server”.

In testing environement I don’t have this error when I try to acces the same page.

 

 

Thank you for your suggestions.

Best regards,

 

Nicoleta

1 Accepted Solution
Amit_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi Nicoleta,

 it looks like this file is not allowed from the apache server. please hack your firewall settings are apache config for prod for .xsl type files?

Regards,

Amit

View solution in original post

15 Replies
florentlb
Level 10
Level 10

Hello Nicoleta,

 

It looks like the system is not able to read this file on the server.

  • If you are using a hosted instance, you can create a ticket to Campaign support to request that access.
    Support portal is available here: https://support.neolane.net.
  • If you are using an on-prem instance, you can check that the 'neolane' user has access to this file on the server.

Thanks,

Florent

nicolletta
Level 2
Level 2

Hello Fleltuerto,

Thank you for your answer, I’ll ask the support to check the rights for neolane user. Should they verify the rights for the user that is connected when the error occurs?

Best regards.

Nicoleta

florentlb
Level 10
Level 10

Hi Nicoleta,

Was your issue finally solved by creating the ticket to support?

Florent.

nicolletta
Level 2
Level 2

Hello Florent,

I've created the ticket to support but my issue is not solved yet.

Best regards,

Nicoleta

nicolletta
Level 2
Level 2

Hello Florent,

The only answer I’ve got from support is that they “checked file permissions on both instances and have found them to be identical”. They cannot identify the problem and they suggest me to update to last build. They thing that the problem is coming from client customization. Is this the only solution?

Thank you.

Best regards,

Nicoleta

florentlb
Level 10
Level 10

Hello Nicoleta,

I suggest you follow support recommendations, while I'll try to find some more insight about it. We had a new build released earlier this week (8765).

Are there any configuration differences between your testing and production instances? Like specific customization or different JS scripts in the workflow? These are common causes for this display issue.

 

Florent.

nicolletta
Level 2
Level 2

Florent,

Thank you for your suggestions also. I’ll ask my client if they want to upgrade.

Is there an easy way to compare two Adobe Campaign instances? Is there a way to easily extract all the code installed on the platform? I wasn’t there where the project stared and I can see that I can extract code object by object.

 

Thank you.

Best regards,

Nicoleta

florentlb
Level 10
Level 10

Hi Nicoleta,

I don't know any easy way of doing this. I will double check and let you know if I have more informaiton to share about this.

Florent.

Amit_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi Nicoleta,

 it looks like this file is not allowed from the apache server. please hack your firewall settings are apache config for prod for .xsl type files?

Regards,

Amit

View solution in original post

nicolletta
Level 2
Level 2

Amit_Kumar wrote...

Hi Nicoleta,

 it looks like this file is not allowed from the apache server. please hack your firewall settings are apache config for prod for .xsl type files?

Regards,

Amit

 

Hello Amit,

 

Thank you for your answer.

You are saying that I should look in apache config file to see if .xsl is well configurated?

I also should ask Adobe support to check firewall settings for .xls, as all the platform are hosted at Adobe?    

Best regards,

Nicoleta

Amit_Kumar
Community Advisor
Community Advisor

You got it right. Do let me know if that worked. sorry for the typo earlier.

florentlb
Level 10
Level 10

Hi Nicoleta,

Did you manage to resolve your issue with Amit's answer?

Florent

nicolletta
Level 2
Level 2

Hello Florent,

I'm still working with support on this. As soon as I'll have a solution I'll post it. 

Regards,

Nicoleta

nicolletta
Level 2
Level 2

Hello Florent,

After opening three support tickets, support applied yesterday a patch on my platform. For now I don’t have more details about the applied patch. It is working fine now. Adobe Campaign Support team said on 14/02/2017: “The permanent fix has been added to the latest build that is currently being evaluated by Adobe Quality Assurance team right now. Once verified and the build is release, you would need to upgrade your environment to get the permanent fix.”


Best regards,
Nicoleta

nicolletta
Level 2
Level 2

Hello Amit,

 

Support confirmed that the problem was in apache configuration file: 

"The configuration file for the apache need to be change to give proper file permission to a specific file path (the one that contains the xsl used within that workflow). Unfortunately, since this patch/configuration change is done at the server level, we do not have access to it. I only know the configuration change was needed to have access to the following folder: /usr/local/neolane/nl6/datakit/xtk/fra/xsl"

Thank you.

Best regards,

Nicoleta