Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error while publishing profile schema

rahulg1930481
Level 4
Level 4

I re-drafted my profile schema and tried to re-publish the profile schema. While preparing I am getting the following error message.

  • SOP-330011 Error while executing the method 'GenerateCusResource' of service 'xtk:builder'.
  • XML-110018 Error while parsing XML string ''
  • (1:1) : Invalid document structure
  • 16384
  • Cannot find the '' resource in the '' version API.
  • Generating 'Profiles (profile)' resource.

I even tried deleting the drafted profile schema and extend it again. But profile is not appearing in the list of available schemas available to be extended. In the workflow logs I started to see the error message "Cannot find the 'profile' resource in the 'head' version API.".

 
ACS profile Schema
1 Accepted Solution
SatheeskannaK
Correct answer by
Community Advisor
Community Advisor

Hi @rahulg1930481,

 

Looks like your schema went to inconsistent state because of recent re-draft and publishing activities.  If you're getting option to check the "Do not publish latest modifications" or "do not synchronize" on the profile resource check that and try publishing again. Try to bring the publishing activity successful before dealing the problem with profile resource. Also, if you could explain what have you done exactly that caused this issue will help to provide better suggestions.

 

Thanks, Sathees

View solution in original post

3 Replies
SatheeskannaK
Correct answer by
Community Advisor
Community Advisor

Hi @rahulg1930481,

 

Looks like your schema went to inconsistent state because of recent re-draft and publishing activities.  If you're getting option to check the "Do not publish latest modifications" or "do not synchronize" on the profile resource check that and try publishing again. Try to bring the publishing activity successful before dealing the problem with profile resource. Also, if you could explain what have you done exactly that caused this issue will help to provide better suggestions.

 

Thanks, Sathees

View solution in original post

rahulg1930481
Level 4
Level 4
I re-drafted the profile schema and added some new fields to it. After when I tried to publish the schema, I started getting this error.
sumitp11734535
Level 2
Level 2
Hi Rahul, you can try to publish after select do not synchronize all the schemas, then try gain your changes. May it's works.