Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Update data error

Avatar

Level 2

Hello,

I'm working on a workflow where I have to upload->update the data in a table then send a delivery but it's giving me the error below.

Ofattah_0-1639479959944.png

 

Do you have an idea please where the problem is?

 

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 5

I would start with verifying that RecProcState for the inbound population is all populated with the correct data type and values before the expression is evaluated. Essentially data in that field for a specific recipient is not letting the expression be evaluated. With these type of errors you have break down the data structure for each activity to figure where things have gone wrong.

View solution in original post

1 Reply

Avatar

Correct answer by
Level 5

I would start with verifying that RecProcState for the inbound population is all populated with the correct data type and values before the expression is evaluated. Essentially data in that field for a specific recipient is not letting the expression be evaluated. With these type of errors you have break down the data structure for each activity to figure where things have gone wrong.

Avatar

Level 2

Thank you for you response @dloyd 

What do you mean by "RecProcState" please? is it a column in the uploaded data? 

 

Thanks

Avatar

Level 5

In the error logs this statement is failing to be evaluated "WHERE W.iRecProcState >= -1".

the W.i is just SQL stuff. RecProcState is either a custom field on some custom data schema, or it is a custom expression in an enrichment or other activity within the workflow.

 

Start by checking the update activity, this is field listed there? If not in the update activity check other activities in the workflow.

Avatar

Level 2

@dloyd 

Thank you again,

 

There are only two activities : Upload and update and there's no such field in both activities. But before that error I have this one : invalid user.table.column... which is not normal because I have always used this table

Ofattah_0-1639492969221.png

 

Thanks

 

Avatar

Level 5

Was anything copied over from another workflow? The temp table of the workflow thinks that field is present. If you are 110% that field is not in existing activity (or the advance JS in activities), I would re-create that workflow from scratch in a new workflow canvas. Don't copy and past anything.

 

Perhaps look up up the table your are writing to in data schemas and make sure that field is not present. Maybe someone edited the actual table structure.

Avatar

Administrator

Hi @Ofattah,

Was the given solution helpful to resolve your query or do you still need more help here? Do let us know.

Thanks!

Avatar

Level 2

Hi @Sukrity_Wadhwa 

 

Thank you all for your help, the solution was helpful

 

Best regards