Expand my Community achievements bar.

The 5th edition of the Campaign Community Lens newsletter is out now!

Tracking / Redirection Server Configuration - RHEL 8

Avatar

Level 1

Hi all,

 

I'm installing a test Campaign Classic Server V7 build 9349 on a single RHEL 8 machine.

 

Everything is correctly installed and working, the deployment wizard has been executed and the tracking server validation was succesful, and the machine restarted.

 

The tracked links inside the deliveries have the correct form (http://<server>:8080/r/?id=hfa0,1e82,424) however they lead to a 404, just as the test URL : http://<server>:8080/r/test 

 

The Campaign server runs the following processes (xxx is the instance name):

Tracking is set to autostart = "true" in serverConf.xml, but I don't see it in the list of processes.

 

My questions are :

  • Is the redirection handled by Apache or Tomcat ?
  • What did I miss in the configuration ?

Thanks a lot for your help.

 

Igor

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

9 Replies

Avatar

Community Advisor

Hello @IgorZk ,
tracking server uses web@default and trackinglogd@default 

have you used option:
Add support for tracking in an existing instance 

in deployment wizard?

Check documentation:
https://experienceleague.adobe.com/docs/campaign-classic/using/sending-messages/tracking-messages/ab...
can you post instance configuration/ deployment wizard
Marcel

Hi @Marcel_Szimonisz ,

 

Yes I selected "Add support for tracking in an existing instance " and validated successfully (see screenshots below).

 

The third screen-shot is the modified section of config-<instance>.xml after the tracking validation.

 

Do you need anything else ?

 

Thanks a lot for your help !

 

tracking-1.pngtracking-2.pngtracking-3.png

Avatar

Community Advisor

Hello @IgorZk ,

Maybe even it says in docu that you do not need web server like apache i guess you need to have it. Can you add web server by following the documentation?

I have also only installed AC without apache on my sandbox..i will try to make it work later and let you know.

Marcel

Avatar

Level 1

Hi @Marcel_Szimonisz ,

Apache was already installed on the server, along with the firewall.

 

Here were the executed commands :

 

// Install Apache web server, activate it and open 80 and 8080 for Tomcat, 5432 for PostgreSQL

sudo dnf install httpd
sudo systemctl enable httpd
sudo systemctl start httpd
sudo dnf install firewalld
sudo systemctl unmask firewalld
sudo systemctl start firewalld
sudo systemctl enable firewalld
sudo firewall-cmd --zone=public --permanent --add-service=http
sudo firewall-cmd --zone=public --permanent --add-service=https
sudo firewall-cmd --zone=public --permanent --add-service=smtp
sudo firewall-cmd --zone=public --permanent --add-port 8080/tcp
sudo firewall-cmd --zone=public --permanent --add-port 8080/udp
sudo firewall-cmd --zone=public --permanent --add-port 5432/tcp
sudo firewall-cmd --zone=public --permanent --add-port 5432/udp
sudo firewall-cmd --reload

Avatar

Level 1

Oops I wanted to correct my post, not to accept it as an answer ! How can I revert this ?

Avatar

Administrator

There you go. I have reverted it for you. 

Best, 

Sukrity

Avatar

Level 1

Hi all,

 

I saw that someone already had nearly the same issue : https://experienceleaguecommunities.adobe.com/t5/adobe-campaign-classic-questions/set-up-tracking-re... , and it was apparently resolved by setting a tracking password and doing the tracking registration again.

 

So I tried to set up a tracking password on the instance by running a nlserver config -trackingpassword, but I get the error below.

 

[neolane@xxxxx bin]$ ./nlserver config -trackingpassword
21:01:59 > Application server for Adobe Campaign Classic (7.2.2 build 9349@e319b6d of 02/28/2022)
Enter the current password.
Password:
Enter the new password.
Password:
21:02:04 >>> RED-520005 Wrong configuration of remote redirection server. Please check the server configuration. (iRc=16384)
21:02:04 >>> XSV-350029 Unable to change password for account 'default' with identification mode 'tracking'. (iRc=16384)

 

Thanks for your help

 

Regards,

Igor

Avatar

Level 1

Oh, when specifying the right instance, the tracking password is ok :

 

[neolane@xxxxx bin]$ ./nlserver config -instance:izt -trackingpassword
21:13:51 > Application server for Adobe Campaign Classic (7.2.2 build 9349@e319b6d of 02/28/2022)
Enter the current password.
Password:
Enter the new password.
Password:
21:14:04 > Password successfully changed for account 'izt' (authentication mode 'tracking').

 

I validated again the tracking configuration with the new password and restarted the server, but still the same 404 errors.

 

CC @adithyacs86 your help would be appreciated on this, thanks a lot !

 

Regards,

Igor

Avatar

Level 1

Hi all,

 

According to the documentation (https://experienceleague.adobe.com/docs/campaign-classic/using/installing-campaign-classic/architect... ), it is stated that redirection is handled by the webmdl module.

 

"To guarantee highest availability, this process is fully independent from the database: the other server processes communicate with it using SOAP calls (HTTP, HTTP(S) and XML) only. Technically, this functionality is implemented in an extension module of a HTTP server (ISAPI extension in IIS, or a DSO Apache module, etc.) and is available in Windows only."

 

Does that really mean that this webmdl module is not usable in a Linux environnent ?

 

Regards,

Igor

page footer