Expand my Community achievements bar.

We are excited to introduce our latest innovation to enhance the Adobe Campaign user experience — the Adobe Campaign v8 Web User Interface!
SOLVED

Build Upgrade Previos (PRE) - Release version 7.3.3 build 9359 - 'nms:delivery' and type 'xtk:form' is in conflict with the new version

Avatar

Level 5

Hi there,

I'm working on the version upgrade and there are several errors to resolve. This is the first time I'm working with this type of error.

One of the errors is "The document with identifier 'nms:delivery' and type 'xtk:form' is in conflict with the new version."

How do I solve this problem?

Regards

1 Accepted Solution

Avatar

Correct answer by
Level 7

Hello @acc_acs ,

Please find the step-by-step guide on how to resolve conflicts in the nms:delivery input form.

 

1. Identify the Input Form: First, go to the location which I mentioned earlier. 

Administration -> Configuration -> Package Management -> Edit conflict.  Check the name on input form where you have conflict. 

I believe you have issue in nms:delivery. 

2. Navigate to Input Forms: Go to the 

Administration -> Configuration ->  Input Forms.

3. Locate and Open the Form: Search for the 'nms:delivery' form and open it.

4. Create a Backup: Copy the code of this input form into a notepad and make sure to create a backup.

5. Identify the Conflict: In another notepad file, paste the copied code and search for the conflict text. You will find the line where the conflict exists.

Let's say you have a conflict on the following line:

 

Old Line:
<value desc="Email channel" img="nms:email.png" label="Email" name="mail" value="0"/>

New line:

<value desc="Email code" label="Email code" name="mailCode" value="0"/>

Normally conflict is mentioned on this line.

6. Resolution Options:  Now, you have two options. You can either keep both lines and remove the conflict text from the XML, or you can choose one line to keep, delete the other line, and remove the conflict text.

7. Ensure Conflict-Free Code: Make sure that all conflict text is removed, and the code is conflict-free.

8. Copy the code: Copy the conflict free code back in Adobe campaign input form. 

 

8. Return to Package Management: Go back to the Administration section, then to Configuration, and click on Package Management. Select the 'Edit conflict' option.

9. Resolve the Conflict: Choose the 'nms:delivery' record, right-click, and select the 'Resolve conflict' option.

10. Repeat as Needed: You can repeat these steps for any other conflicts you encounter and resolve them in the same manner.

11. Reinstall the Application: Finally, attempt to reinstall the application after all conflicts have been successfully resolved.

 

I hope these steps prove helpful in resolving the conflicts you're facing with the nms:delivery input form. 

 

Best regards,

Parvesh

View solution in original post

6 Replies

Avatar

Level 2

Hi!

What I know about this is:
"indicates that there is a conflict with a document called 'nms:delivery' of type 'xtk:form' when trying to update or make a change in Adobe Campaign Classic. This type of error usually occurs when there is an inconsistency between the existing document version and the version expected by the operation you are trying to perform."


But I don't know how to solve it. I hope this helps at least as a start to arriving at your solution.

 

Regards

Avatar

Level 7

Hello @acc_acs

 

To solve the error "The document with identifier 'nms:delivery' and type 'xtk:form' is in conflict with the new version.", you can try the following steps:

Identify the conflict: Can you please check there is no active conflict in your env. now.  You can go the below location to check it. Parvesh_Parmar_0-1695043190720.png

 

If you found any conflict please resolve it first.

Resolve the conflict. Once you have identified the conflict, you need to resolve it. There are two ways to resolve a conflict:

  • Overwrite the document in the current version with the document in the new version. This is the simplest way to resolve a conflict, but it can lead to data loss if the document in the current version has been modified since the new version was created.
  • Modify the document in the new version to resolve the conflict. This is the more complex way to resolve a conflict, but it allows you to preserve any changes that have been made to the document in the current version.

Upgrade the environment. Once you have resolved the conflict, you can upgrade the environment to the new version.

I hope this information is helpful. Please let me know if you have any other questions.

Kr,

Parvesh

Avatar

Level 5

Hi @Parvesh_Parmar ,

Thanks for ,your response and for your time! But I've never done this and I'm still a little confused how do I solve this.

In this case, which object would it be for an overwrite or a modify?

In this specific case, would it be working based on the respective "xtk:form" as indicated in the error or based on the version in the "/Administration/Configuration/Package management/Edit conflicts/" folder?

If you are going to work on this version that is in the "Edit conflicts" folder, there are several conflict references ("_confict" /cus/new/org).

And I would like some advice on some of the steps I would have to take to resolve this error.

Regards

 

Avatar

Correct answer by
Level 7

Hello @acc_acs ,

Please find the step-by-step guide on how to resolve conflicts in the nms:delivery input form.

 

1. Identify the Input Form: First, go to the location which I mentioned earlier. 

Administration -> Configuration -> Package Management -> Edit conflict.  Check the name on input form where you have conflict. 

I believe you have issue in nms:delivery. 

2. Navigate to Input Forms: Go to the 

Administration -> Configuration ->  Input Forms.

3. Locate and Open the Form: Search for the 'nms:delivery' form and open it.

4. Create a Backup: Copy the code of this input form into a notepad and make sure to create a backup.

5. Identify the Conflict: In another notepad file, paste the copied code and search for the conflict text. You will find the line where the conflict exists.

Let's say you have a conflict on the following line:

 

Old Line:
<value desc="Email channel" img="nms:email.png" label="Email" name="mail" value="0"/>

New line:

<value desc="Email code" label="Email code" name="mailCode" value="0"/>

Normally conflict is mentioned on this line.

6. Resolution Options:  Now, you have two options. You can either keep both lines and remove the conflict text from the XML, or you can choose one line to keep, delete the other line, and remove the conflict text.

7. Ensure Conflict-Free Code: Make sure that all conflict text is removed, and the code is conflict-free.

8. Copy the code: Copy the conflict free code back in Adobe campaign input form. 

 

8. Return to Package Management: Go back to the Administration section, then to Configuration, and click on Package Management. Select the 'Edit conflict' option.

9. Resolve the Conflict: Choose the 'nms:delivery' record, right-click, and select the 'Resolve conflict' option.

10. Repeat as Needed: You can repeat these steps for any other conflicts you encounter and resolve them in the same manner.

11. Reinstall the Application: Finally, attempt to reinstall the application after all conflicts have been successfully resolved.

 

I hope these steps prove helpful in resolving the conflicts you're facing with the nms:delivery input form. 

 

Best regards,

Parvesh

Avatar

Level 5

Hi @Parvesh_Parmar 

Thank you for your answer. I will try to follow the suggested steps.
And this week I respond here to tell you how the result was.
Thank you once again

Regards

Avatar

Level 5

Hi @Parvesh_Parmar 

 

It seems like everything went well. I asked them to run the postupgrade, I checked the logs in /usr/local/neolane/nl6/var/[instance]/postupgrade/.
And the logs stopped showing error messages. If so, then it looks like it worked.

 

Regards