Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Analytics Champion Program are open!
SOLVED

UTM on QR code not working

Avatar

Level 2

Hi,

 

I have a UTM on a QR code, however, no data is coming through for it. We have tested it, so should be showing our traffic at least.

Does anyone know of any problems with QR codes and UTMs please?

 

Another dept set one up and their data is showing, but they have used formart of marketing = true, campaign, code, medium and term.

Where as I've used source, medium and campaign.

 

Any help would be appreciated.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor and Adobe Champion

Hi @jesscoleman! Do you share an implementation with the other department? If so, the marketing=true parameter might be necessary to trigger the collection of your source, medium, and campaign. Also, they have a different set of parameters so AA might be set up to capture those, not the parameters you've set.

If not, there is also a possibility that campaign tracking in your Adobe Analytics instance is not set up. Here is some guidance on how to get started on that: https://experienceleague.adobe.com/docs/analytics/implementation/use-cases/campaign-tracking.html?la...

View solution in original post

5 Replies

Avatar

Correct answer by
Community Advisor and Adobe Champion

Hi @jesscoleman! Do you share an implementation with the other department? If so, the marketing=true parameter might be necessary to trigger the collection of your source, medium, and campaign. Also, they have a different set of parameters so AA might be set up to capture those, not the parameters you've set.

If not, there is also a possibility that campaign tracking in your Adobe Analytics instance is not set up. Here is some guidance on how to get started on that: https://experienceleague.adobe.com/docs/analytics/implementation/use-cases/campaign-tracking.html?la...

Avatar

Community Advisor

Did you tested the UTM parameters in the URL after you scanned the QR Code? If yes, Are you seeing the expected UTM params in there?

Avatar

Community Advisor

Echoing the others here... understanding how your implementation processes the UTMs (knowing the rules and how the values are processed is important to understanding what to expect so that you can test properly).

 

A QR code is just a way open a URL... so the QR portion should have no impact on the tracking...  the resulting URL should act the same whether opened directly or through the QR code.

 

The other possibility is checking that the URL that was coded into the QR code is a properly formatted URL.... there should be one ? and all the parameters should be separated by & (if the url has multiple ? this isn't a proper URL and will break tracking)... if there is a # in the URL, the # must come after the url params:

 

www.site.com#hashvalue?utm_source=something&utm_medium=othervalue - will not work - the browser cannot interpret the query strings, it just thinks they are part of the hash

 

www.site.com?utm_source=something&utm_medium=othervalue#hashvalue - this is the correct format that will allow the browser to properly read the parameters and the hashvalue correctly

Avatar

Level 2

Hi all, thank you for your replies.
We think we have worked it out. The UTM not working was pointing at a URL on the site that is effectively a redirect. So it looks like the UTM was being stripped out as part of the redirect.