Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unspecified Data in Campaign Report

Vyom
Level 2
Level 2

I am seeing "Unspecified" line item data in huge numbers. Could this be because of any existing untagged campaigns?

1 Accepted Solution
Gigazelle
Correct answer by
Employee
Employee

The bottom line is that whatever metrics you're using, at the time at event was fired the campaign variable did not have a persisting value. This could be due to the visitor not arriving via a campaign (such as direct traffic), or it could be improper campaign tagging.

If you suspect a campaign is improperly tagged, I'd recommend pretending to be a visitor, click through the campaign, and check the debugger to make sure the campaign variable is triggered on the following page.

View solution in original post

0 Replies
shekhardhiman
Employee
Employee

Hi there,

Thanks for reaching out to Adobe Community.

Please go though the below article and see if it helps:

https://helpx.adobe.com/analytics/kb/none-unspecified-and-unknown.html

Thanks!

Vyom
Level 2
Level 2

I read that link. None of the explanation in that link helps.

Vyom
Level 2
Level 2

This could be the answer. Please confirm!

For example:

Site total revenue= $1000 for 1 day

Campaign total revenue= $1000 for 1 day

                                   - $900 from paid Campaign alone and $100 from the Non paid campaign 

                                  - Adobe Analytics reports the non-campaign data here while we break down other metrics which has got data (It can be props /                                         eVars / events). In this case we are breaking events  (Revenue and Order)

In the Campaign report, the “Unspecified” data is a an addition of the other revenue data to arrive at the site’s entire revenue in the bottom table. Adobe Analytics do this mainly to break-down other metrics which has got the value (Orders and Revenue) but “NO CAMPAIGN DATA." 

Vyom
Level 2
Level 2

Or is the answer for "Unspecified" in Campaign report = IMPROPER Campaign tagging? I tried breaking down by visits - still I could see "Unspecified" contrary to what I explained above - breaking down by custom variables / custom metrics.

Please help on this!

Gigazelle
Correct answer by
Employee
Employee

The bottom line is that whatever metrics you're using, at the time at event was fired the campaign variable did not have a persisting value. This could be due to the visitor not arriving via a campaign (such as direct traffic), or it could be improper campaign tagging.

If you suspect a campaign is improperly tagged, I'd recommend pretending to be a visitor, click through the campaign, and check the debugger to make sure the campaign variable is triggered on the following page.