Expand my Community achievements bar.

Announcement: Calling all learners and mentors! Applications are now open for the Adobe Analytics 2024 Mentorship Program! Come learn from the best to prepare for an official certification in Adobe Analytics.
SOLVED

Old Classifications Still Appearing

Avatar

Level 2

I recently classified and organised all of my product categories across 14 production suites. In most cases, the SAINT upload was to overwrite some old classifications to ensure that the experience was identical in each production suite.

The issue I'm having is that despite uploading these new classifications, the old classifications are still appear under certain categories.

Here's an example to explain what I'm experiencing:

Under my Electronics Category, I wanted to separate specifically into Tablets, MP3 Players and Phones so I created a classification "Electronics Category". Under this category, I then defined each product as either a Tablet, MP3 Player or Phone.

After I uploaded the file and having waited a few days for the SAINT classification file to upload fully, I find that when I go into the Electronics Category, I see other product types such as Digital Services which should not be present.

I did a browser export of my file and found that in some cases, Digital Services were appearing under the Electronics category but it looks like this was due to previous uploads (I expected these to be overwritten). So I amended the file retrieved from the browser export, uploaded the file a few days ago and today, I'm still seeing Digital Services appear under this category.

Does anyone have an idea what I could be doing wrong? I've triple checked the files I've uploaded and all seems fine. Any help would be greatly appreciated

Prior to uploading the SAINT files, I removed all classifications and rebuilt them so they would all have the same hierarchy in each production suite.

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi, 

When you upload the classification again, the whole process would re-initiate. You should give at least 24 hours for the classification to reflect on the reports.

Having said that, could you send me a direct message with your company name, report suite ID on which the classification is used and filename so I could check whats going on at the backend?

Thanks!

TM

View solution in original post

4 Replies

Avatar

Level 10

Hi Stephan,

Thanks for reaching out to Adobe Community.

Sometimes when creating or modifying classifications, your changes do not take effect. This article lists all known reasons why classification data is not reflected in reporting.

https://helpx.adobe.com/analytics/kb/troubleshooting-classifications-altering-data.html

Also Check this link to avoid common upload errors https://marketing.adobe.com/resources/help/kb/en_US/analytics/kb/common-saint-upload-issues.html

Thanks!

Avatar

Level 2

Thank you, I'll go through my file again and double check everything but from the list, there is not much standing out right now.

Avatar

Level 2

Just an update on this. So as some values were appearing in the incorrect categories, I went to the affected values in one marketplace and input ~empty~ to remove them. After about 7 hours there was no effect. Then, I said it would be best to remove everything and then re-upload the classifications correctly.

When I use browser export to generate the classifications file, everything on there looks fine but it is not reflected in SiteCatalyst itself. Do I need to allow more time for this data to populate?

Thanks.

Avatar

Correct answer by
Employee

Hi, 

When you upload the classification again, the whole process would re-initiate. You should give at least 24 hours for the classification to reflect on the reports.

Having said that, could you send me a direct message with your company name, report suite ID on which the classification is used and filename so I could check whats going on at the backend?

Thanks!

TM