Expand my Community achievements bar.

Announcement: Calling all learners and mentors! Applications are now open for the Adobe Analytics 2024 Mentorship Program! Come learn from the best to prepare for an official certification in Adobe Analytics.
SOLVED

Launch: rule is not fired if we change the website language

Avatar

Community Advisor

Dear All,

We found the required selector(HTML element) and rule if fired in English version but when we change to German language then rule is not fired and selector is same.

We are unable to understand why its happened. Could you please help to guide. Thank you.

Note: Links is coming from salesforce.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

You can also try to run _satellite.setDebug(true) in the developer console and observe any error the non-matching conditions stopped rules triggering.

View solution in original post

3 Replies

Avatar

Community Advisor

Without knowing how your website or the Salesforce links are coded, it's hard to say what's going wrong.

My first guess would be that the selector that you're using depends on English words. So when you change to the German site, those words are now in German, and so you're selector doesn't work any more.

Avatar

Level 4

Hi Kamlesh,

 

Please check if the launch library is called for both languages.

and also check if the selector is same using chrome inspect (https://amasty.com/knowledge-base/product-labels-find-css-selector.html)

Avatar

Correct answer by
Community Advisor

You can also try to run _satellite.setDebug(true) in the developer console and observe any error the non-matching conditions stopped rules triggering.