Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Adobe Analytics Coffee Break: On Monday, January 30 at 10am PT, the NOAM User Group led by Jennifer Dungan and Jeff Bloomer will be joining us to answer your Analytics related questions. To register and for more information, follow the link to the right.
SOLVED

Failure in SAINT import - Import Status : Relation 0 is not currently set up to import data

Avatar

Level 1

Hello Everyone,

I'm fairy new in using the Adobe Classification API and i hope that someone can help me.

Situation (these are the steps i follow before getting an error) :

  • Classification.CreateImport method.
    • Return message : JobId: xxxxxx
  • Classification.PopulateImport method.
    • Return message : true
  • Classification.CommitImport method.
    • Return message : true

Just to be sure i also execute the method Classification.GetStatus which returns the message "In Progress". But and the end of all this i receive an email with an Import status error saying "Relation 0 is not currently set up to import data".

I was wondering if any has already encountered this type of issue ?

Thank you in advance.

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi,

This error is returned when the API call is using incompatible/invalid element. AN element with incorrect case is also considered invalid. Ex: For the SAINT server, 'product' is valid, however, 'Product' is invalid.

Please check for the valid elements to be used via the 'getCompatibilityElements' method and update your call. This should help resolve the issue.

In case the issue persists, it'd require further investigation and I'd request you to create a support ticket by contacting Customer Care for the same.

View solution in original post

0 Replies

Avatar

Correct answer by
Employee

Hi,

This error is returned when the API call is using incompatible/invalid element. AN element with incorrect case is also considered invalid. Ex: For the SAINT server, 'product' is valid, however, 'Product' is invalid.

Please check for the valid elements to be used via the 'getCompatibilityElements' method and update your call. This should help resolve the issue.

In case the issue persists, it'd require further investigation and I'd request you to create a support ticket by contacting Customer Care for the same.