Expand my Community achievements bar.

The Analytics Community Lens news letter for February 2024 is now here! Come see upcoming events and what's been going on in the community!

Error with Classification Rule builder when trying to assign different levels for one value

Avatar

Level 1

I have a classification rule built as below. I am able to validate this rule however I am not able to activate this rule wit multiple classifications level

 

TARUNKUMAR2_0-1695935354485.png

 

Error message comes like this:

Untitled.jpg

 

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

15 Replies

Avatar

Level 9

A couple of basic things to verify:

1. Check to see the right report suite and variable is selected.

RobertBlakeley_0-1695936603732.png

 

2. Check to see the classification is set up on the variable in the right report suite in the report suite manager. Admin > Report Suites > Traffic or Conversion classifications.

RobertBlakeley_1-1695936875668.png

 

Avatar

Level 1

Yes, both of those settings are correct. The rule works if I remove either of the levels i.e setting alone on "Bucket" or "Section" works but not able to do both.

Avatar

Community Advisor

This is going to sound really dumb.. but I have found that even if the classifications match but were created separately (i.e. Make the Classifications on Suite A, then make the same classifications on Suite B) then this fails...

 

In my experience they need to be made at the same time with both/all suites selected... so that the classifications are applied to all suites simultaneously... I suspect there is some sort of classification id (behind the visible names) that is created in the system, and those IDs have to match for this to work.

 

When I had this issue in the past, I had to delete all the classifications from all suites individually, then select all the suites, then re-create the classifications....

 

Because I don't want to risk having to re-do work, I have always created classifications with all suites selected for a few years now (just in case this was still an issue).

Avatar

Level 1

I have not tried that but I am only creating classifications on same report suite across as you mentioned. I believe the problem is that we can split the values from regex and assign to different  classifications of same evar but can not do that with contains or other regex'es.

Avatar

Community Advisor

I'm not sure I understand what you mean... The error indicates that one of the Classifications (either Product Availability Buckets or Product Availability Sections; or I guess both) aren't available on your suite(s).

 

What rules you are running (regex, contains, etc) can all be used, and used as many times as you need... Classification Rules run in order, so you could have 5 rules that all match the original value, they will run 5 times... if they all go into 1 Classification, the last rule run will be the value you get, if they go to 5 separate Classifications, each classification will get the value set by the corresponding rule...

 

Before trying to activate the rule, what shows up in Test Rules? Are you getting errors there?

Avatar

Level 1

I do not see any error's when running test as you can see below. Also both of them exist in report suite and I can save this classification if I remove either "Product Availability Buckets" or "Product Availability Sections"

 

TARUNKUMAR2_0-1695957384001.png

 

Avatar

Community Advisor

Just curious, both Classifications (Product Availability Buckets and Product Availability Sections) are on the same eVar?

 

Jennifer_Dungan_1-1695958674423.png

 

 

You have that 1 suite selected on your Rule Builder, with that one eVar selected?

Jennifer_Dungan_2-1695958896617.png

 

 

While you can select multiple suites (with an eVar selected for each), this is what I was talking about setting them up simultaneously...

 

If you have classifications on 2 different eVars, you need to create a separate rule for each dimension. 

 

Or rather I should say that BOTH Classifications (Product Availability Buckets and Product Availability Sections) must be available on all selected eVars in the Select Report Suites and Variables

Avatar

Community Advisor

If you have Product Availability Buckets on eVar1 and Product Availability Sections on eVar2... you will need to create a separate rule for each eVar.

Avatar

Level 1

@Jennifer_Dungan @RobertBlakeley  Has this issue of yours been resolved? If so, how did you manage to resolve it? I'm currently facing the same error and unsure of the steps to fix it.

Avatar

Level 1

I am also experiencing this error: "Some classifications being set within the rules are not available for the following report suites:'report_suite_name' ".

 

I am not doing anything novel. I have set my classifications like this many times.

Avatar

Level 1

@bflynn yeah , i am not sure what is causing this issue . I think adobe support can help us resolve this issue

Avatar

Level 1

My issue has been fixed. Nothing changed on the classification itself. It was a product fix from Adobe. I guess if you still see this issue you can raise a support ticket.

Avatar

Level 1

@TARUNKUMAR2Has this issue of yours been resolved? If so, how did you manage to resolve it? I'm currently facing the same error and unsure of the steps to fix it.

Avatar

Level 1

Yes @Dhanush_RP  this issue has been fixed. Nothing changed on the classification itself. It was a product fix from Adobe. I guess if you still see this issue you can raise a support ticket.

Avatar

Level 1

I can echo the other's statements. Adobe support was able to solve the issue.

They said:

There was a syncing issue on the backend and once the system was resynced, the Classifications worked!