Expand my Community achievements bar.

Announcement: Calling all learners and mentors! Applications are now open for the Adobe Analytics 2024 Mentorship Program! Come learn from the best to prepare for an official certification in Adobe Analytics.
SOLVED

Adobe Analytics Data is not reflecting into the Reportsuite

Avatar

Level 2

Hi,

 

we created a new reportsuite (for testing) for the mobile SDK implementation and all the implementation has been done and mapped new reportsuite to the Analytics service in Datastreams. Lifecycle metrics and visits data are captured in new reportsuite, but standard page data is unavailable in new reportsuite. I created a rule in Tags property by following this article's steps https://developer.adobe.com/client-sdks/documentation/user-guides/getting-started-with-platform/rule... and tested in Assurance debugger as per mentioned article, and for reference, you can see AEP request in the attached snapshot.

 

Note: we configured Adobe Analytics extension with the existing (development and prod) reportsuites in the same property

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

For other people's benefit, here are the images from above:

 

Analytics:

Jennifer_Dungan_0-1689601970924.png

 

Assurance:

Jennifer_Dungan_1-1689601986042.png

 

 

 

My first thoughts are, this is the raw send data? What about the post-processed data? A lot can happen between the send and if the data is properly received...

 

We aren't using the xdm stream like above, but even with the older model, I would never use this view to actually test the implementation as it doesn't tell me anything about IF it got to Adobe or how it was processed....

 

I would expect that should still be available via the "Analytics Events"  section of Assurance (or maybe there is a data stream specific area), have you checked there? 

 

Does the request overview show if the data is going to the correct suite? Is it showing post-processed and request detail data?

View solution in original post

4 Replies

Avatar

Correct answer by
Community Advisor

For other people's benefit, here are the images from above:

 

Analytics:

Jennifer_Dungan_0-1689601970924.png

 

Assurance:

Jennifer_Dungan_1-1689601986042.png

 

 

 

My first thoughts are, this is the raw send data? What about the post-processed data? A lot can happen between the send and if the data is properly received...

 

We aren't using the xdm stream like above, but even with the older model, I would never use this view to actually test the implementation as it doesn't tell me anything about IF it got to Adobe or how it was processed....

 

I would expect that should still be available via the "Analytics Events"  section of Assurance (or maybe there is a data stream specific area), have you checked there? 

 

Does the request overview show if the data is going to the correct suite? Is it showing post-processed and request detail data?

Avatar

Community Advisor

According to the second image for Assurance, you are using XDM and hence the Edge.sendEvent for tracking. Then your data need to be mapped to the XDM schema for Adobe Analytics, where the page name is automatically mapped from web.webPageDetails.name in XDM, which is not the case in your XDM. You can find all auto mapping at Analytics variable mapping in Adobe Experience Edge | Adobe Analytics

It is ok for not to use the same XDM structure when sending in data to Adobe but you need to configure the mapping from your structure to the web.webPageDetails.name in the datastream configuration.

Moreover, when using Assurance, the basic "Events" is really basic and you can use either "Adobe Analytics" or "Adobe Experience Platform Edge", depending on what extension you are using in Adobe Launch, to debug tracking which will give you a better view on what data captured, mapped, and sent to Adobe.

Screenshot 2023-07-18 at 1.11.02 PM.png

Avatar

Community Advisor

Hi @Sivateja123 

 

If data is not reflecting in the relevant report suite, there might be many reasons for this problems.

Please find below some common validation steps to test and resolve the issue:

 

1) Data Latency: Adobe Analytics data may take some time to process and appear in the report suite. Check the data latency documentation for your Adobe Analytics implementation to understand the typical delay.

2) Date Range: Ensure that you are looking at the correct date range in the report suite. If the data was collected after the selected date range, it won't be visible in the reports.

3) Data Collection Issues: Verify that your website or app is correctly implementing the Adobe Analytics tracking code. Use browser developer tools or debugging tools to check for any errors related to data collection.

4) Adobe Analytics Configuration: Double-check your Adobe Analytics configuration to ensure that the report suite is set up correctly and includes the desired data sources and variables.

5) Data Filters: Check if any filters are applied to the report suite, which could be excluding the data you are trying to access. Review any segments or filters that may be affecting the data visibility.

6) Permissions: Confirm that you have the necessary permissions to access the report suite and view the data. In larger organizations, access to specific report suites may be restricted.

7) Data Processing Delay: In some cases, there might be a delay in data processing on Adobe's servers, especially during high-traffic periods. This delay could affect data availability in the reports.

Sampling: If your website or app generates high traffic, Adobe Analytics may use data sampling to process the information. Check if data sampling is applied to your reports, as it could affect data accuracy.

9) Custom Processing Rules: Review any custom processing rules you may have applied in Adobe Analytics. These rules could modify or exclude data before it appears in the report suite.

10) Technical Issues: Occasionally, technical issues may occur on Adobe's end, affecting data processing and reporting. .

If you've gone through these troubleshooting steps and are still experiencing issues, consider reaching out to Adobe Analytics support or consulting with your Adobe Analytics implementation team to investigate further. They can provide more specific guidance based on your setup and configuration.

Avatar

Community Advisor

Just need to point out... Adobe doesn't sample data... 

 

Now, it will bundle the lower traffic under a bucket called "(Low Traffic)" if you have exceeded the 500,000 unique values in a dimension (for performance improvements)... but every single page is accounted for in the data.

 

However, data that is in "(Low Traffic)" won't be returned via a segment if that dimension is used for the segment rule.

 

Bundling content under low traffic is very different than Sampling.... GA uses sampling and when it does, your overall dimension totals actually miss counting that content in the totals. Sampling means only a subset of data is returned for analysis... (a small sample - hence "sampling")...

 

When you are working with Adobe, your totals are always your totals... but you may not be able to analyze data in workspace if it is low (that said, the data is still available for export via the Data Warehouse, API, or Raw Data Feeds).