Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Opening direct links with SSO authentication

Avatar

Level 7

Hey guys…

Here is the scenario…

Many teams that use WF for intake want to have the direct link to their specific request page posted out there in SharePoint or maybe in email communications with their partners. If that “requestor” opens the link and isn’t already logged into WF, they are authenticated and then taken to the home page instead of the specific request page. So, if we send a communication to our requestors, they essentially have to click the link twice for it to open the correct page. Has anyone else ran into this and how do we solve for it? We do have Fusion purchased, so I am wondering if we should direct them to another site such as SharePoint to fill out the form and then have SharePoint create the WF request? Maybe it's a simple adjustment in our authentication process?

Hopefully that makes some sort of sense... Let me know if you guys have any suggestions here...

Thanks!

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi Brandon,

We use SSO and I just just tried going into Workfront from an email link - direct into a project and from another link directly into a request queue (logging out of Workfront first each time) and both links took me directly where I wanted to go, not to the Home page.

I'm thinking it may be something with your authentication process, you may want to bring Workfront support and your internal authentication folks together to figure it out. I recently brought both together on a call for something else and we had our issue solved within about 15-20 minutes. It was way faster than trying to go back and forth between the two! 🙂

View solution in original post

0 Replies

Avatar

Correct answer by
Community Advisor

Hi Brandon,

We use SSO and I just just tried going into Workfront from an email link - direct into a project and from another link directly into a request queue (logging out of Workfront first each time) and both links took me directly where I wanted to go, not to the Home page.

I'm thinking it may be something with your authentication process, you may want to bring Workfront support and your internal authentication folks together to figure it out. I recently brought both together on a call for something else and we had our issue solved within about 15-20 minutes. It was way faster than trying to go back and forth between the two! 🙂

Avatar

Level 7

Thanks Heather! This is as I expected. I would find it hard to believe that we would have to use integrated APIs just to simply have users open a request page link. I have a meeting with our internal IT team today to discuss more. It's good to know that other companies have this working successfully.

Avatar

Level 7

Looks like that was the case. We just need to re-configure our authentication and we should be good. IT is working on it now. Thanks!