Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

bunny87948290
Community profile bunny87948290 Level 2
Job title here
Location here
10 BADGES
Level 2

Level 2

Learn more
Joined the community 19-10-2016 5:57:46 AM
Offline
Top badges earned by bunny87948290
Customize the badges you want to showcase on your profile
Re: AEM servlet redirect with parameters and display resu...
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
So I used the model code as you have mentioned, had to update little but as it was giving error for SlingHttpServletRequest in model class. So here is my code - In the servlet, I am setting cookie value as before redirect - Cookie cookie = new Cookie("caseid", caseId);response.addCookie(cookie);response.sendRedirect(redirect_URL); In HTL/Slightly , printing the value as - Thank you for information, your case id is:${case.getCaseID} It is is printing all the log statements from model class, but ...

Views

1.1K

Likes

0

Replies

0
Re: AEM servlet redirect with parameters and display resu...
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
With Sling model, the sentence is hard coded - ${' Thank you for your information} , want to give ability to author to author and format the message however they want. So, I used the text component with rte plugin, and then just replace the case ID in the text. Is there any way to maintain authoring ability here ?

Views

1.1K

Likes

0

Replies

0
Re: AEM servlet redirect with parameters and display resu...
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Got it! This is helpful, will get it try. One more question - Once I get the case ID, I have text component and text authored as "Thank you for your information, your case ID is caseIDNew" and on slightly page, have this script added to replace "caseIDNew" with the ID I get from sling model or JS, it seems to work, but just want to check if there is any other approach. $(document).ready(function () {$('body').find('*').each(function() {var html= $(this).html().replace(/caseIDNew/g, ${info.title @ context='scriptString'});$(this).html(html);});});

Views

1.1K

Likes

0

Replies

0
Re: AEM servlet redirect with parameters and display resu...
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Thanks you for the suggestion, I don't want to pass anything as query parameter. I think cookie option may work. For that, I need to set the cookie in servlet, then how would I read it in front end via sling model. I think Javascript may be possible. Can you please elaborate on this ? Also, I tried request.getSession().setAttribute("caseID",caseID) , and reading it with JS use API in slightly. IT seems to be working. But, I am not sure will there be any issue with this in production since we hav...

Views

1.2K

Likes

0

Replies

0
Re: AEM servlet redirect with parameters and display resu...
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
I don't see any parameter passed and retried using slightly with this approach, I am looking to display value using htl/slightly

Views

894

Likes

0

Replies

0
Re: AEM servlet redirect with parameters and display resu...
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
I have tried something similar but it didn't work, I am trying to show the parameter value in slightly. I am wondering if I need to use sling model to pass the value

Views

886

Likes

0

Replies

0
AEM servlet redirect with parameters and display result using slightly
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello, I am trying to redirect to .html page from servlet - String cased = "abcd4444";response.sendRedirect(redirect_URL); I need to pass the caseId parameter to redirect url from servlet and show it on the page. What is the best way to achieve it ? Is it possible via sling Model ?

Views

1.3K

Likes

0

Replies

11
Re: After Inplace upgrade of AEM from 6.3 to 6.5, Components are in a satisfied state
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Thanks. Did you have to do any code base update after the in place migration ? Document lists deploy upgraded code base.

Views

3.5K

Likes

0

Replies

0
AEM 6.3 to AEM 6.5 inplace upgrade
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello,I would like to know if anyone has done this upgrade and what are the steps you followed for this upgrade ? I would like to start with my local 6.5 instance, any steps/plan would be helpful.Thanks,Snehal

Views

918

Likes

0

Replies

1
Re: After Inplace upgrade of AEM from 6.3 to 6.5, Components are in a satisfied state
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Just curious, what are the steps performed for inplace upgrade from AEM 6.3 to 6.5 ? We are in the process of upgrading and would like to know more about the steps you took or plan you followed for this upgrade.

Views

3.5K

Likes

0

Replies

0
Re: Scheduler not working in AEM 6.3
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Ah! May be I missed the Cron expression. I thought it is set to run every minute so that I can verify The log statement getting printed. I will try the Cron expression that you mentioned, by changing it to 1 min instead of 30mins. Thank you!

Views

2.1K

Like

1

Replies

0
Re: Scheduler not working in AEM 6.3
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
This is the code I posted earlier and deleted as it was marking it correct answer and closing this question. i triEd OSGIR6 annotations and it is still not working. Logs statement is not getting printed. Can you please let me if this is actually working for you?

Views

1.8K

Like

1

Replies

0
Scheduler not working in AEM 6.3
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello,I have following code for scheduler, I am just trying to print the log statement to check if scheduler actually works. It is not firing any event. In the logs I see -[java.lang.Runnable]] ServiceEvent REGISTEREDBut nothing gets printed. Can you please help ? Here is the code I am using - @Component(immediate = true )@Properties({ @Property( label = "Cron expression defining when this Scheduled Service will run", description = "[every minute = 0 * * * * ?] ", name = "scheduler.expression", ...

Views

3.4K

Likes

0

Replies

4
Re: Cannot resolve dependency for Microsoft service bus
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Thank you! Approach #2 may work for local instance, but for other environments (Dev,QA etc) do I have to add jar to each environment ?

Views

803

Likes

0

Replies

0
Cannot resolve dependency for Microsoft service bus
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello,I have added following dependency to my pom.xml - com.microsoft.azure azure-servicebus 3.0.0 providedBuild is successful, but bundle says cannot resolve it. So, I added it to export package - com.microsoft.azure.servicebus.*; now it resolves the service-bus dependency, but there are several other dependencies that bundle can't resolve, example -om.microsoft.azure.proton.transport.proxy -- Cannot be resolvedcom.microsoft.azure.proton.transport.proxy.impl -- Cannot be resolvedcom.microsoft...

Views

896

Likes

0

Replies

2
Designing a dynamic template with experience/content fragment
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello,I have a requirement to implement a home page which would show the content using content/experience fragment. If user is logged in, different content/experience fragments will be shown, and if user is not logged in, he/she will see different content/fragments.How do I go about this requirement ? do I have to use editable template ? I am confused on how to approach this. Any help would be appreciated.Thanks,Snehal

Views

438

Likes

0

Replies

0
AEM6.3 Error creating live copy
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello,I am creating a live copy for our website using the steps mentioned at - Creating and Synchronizing Live Copies and getting error message - We were able to create live copy before in previous versions. We recently migrated to 6.3. Any idea why I am getting this error ?Thanks.

Views

639

Likes

0

Replies

1
Issue creating project
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello,I am creating MVN project using the doc - Creating an Adobe Experience Manager 6.3 Project using Adobe Maven Archetype 11 As per the doc when I run #1 command. I am getting below error. Any idea ?[WARNING] Error reading archetype catalog https://repo.adobe.com/nexus/content/groups/publicorg.apache.maven.wagon.TransferFailedException: hostname in certificate didn't match: != OR at org.apache.maven.wagon.providers.http.AbstractHttpClientWagon.fillInputData(AbstractHttpClientWagon.java:935...

Views

527

Like

1

Replies

0
Re: Issue with pages appending "/" at the end
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Yes, it is dispatcher cache issue but it comes up often.There is a page new-and-envents.html that is what we are trying to access.Regarding URL - we have - /content/interflex/en/news-and-events.html page created and we are trying to access this page from our website - News and EventsThis seems to load fine now. But it doesn't stay that way. It goes blank and it is because it appends "/" at the end when you try to access this page url.

Views

1.0K

Like

1

Replies

1
Issue with pages appending "/" at the end
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello,We are seeing issue with our site for some pages. Welcome to Interflex When you go to New and Events page from navigation, it opens the page appending "/" at the end. After we clear the dispatcher cache, page loads fine for some time. Again, it starts appending "/". Is it considering it as a directory and appending that "/" ? What can be done to fix this issue. Will appreciate your response on this.Thanks.

Views

1.1K

Likes

0

Replies

4
Re: WCMUsePojo in AEM6.3 not working
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
I included uber jar dependency and still see the same error. Any other solution I can try ?com.day.cq.mailer,version=[5.6,6) -- Cannot be resolvedcom.day.jcr.vault.util,version=[2.4,3) -- Cannot be resolved

Views

556

Likes

0

Replies

0
Re: WCMUsePojo in AEM6.3 not working
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Thanks for your reply. One more question - we just did jcr to OAK migration and moved all 5.6 version sites to 6.3. When I open the pages that were working in 5.6 in 6.3 it shows just blank page. Is it because my bundles are not resolving ? Is this expected behavior when we migrate until we make code compatible to 6.3 ?

Views

545

Likes

0

Replies

0
Re: WCMUsePojo in AEM6.3 not working
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Thanks. No , I haven't added uber dependency in POM. Do I need to add below dependency and remove the deprecated one? com.adobe.aem uber-jar 6.3.0 6.1.0 --> 6.1.0-SP1-B0001 --> 6.1.0-SP2 --> 6.2.0 --> obfuscated-apis provided

Views

552

Likes

0

Replies

0
Re: WCMUsePojo in AEM6.3 not working
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hi,We are in the process of migrating from 5.6.1 to 6.3 I am seeing similar issue with the AEM 6.3. I am getting error - com.day.cq.mailer,version=[5.6,6) -- Cannot be resolvedcom.day.jcr.vault.util,version=[2.4,3) -- Cannot be resolvedCan you please help on with dependency I need to add for it ? Also, can I use JDK1.7 to compile backend bundles ? We are maintaining both the version currently until we fully migrate. So, just wanted to check if I can still use JDK1.7 to compile the code from jenk...

Views

573

Likes

0

Replies

0
Re: Error while deployment of AEM project throguh Jenkins
Avatar
Give Back 10
Level 2
bunny87948290
Level 2

Likes

4 likes

Total Posts

25 posts

Correct reply

1 solution
Top badges earned
Give Back 10
Give Back 5
Ignite 5
Ignite 3
Ignite 1
View profile
bunny87948290
- Adobe Experience Manager
Hello,I am getting below error for the jenkins deployement. Anyone have any solution for this ? We are using Java 7 at java.lang.ProcessBuilder.start(ProcessBuilder.java:1047) at hudson.Proc$LocalProc.(Proc.java:244) at hudson.Proc$LocalProc.(Proc.java:216) at hudson.Launcher$LocalLauncher.launch(Launcher.java:773) at hudson.Launcher$ProcStarter.start(Launcher.java:353) at hudson.Launcher$ProcStarter.join(Launcher.java:360) at hudson.tasks.Maven.perform(Maven.java:329) at hudson.tasks.BuildStepM...

Views

1.2K

Likes

0

Replies

0
Likes from