since ‎13-05-2016
‎10-12-2019
akhilat9657589
Level 2
Unable to open livecycle protected document akhilat9657589 - Adobe Experience Manager
Hi All,We have created a new livecycle policy and processed a pdf document with the new policy. But while trying to open the document, we are getting an error message as "Access to this document is restricted. Your account doesn't have permission to open it".While checking livecycle server logs, we could verify that authentication is successful.Kindly help us to resolve this.Below are the logs.Note:If I add a user directly in Livecycle policy, user is able to access document, but when I add a gr...
302
Views
0
Likes
0
Replies
Issue in accessing Livecycle protected document akhilat9657589 - Adobe LiveCycle
Hi All,We have created a new livecycle policy and processed a pdf document with the new policy. But while trying to open the document, we are getting an error message as "Access to this document is restricted. Your account doesn't have permission to open it".While checking livecycle server logs, we could verify that authentication is successful.Kindly help us to resolve this.Below are the logs.Note:If I add a user directly in Livecycle policy, user is able to access document, but when I add a gr...
342
Views
0
Likes
0
Answers and Comments
UserProperties is always null akhilat9657589 - Adobe Experience Manager
Hi All,We are using AEM 6.3.3.0. There are 2 publish instances and we have configured SCD.We use below code to get logged in user details.UserPropertiesManager upm = userPropertiesService.createUserPropertiesManager(resourceResolver);Session session = slingRequest.getResourceResolver().adaptTo(Session.class);UserProperties userProperties = upm.getUserProperties(session.getUserID(), "profile");When ever we are trying to access site via dispatcher userProperties is always becoming null. So we trie...
309
Views
0
Likes
1
Answers and Comments
Re: Thumbnail tab in page property is not working. akhilat9657589 - Adobe Experience Manager
Were you able to fix the issue?
1152
Views
0
Likes
0
Replies
Re: CUG login not working on publish server after restart akhilat9657589 - Adobe Experience Manager
Please check if the user cug-service is having access to /content node.Thanks,Akhila
380
Views
1
Like
0
Answers
Adaptive Form License akhilat9657589 - Adobe Experience Manager
Hi All,To use adaptive form in production, do we need AEM form license?Thanks,Akhila
550
Views
0
Likes
1
Answers and Comments
Re: Date component in AEM form akhilat9657589 - Adobe Experience Manager
Hi Kautuk,This is for adaptive form right? I was asking for normal AEM form.Do adaptive form require a separate license to use in production?Thanks,Akhila
429
Views
0
Likes
0
Answers
Re: Error while submitting form akhilat9657589 - Adobe Experience Manager Forms
Hi Mayank,We could fix the issue by changing below configuration.https://helpx.adobe.com/experience-manager/kb/AEM-redirecting-back-to-http-on-accessed-via-SSL-terminated-Load-Balancer.html III. Update the Header Configurations:1. Go to http://host:port/system/console/configMgr/org.apache.felix.http.sslfilter.SslFilter, and log in as administrator.2. Set SSL forward header to X-Forwarded-Proto.3. Set SSL forward value to https.4. Click Save.Thanks,Akhila
2168
Views
1
Like
0
Replies
Re: Error while submitting form akhilat9657589 - Adobe Experience Manager Forms
Thanks Mayank for sharing URLs.I looked into the URLs shared. As a primary solution they are mentioning is to use the https version of page. But in my case, I am not sure where and http is getting requested as I am using guideBridge.submit method which is OOB. Is there any solution where we can avoid calling "'http://author-stg.myproject.org/content/test/en/form/country-form/jcr:content/mainContent/ guideContainer.guideAsyncThankYouPage.html"I am not understanding how it is getting called. I tri...
2168
Views
0
Likes
2
Replies
Re: Error while submitting form akhilat9657589 - Adobe Experience Manager Forms
Yes Mayank. It is working as expected in IE. Only on chrome I have this issue.Thanks,Akhila
2168
Views
0
Likes
4
Replies
Re: Unable to read the response back when using submit action in AEM forms akhilat9657589 - Adobe Experience Manager Forms
Hi Rohit,Were you able to fix this?Thanks,Akhila
759
Views
0
Likes
0
Answers
Re: Error while submitting form akhilat9657589 - Adobe Experience Manager Forms
Hi Mayank,If I didn't customize the submit action, form submission will be successful and will get redirected to thanks page. But as per my requirement, I don't want to get redirected to thanks page, but to show thanks message in modal.So to show thanks content in modal, I have customized submit action.Thanks,Akhila
2168
Views
0
Likes
6
Replies
Error while submitting form akhilat9657589 - Adobe Experience Manager Forms
Hi All,I have created an adaptive form and I have a requirement to do certain functions based on the input submitted and show a modal popup once form is submitted successfully.I have customized submit action as below.guideBridge.registerConfig("submitConfig", {"useAjax" : true});guideBridge.submit({ error : function (guideResultObject) { }, success : function (guideResultObject) { $.ajax({ url: "/bin/wcm/testproject/books", data: {dataXml: guideResultObject.data}, success: function(result){ $("#...
2666
Views
1
Like
8
Replies
Re: [Sample] How to create and use Modal in an Adaptive Form akhilat9657589 - Adobe Experience Manager Forms
Hi Mayank,How can we show a modal on submitting a form?Thanks,Akhila
1221
Views
2
Likes
0
Replies
Re: 403 forbidden for some of the POST operations akhilat9657589 - Adobe Experience Manager
Hi Kumar,We tried this, but still not working. As I have mentioned above, for some of the form submit, it is working, but in some it is not.Thanks,Akhila
1118
Views
0
Likes
0
Answers
Re: 403 forbidden for some of the POST operations akhilat9657589 - Adobe Experience Manager
Yes, we are using Jquery Ajax to perform the operation. Now we have fixed the issue by adding the token to the form data using jquery.
1113
Views
0
Likes
0
Answers
Re: 403 forbidden for some of the POST operations akhilat9657589 - Adobe Experience Manager
Note: Sorry, The configuration name I have mentioned is wrong. It is "Apache Granite CSRF Filter " instead of "Apache Sling Referrer Filter"Also the exception I am getting is as below.com.adobe.granite.csrf.impl.CSRFFilter isValidRequest: empty CSRF token - rejectingcom.adobe.granite.csrf.impl.CSRFFilter doFilter: the provided CSRF token is invalidApache Granite CSRF Filter
1115
Views
0
Likes
0
Answers
Re: 403 forbidden for some of the POST operations akhilat9657589 - Adobe Experience Manager
yes, it is working when POST is removed from CSRF filter. But we will not be able to do this as security fails.Thanks,Akhila
1111
Views
0
Likes
0
Answers
403 forbidden for some of the POST operations akhilat9657589 - Adobe Experience Manager
Hi,For some of the POST operations, we are getting the response as 403 forbidden. This work fine when "POST" operation is removed from Apache Sling Referrer Filter.We have added the js . But still the response is 403. When we checked the form data from the reqest the attribute :cq_csrf_token is missing in those ajax call which is getting failed. Have any one of you faced similar issue? Please advice.Thanks,Akhila
2973
Views
1
Like
9
Answers and Comments
Date component in AEM form akhilat9657589 - Adobe Experience Manager
Hi,Is there a date component that can be used in AEM form?Thanks,Akhila
864
Views
0
Likes
2
Answers and Comments
Re: javax.activation.UnsupportedDataTypeException: no object DCH for MIME type multipart/mixed; akhilat9657589 - Adobe Experience Manager
Hi Donald,I tried to send mail outside AEM, but we getting connection time out exception.Thanks,Akhila
972
Views
0
Likes
0
Answers
javax.activation.UnsupportedDataTypeException: no object DCH for MIME type multipart/mixed; akhilat9657589 - Adobe Experience Manager
Hi All,We are trying to send an email from a service. The mail contains an HTML body and an attachment. Below is the code we are using to send email.DataSource source = new ByteArrayDataSource(bytes, "application/pdf");MimeMultipart multipart = new MimeMultipart(); // Create the attachment partMimeBodyPart attachmentBodyPart = new MimeBodyPart(); attachmentBodyPart.setDataHandler(new DataHandler(source)); attachmentBodyPart.setFileName("attachment.pdf"); multipart.addBodyPart(attachmentBodyPart)...
1778
Views
0
Likes
3
Answers and Comments
Session getting closed in custom service akhilat9657589 - Adobe Experience Manager
Hi All,We have created a service which will iterate a huge number of nodes and do certain operations. But after iterating over a few nodes, the session is getting closed and we are getting an exception as below.: This session has been closedjava.lang.IllegalStateException: This session has been closed at com.google.common.base.Preconditions.checkState(Preconditions.java:150) at org.apache.jackrabbit.oak.core.ContentSessionImpl.checkLive(ContentSessionImpl.java:85) at org.apache.jackrabbit.oak.co...
480
Views
0
Likes
2
Answers and Comments
Initial text for components akhilat9657589 - Adobe Experience Manager
I have noticed that when we drag and drop a component in a page in touch ui mode, an initial text is coming up for each components. For example, when I include an image component in page, initially(if nothing is authored), a text "Image" is getting displayed. I would link to implement same in my custom component, can any one explain how to implement this? I have attached a sample screenshot.Thanks in advance.
512
Views
0
Likes
1
Replies
Re: Issue while fetching relationships of users in AEM akhilat9657589 - Adobe Experience Manager
Hi,We are not using any query in our code, below mentioned is the code.SocialGraph socialGraph = resourceResolver.adaptTo(SocialGraph.class);GraphNode currentUser = socialGraph.getNode("somegroup-users");for (Relationship r: currentUser.getRelationships("BOTH", "following")) { // We are getting warning for this line // .. ..//}
2856
Views
0
Likes
1
Replies
Re: Issue while fetching relationships of users in AEM akhilat9657589 - Adobe Experience Manager
Yes we have indexed "jcr:path,jcr:score,nt:base" properties. But still we are able to see this warning in logs.
2856
Views
0
Likes
3
Replies
rep:policy node not getting activated akhilat9657589 - Adobe Experience Manager
We are working on AEM 6.1 We have a custom job that will get activate a site once it got created in author. On site creation, in our custome job, we are creating some user groups and providing access to that site only for them and then will activate the site. But our replication queue is getting stuck as rep:policy node us not getting activated.Below is the error we are getting.07.06.2016 14:12:18 - ERROR - publish1 : Replication (ACTIVATE) of /content/groups/mysite/rep:policy not successful. Co...
1193
Views
0
Likes
2
Replies
Re: Issue while fetching relationships of users in AEM akhilat9657589 - Adobe Experience Manager
Hi Opkar,Thank you for your reply.When I googled the warning, I got a similar post telling "The warning message "Traversed 333000 nodes using index cq:tags with filter" actually means that there is an existing "property" index, but it itself is too large, and a lucene index should be used instead. The common case of querying something for which there is no index at all will look slightly different - something like "Traversed 1000 nodes without index". So I feel like indexing is not an issue here...
2856
Views
0
Likes
5
Replies
Issue while fetching relationships of users in AEM akhilat9657589 - Adobe Experience Manager
We did a code migration from cq5.6 to AEM 6.1. But after migration we are getting bellow warning.13.05.2016 04:47:08.629 *WARN* [134.113.238.3 [1463129228000] GET /content/myproject/en/groups/MY-GROUP/en.html HTTP/1.1] org.apache.jackrabbit.oak.spi.query.Cursors$TraversingCursor Traversed 907000 nodes with filter Filter(query=select d.[jcr:path] as [jcr:path], d.[jcr:score] as [jcr:score], d.* from [nt:base] as a inner join [nt:base] as b on ischildnode(b, a) inner join [nt:base] as c on ischild...
3217
Views
0
Likes
7
Replies