Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

TheBigRed
Community profile TheBigRed Level 4
Job title here
Location here
20 BADGES
Level 4

Level 4

Learn more
Joined the community 06-04-2015 11:52:35 AM
Offline
Top badges earned by TheBigRed
Customize the badges you want to showcase on your profile
Extending the default search in Assets section of AEM
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
My goal here is to integrate third party images when searching for images in AEM Assets.How can I extend the default search bar to include third party images (getty, istock, etc)?

Views

397

Likes

0

Replies

1
Getting jcr in xml format
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Is there away to get a specific tree under a node in xml format?Sort of like the xml which maven archetype 10 projects have under projectname.ui.apps?

Views

375

Likes

0

Replies

0
Re: Sending large text to servlet
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
smacdonald2008 wrote... IS your servlet getting the data? Looks like the only thing here is the WARN in the log. Nothing from the form submit is being passed to the servlet due to the the textarea field having a large block of text.When the text is smaller, it get's passed.

Views

2.8K

Likes

0

Replies

0
Re: Sending large text to servlet
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Any help on this please?

Views

2.8K

Likes

0

Replies

3
Re: Sending large text to servlet
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
smacdonald2008 wrote... This is more of a App server issue as opposed to a AEM issue. For example - see http://stackoverflow.com/questions/22654521/send-large-amount-of-text-to-servlet-via-form Thanks Scott. However this is on my localhost, is there anyway I can change the jetty settings?Thanks!

Views

2.8K

Likes

0

Replies

4
Sending large text to servlet
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
I'm getting the following error whenever passing a large body of text to a servlet:09.03.2017 10:04:28.015 *WARN* [qtp2103505453-6000] org.eclipse.jetty.http.HttpParser URI is too large >16384 09.03.2017 10:04:28.015 *WARN* [qtp2103505453-6000] org.eclipse.jetty.http.HttpParser badMessage: 414 for HttpChannelOverHttp@21df0b1d{r=69,c=false,a=IDLE,uri=} 09.03.2017 10:04:28.015 *WARN* [qtp2103505453-6000] org.eclipse.jetty.http.HttpParser badMessage: java.lang.IllegalStateException: too much data a...

Views

3.2K

Likes

0

Replies

6
Re: Launch site programmatically
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
kautuksahni wrote... TheBigRed wrote... kautuksahni wrote... Just to clear the use-case 1. What is the event that will trigger to open the web page? 2. What do you mean by user screen? Is it any screen that user is on? 3. What exactly you want to achieve? what is that current AEM implementation is not helping out you with? ~kautuk 1) On upload of a file in the DAM (Any folder under under /content/dam) 2) User screen as in current screen on AEM the user is viewing. For this case it'll be whatever...

Views

1.2K

Likes

0

Replies

0
Re: Launch site programmatically
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
kautuksahni wrote... Just to clear the use-case 1. What is the event that will trigger to open the web page? 2. What do you mean by user screen? Is it any screen that user is on? 3. What exactly you want to achieve? what is that current AEM implementation is not helping out you with? ~kautuk 1) On upload of a file in the DAM (Any folder under under /content/dam)2) User screen as in current screen on AEM the user is viewing. For this case it'll be whatever folder the user uploaded to under /conte...

Views

1.2K

Likes

0

Replies

2
Launch site programmatically
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
I want a custom event listener (on adding a file to a folder) to trigger the launching of a site. What I mean by launching is taking the user's screen to a custom built website.Is this possible?

Views

1.2K

Likes

0

Replies

5
Re: Error in workflow status
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
I'm moving only the payload of the workflow using the following package com.adobe.granite.asset.api.AssetManager.I'm strictly using the moveAsset(String, String) method.So I'm guessing this happens because the file is truly moved but the payload hasn't changed to the new location? Thanks

Views

2.1K

Likes

0

Replies

1
Re: Error in workflow status
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Anything on this?

Views

2.1K

Likes

0

Replies

0
WorkflowExternalProcess use case & example
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
From my understanding it's for making asynchronous calls. What are some use cases for this and is there and Adobehelpx article utilizing this class? Or an example provided would be helpful as well. Thanks!

Views

395

Likes

0

Replies

1
Re: Error in workflow status
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Handler advanced is checked and no error's in logs. Half the assets show with status while the others don' have the status.Any help on this?

Views

2.1K

Likes

0

Replies

1
Re: Getting no class found error with injection of ResourceResolverFactory
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
I'm getting the following exception:18.01.2017 10:44:04.132 *ERROR* [0:0:0:0:0:0:0:1 [1484754244068] GET /content/fms.html HTTP/1.1] com.day.cq.wcm.core.impl.WCMDebugFilter Error during include of SlingRequestPathInfo: path='/content/fms/jcr:content', selectorString='null', extension='html', suffix='null' org.apache.sling.api.scripting.ScriptEvaluationException: This is how I'm calling it@Component @Service(Value=SomeClass.class) public class SomeClassImpl implements SomeClass{ @Reference privat...

Views

958

Likes

0

Replies

0
Re: Getting no class found error with injection of ResourceResolverFactory
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Had to forcefully update dependencies and close/open project to update to 2.8.0

Views

1.0K

Likes

0

Replies

0
Re: Getting no class found error with injection of ResourceResolverFactory
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
The following doesn't seem to exist in the API:ResourceResolverFactory.SUBSERVICEresolverFactory.getServiceResourceResolver(param);while using this dependancy: org.apache.sling org.apache.sling.api 2.8.0

Views

959

Likes

0

Replies

0
Getting no class found error with injection of ResourceResolverFactory
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
When injecting ResourceResolverFactory into my custom OSGi service I'm gettting a the following exceptions thrown:*Cannot create component instance due to failure to bind reference repository*ERROR (org.osgi.framework.ServiceException: Service factory exception: org/apache/sling/api/resource/ResourceResolverFactory)*com.rogers.services.FolderMonitorService-bundle [com.rogers.services.impl.FolderMonitorServiceImpl(2222)] Failure loooking up method bindResolverFactory(org.osgi.framework.ServiceRef...

Views

3.1K

Likes

0

Replies

10
Re: Accessing method from custom OSGi Service
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
smacdonald2008 wrote... If you have an OSGi service that exposes method A - you can use dependency injection and get an instance of that service from within your servlet. then all mehtod A I understand you can use @Reference correct?How would the dependency look on my servlet's POM file?I'm getting an error everytime I'm trying to build bundle through maven. Sorry first time for this use case.Lets say service is named SampleService in package com.foo.bar

Views

544

Likes

0

Replies

0
Accessing method from custom OSGi Service
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
I'm trying to access a method from a custom OSGi service I've built from a servlet.How do I go about this with dependencies and initiating the variable from my servlet?

Views

685

Like

1

Replies

3
Error in workflow status
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
HiI have a custom workflow which moves some files when applied.Problem is once moved, those file's status shows up as "In Workflow"Now the workflow archives show up as "Completed" and nothing in workflow instances. Nothing in the logs indicate that the payload is still in a workflow.Any thoughts? Thanks!

Views

2.2K

Like

1

Replies

6
Re: Running a daemon like service
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Thank you Scott, what would be the best practice way of triggering this?Service or Servlet?

Views

553

Likes

0

Replies

0
Running a daemon like service
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Hello trying to run a daemon like service on AEM. What is the best practice for this?Use case is need to run a service that constantly watches a folder outside of AEM and pulls in content whenever it's uploaded to it.Better to trigger this as an servlet or and OSGi service? Or can I implement this like a daemon somehow?Thanks!!!

Views

695

Likes

0

Replies

3
Java Use-API with JSP
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Is it possible to use the Java Use-API with the JSP components?Also a sample would be appreciated if it's possible.Thanks!

Views

396

Likes

0

Replies

0
Re: Workflow not appearing when trying to apply manually
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
psjaison wrote... Hi BigRed, Yes it is not appearing for me also in 6.2. It is coming in 6.1 though. May be, it is not present for a reason. Adobe experts here can say the reason why it is not part of drop down in 6.2. From my experience, We generally should not modify DAM Update Asset as it is one of the key workflow which automatically gets triggered when you upload any asset. I have a workaround for you now. Goto Workflow console - http://localhost:4502/libs/cq/workflow/content/console.html C...

Views

686

Likes

0

Replies

0
Workflow not appearing when trying to apply manually
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
When manually trying to apply 'DAM Update Asset' it's not appearing in the drop-down listeven though the model exists. please see screenshot.

Views

1.2K

Likes

0

Replies

3
Re: Accessing jcr:content property from cq:page
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
I figured it out, its done like this: <%@include file="/libs/foundation/global.jsp"%><% String title = properties.get("html", "default title");%><%=title%>

Views

927

Likes

0

Replies

0
Re: Accessing jcr:content property from cq:page
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
not the page node, the property within the jcr:content of the page node is what I want to access/content/MyPage/jcr:content <-- thisI want to access that node from the page...not using any java methods or anything.I did it before but just can't find the documentation.

Views

933

Likes

0

Replies

0
Accessing jcr:content property from cq:page
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
I have a page where I want to access a node property from that page's jcr:content nodeHow can I do this? I remember seeing an example using the CQ tag or slightlyAn example would be greatly appreciated.Thanks!

Views

4.2K

Likes

0

Replies

4
Re: Servlet forward to another JSP page
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Sorry guys I think you're misunderstanding here.I know how to redirect, just can't get the PATH to my JSP page correctThe jsp page I want to redirect to lives in http://localhost:4502/content/magazine.htmlWhat would be the path to this...currently my getting this exception from my servletLOG Including resource NonExistingResource, path=/bin/Magazine.jsp (SlingRequestPathInfo: path='/bin/Magazine.jsp', selectorString='null', extension='jsp', suffix='null')My servlet path is /bin/MyServlet

Views

1.3K

Likes

0

Replies

0
Re: Servlet forward to another JSP page
Avatar
Ignite 40
Level 4
TheBigRed
Level 4

Likes

5 likes

Total Posts

122 posts

Correct reply

2 solutions
Top badges earned
Ignite 40
Ignite 30
Give Back 50
Ignite 20
Give Back 25
View profile
TheBigRed
- Adobe Experience Manager
Sorry guys this still didn't work.My second page(The one I want the servlet to forward to) lives on AEM.It's path is http://localhost:4502/content/Magazine.htmlI also tried putting the jsp under the "content" part of my bundleunder src/main/content/jcr_root and still didn't workMy servlet redirect code is this: RequestDispatcher requestDispatcher = request.getRequestDispatcher("Magazine.jsp"); requestDispatcher.forward(request, response) Think I might be doing this wrong, sorry first time doing ...

Views

1.3K

Likes

0

Replies

0
Likes given to