since ‎20-08-2014
‎22-02-2021
kolpur
Level 2
Re: Getting error when Migration user from 6.0 to 6.2
Avatar

kolpur

kolpur
- Adobe Experience Manager
Hi,Even we faced this issue when migrating from 5.6.1 to 6.1. The problem here is that your package has all users (at folder level - alphabets, numbers, etc), so what happens is it will replace the existing the folder structure which will remove the existing users including admin and anonymous which are now created with random id.We resolved this issue by creating user package with individual filters (each user and group path). You can make use of ACS AEM Commons tool - https://adobe-consulting-...

Views

859

Like

1

Replies

0
Re: Need SQL2 query for AEM 6.2
Avatar

kolpur

kolpur
- Adobe Experience Manager
@thiszparveen,You can try something like this:SELECT parent.* FROM [cq:Page] AS parent INNER JOIN [nt:base] AS child ON ISDESCENDANTNODE(child, parent) WHERE ISDESCENDANTNODE(parent, '/content/geometrixx/en/products') AND child.[sling:resourceType]='geometrixx/components/title'This will return all [cq:Page] nodes that have nodes with property [sling:resourceType] set to geometrixx/components/title.You can modify this for your property.

Views

928

Likes

0

Replies

0
Re: Generating report for number of authors logged in.
Avatar

kolpur

kolpur
- Adobe Experience Manager
I think you can try querying for rep:Token (6.2) or login token (<6.2) under /home/users as a token would be created for every login.

Views

3.6K

Likes

0

Replies

0
Re: In Mail question mark is coming in place of special characters
Avatar

kolpur

kolpur
- Adobe Experience Manager
Hi Sunita,Check the email headers you received if its encoded in UTF-8 (i think it wouldn't be). What is the emailService class you are using to send email?OOB or custom?If custom, ensure you are setting the encoding to the email.

Views

6.6K

Likes

0

Replies

2
Re: In Mail question mark is coming in place of special characters
Avatar

kolpur

kolpur
- Adobe Experience Manager
Hi Sunita,1. Try to put the hard-coded Japanese string in the mail (abc.txt) directly and check if you are getting it right - if this is working, then it means you are not encoding it properly while setting the params2. If above works, try setting the Japanese string only (new String(pageTitle.getBytes("UTF-8"))), then use the StringBuilder to append the full html.

Views

6.6K

Likes

0

Replies

4
Re: In Mail question mark is coming in place of special characters
Avatar

kolpur

kolpur
- Adobe Experience Manager
You might need to use the following:sb.append(new String(bytes, charset));

Views

6.6K

Likes

0

Replies

6
Re: custom liveaction implementation using BaseAction and BaseActionFactory
Avatar

kolpur

kolpur
- Adobe Experience Manager
If you are getting this error with aem uber.jar, then you can try adding an explicit dependency for com.day.cq.wcm.cq-msm-commons

Views

516

Likes

0

Replies

0
Oak index for jcr:title property
Avatar

kolpur

kolpur
- Adobe Experience Manager
Hi,I have this query to get a pagecontent node based on jcr:title property this way:/jcr:root/content/abc/def/ghi/jkl//element(*, cq:PageContent)[@jcr:title = 'config']When I run this query, I'm observing following kinda warnings in logs:org.apache.jackrabbit.oak.plugins.index.property.strategy.ContentMirrorStoreStrategy Traversed 7000 nodes using index jcr:primaryType with filter ......I created following property index:declaringNodeTypes Name[] cq:PageContentjcr:primaryType Name oak:QueryIndex...

Views

950

Likes

0

Replies

2
Re: SSO in AEM 6.0 with JCR OAk
Avatar

kolpur

kolpur
- Adobe Experience Manager
Hi Dheepak,Even I'm facing a similar issue with SSO login. Can you please share the steps you performed and also please check if with above procedure the CUG pages are working fine.Thanks,Srinivasa Chary Kolpur

Views

275

Likes

0

Replies

0
Likes from