Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

b7wilso
Community profile b7wilso Level 3
Job title here
Location here
13 BADGES
Level 3

Level 3

Learn more
Joined the community 22-08-2014 4:59:52 AM
Offline
Top badges earned by b7wilso
Customize the badges you want to showcase on your profile
QueryBuilder returning different results than XPath "debugger" for Chinese character search
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
I am using QueryBuilder to do a search. It works with Latin characters, but as soon as I do a search with Chinese characters it is not returning any results. I turned on logging for com.day.cq.search which allowed me to pull the XPath query that it is attempting to run. The weirder thing is that when I copy that query over to http://localhost:4502/crx/explorer/ui/search.jsp (the "debugger") and use that, it pulls back three results. Would appreciate any help that anyone could provide. For what i...

Views

320

Likes

0

Replies

0
"String is too long" error when attempting to retrieve jcr:data
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
java.lang.IllegalStateException: String is too long: 2318847350793139939 at org.apache.jackrabbit.oak.plugins.segment.Segment.loadString(Segment.java:397) at org.apache.jackrabbit.oak.plugins.segment.Segment.readString(Segment.java:364) at org.apache.jackrabbit.oak.plugins.segment.Segment.readString(Segment.java:358) at org.apache.jackrabbit.oak.plugins.segment.SegmentPropertyState.getValue(SegmentPropertyState.java:174) at org.apache.jackrabbit.oak.plugins.segment.SegmentPropertyState.getValue(...

Views

1.8K

Likes

0

Replies

6
AEM - Connection pooling for SQL Server
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
So, I am attempting to use the Day Commons JDBC Connection Pool feature of AEM to hit my SQL Server instance. I am getting the impression, based on the thread I have linked in (below) that it is not really possible?http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manager.topic.html/forum__tj7e-hi_im_tryingto.htmlSo, on my local instance I am getting the following error (on startup) even though I have the class in question loaded to the environment as ...

Views

1.1K

Likes

0

Replies

3
Re: AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Naveen - I am including it below, but after what I came across yesterday afternoon, I don't believe that this is the problem (not to mention, this is returning the one tag that is in the field).public Optional getOptionsTags() { return get("cq:tags", String[].class); }All of that said, I think the key thing at this point seems to be the cq:Taggable declaration and somehow getting it to apply to the new pages that have global-web/components/page/optionPage as their resourceType. When I discovered...

Views

1.8K

Likes

0

Replies

0
Re: AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Hey all, Decided I would revisit this and discovered that it is not working on my local Publish environment like I thought it was. I am revisiting the changes that I swear made it work to try and reproduce the situation where it was working.

Views

1.8K

Likes

0

Replies

0
Re: AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
JK - just FYI, based on what we are seeing this still isn't working. Sorry for the duplicate post, but I am wondering if you did not see my last response because I "replied to myself"?Thanks.

Views

1.8K

Likes

0

Replies

2
Re: AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Bad news, in this case it does not seem to have helped. Based on the screen shot provided from our Operations dept it does appear that the tag is readable by all in that publish environment now (admittedly it was not before).

Views

1.3K

Likes

0

Replies

0
Re: AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
JK - Based on my initial read of your provided link I am pretty sure we haven't done this. I will give it a try and come back and let you know. Thanks!

Views

1.3K

Likes

0

Replies

1
Re: AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
TagManager tagManager = request.getResourceResolver().adaptTo(TagManager.class); Optional tagArrayOptional = getOptionsTags(); if (request.getWCMMode() != WCMMode.EDIT) { RangeIterator resourceRangeIterator = null; if (tagArrayOptional.isPresent()) { LOG.info(CONTROL_NAME + "Options Root: " + optionsRoot); String[] tagArray = tagArrayOptional.get(); String tagValues = StringUtils.EMPTY; for (int ctr = 0; ctr < tagArray.length; ctr++) { tagValues += tagArray[ctr] + ", "; } LOG.info(CONTROL_NAME +...

Views

1.3K

Likes

0

Replies

2
Re: AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Yes, the screen shot above is showing that the tag has been promoted to the publish environment. When I do tagmanager.find(rootDirectory, tagID) it is returning null. I have it pointing to the correct directory and both the find and the pages I am trying to pull are using that tag that has been promoted to publish. Is there some sort of config or something that might be messing with this?Thanks.Brad.

Views

1.3K

Likes

0

Replies

4
Re: AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Good thought, but it auto-promoted just that tag when I promoted either page or the tagged component.

Views

1.3K

Likes

0

Replies

12
AEM Tagging - Not pulling results with TagManager.find
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Sorry, I really hope that this is not too basic of a question. That said, please forgive the basic-ness of the question as this is really my first foray into tagging. My local environment is a Windows environment running AEM 6.1, but I don't think I have gotten around to installing SP1 there yet. Alternatively, my Dev environment is on Linux, AEM 6.1 and we do have SP1 installed on there.So I have a component built on tagging that works just fine in my local environment (both Author and Publishe...

Views

3.2K

Likes

0

Replies

14
Re: Custom OSGi Component behaving oddly
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
@Lokesh - PropertiesUtil is just the standard org.apache.sling.commons.osgi.PropertiesUtil;@Scott - Thanks for that, based on that blog post I have updated my declaration to be more correct. That said, it is still not working. I did try just creating a sling:OsgiConfig node which worked (in the sense that I can see it under system/console/configMgr, but not under /system/console/components, is that the way it is supposed to work?). Could I code a fallback to attempt to read from the property I c...

Views

843

Likes

0

Replies

2
Re: Custom OSGi Component behaving oddly
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
@Lokesh - K, I updated to handle the null value more gracefully. I now appear to be making it all of the way through my activate routine. I tried editing the values inside of :4503/system/console/configMgr three different times and none of those times did I seem to be hitting my modified routine even though the values are updating. Any ideas? Why are they not being pulled from the repository (screenshot) on first post? Thanks.

Views

843

Likes

0

Replies

5
Re: Custom OSGi Component behaving oddly
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
@Scott, @Lokesh - thanks for your responses. I got pulled off looking at something else and am just getting back to this one. So I stopped and started and I am able to see the activate log. It is pulling null for the value of the properties.get(TO_EMAILS) call (TO_EMAILS is defined as private static final String TO_EMAILS = "to.addresses";). Because of pulling null it throws an exception where it tries to write out the value of toAddresses.length.I am still questioning why this would be working ...

Views

843

Likes

0

Replies

7
Custom OSGi Component behaving oddly
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
We are on 6.1, but have not gotten any of the hotfixes installed if that makes a difference (but it is planned for this week).First off, this works just fine on my local (to my machine) author and publish instances. On the servers we are seeing the following problem:So this is a configuration component that I developed as part of our first initial release (which is coming soon). I have LOGGING applied in the code which I can see being hit on my local machine but cannot see being hit in the publi...

Views

1.4K

Likes

0

Replies

12
Re: Showing the component outline in Touch UI
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Opkar Gill wrote... Hi Brad, when you say the touch UI components don't show when dropped on the page, then this may be because the appropriate css class has not been applied to the component. I can't remember what it should be off hand, but If you check the css classes applied to an OOTB component that shows the behaviour with the outline around the component appearing, you will see the correct css class to apply. Regards, Opkar Opkar - thanks for your response. From what I am seeing in the OOT...

Views

268

Likes

0

Replies

0
Re: Showing the component outline in Touch UI
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Sorry, was not trying to create a new question. Was trying to rename http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manager.topic.html/forum__fuu1-aem_6_0_sp1wea.html#forum__fuu1-aem_6_0_sp1wea__npdk-_opkar_gillwrote so that it was more accurate to search over.The following can be placed at the top of your component to get the outlining Touch UI behavior. This is working for me in Sightly. We don't have any .jsps so I cannot verify whether it works ...

Views

263

Likes

0

Replies

0
Re: Showing the component outline in Touch UI
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Sure guys, I don't disagree with either point. My use case is this: the components do work in Touch UI, but some only if data has been populated. In several of the components that were developed there is not really a good "default" state developed for when the component is dropped on the page, so you drop it on the page and nothing shows up (but you switch to classic mode) and you can see it (and therefore, edit it). So what I was hoping to do was create an item I could place at the top of any s...

Views

268

Likes

0

Replies

0
Showing the component outline in Touch UI
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
AEM 6.0, SP1We are fairly new to AEM (have not launched our first AEM site yet). When working with our partner all our components were developed with Classic in mind. I am now attempting to make the components (more) usable within Touch UI.Thanks in advance,Brad WP.S. - I submitted this one late last Friday. If you wanted to review that one too that would be helpful. Thanks.

Views

1.6K

Likes

0

Replies

6
Re: Can I use Sling selectors to pull different sightly files
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
For what it's worth we are only on 6.0, SP1. So I have dropped my component on to a page (its the only component within that page) within my content structure that is referenced by SMT.html. To attempt to get the admin version of this component to show up I have tried "SMT.admin.html" and "SMT.file.admin.html". Neither work, the just show the regular version of the component. I did setup some logging in the code behind to show me what selectors I am using and here's what it shows:09.06.2015 10:4...

Views

236

Likes

0

Replies

0
Can I use Sling selectors to pull different sightly files
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Example: I have a component folder called file. Underneath that folder I have two files that I would like to use to display the component: file.html and file.admin.html. I have dropped my component onto a page and have been trying several variations on trying to get the admin version to display, so far to no avail. Any ideas how I would get this to work (or do I need to switch over to JSP's for this component)? Thanks in advance!

Views

391

Likes

0

Replies

2
Can a Granite UI component be used inside of Sightly (if so, how?)
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
I have been experimenting with the Touch UI dialogs in my "spare time" over the past week after last week's session. At some point it clicked in my head that these Granite UI components are in our instance and I wondered if I could use them in our implementation (which has not been launched yet, and since it is a relatively new implementation was developed almost entirely with Sightly for our user interaction). Finally got a chance to attempt to pull one of the Granite UI components earlier this...

Views

238

Likes

0

Replies

1
Re: cq:actionConfigs in Touch UI vs Classic UI - Some code could not be run
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
I had not, but I have added it now (see attachment). It has not helped. Do I need to add a separate clientlib that roles up the cq.authoring.dialog or should it do it automatically? Thanks.

Views

399

Likes

0

Replies

0
cq:actionConfigs in Touch UI vs Classic UI - Some code could not be run
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
I have a component that has sub-components that the author can add as needed. To do this in classic UI we setup following in the authorclientlib:CompanyName.Components.Parent = function (jQuery) { 'use strict'; return { addChild: function(component) { jQuery.post(); } }; }(jQuery);and in the cq:editConfig:cq:actionConfigs:handler=function(){CompanyName.Components.Parent.addChild(this)}This works great for classic UI, but every time I click on the add button in Touch UI I receive a message saying...

Views

1.1K

Likes

0

Replies

3
Re: Learn to create an AEM component that uses a custom xtype
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
@smacdonald2008 - This helped immensely. I now have a dialog field that I am able to add things to. From here I should be able to take it and apply it to the situation I am trying to create (which is similar to what was being done in the article). Thanks!A couple of questions and a comment (not necessarily in that order):Comment - several of the taglibs that you are attempting to include in the JSP are not resolving (I tried copying the URL and hitting it myself and received a 404)Questions:What...

Views

446

Likes

0

Replies

1
Re: Learn to create an AEM component that uses a custom xtype
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Hi, I am fairly new to AEM development (I have been to Developer Training and then our AEM partner's version of Advanced Developer Training) and am just finally having time to start applying what I learned. I found your article mentioned above and thought I followed it word for word, but unfortunately when I try to add an item on the component I am getting a javascript error: "ejstcustom not found and no default supplied". I am using AEM 6.0 and I noticed this article was written for 5.6 and the...

Views

446

Likes

0

Replies

4
Re: Using the Granite include to include an individual item in a cq:dialog
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
Yes. That works better. Based on how it is working now from that change, what happens if I want to use that item across multiple dialogs but it is currently named differently, is there a way to override the name "locally" in the dialog? Thanks.

Views

1.0K

Like

1

Replies

0
Re: Using the Granite include to include an individual item in a cq:dialog
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
I appreciate the attempt. What I am attempting to do is to NOT have to copy and paste the same 40 item select into multiple dialogs. Since I figured out how to include a whole tabs worth of items using the granite/ui/components/foundation/include I wanted to try and use the include to include a single item in a dialog. It works, as I have it referenced above in that it pulls in the whole list of items, but changing the selection and saving does not change the value. So the question is if there i...

Views

1.1K

Likes

0

Replies

0
Using the Granite include to include an individual item in a cq:dialog
Avatar
Give Back 25
Level 3
b7wilso
Level 3

Likes

4 likes

Total Posts

38 posts

Correct reply

2 solutions
Top badges earned
Give Back 25
Ignite 10
Give Back 10
Give Back 5
Give Back 3
View profile
b7wilso
- Adobe Experience Manager
We are currently on AEM 6.0, SP1 for what its worth.I am setting up the cq:dialog's for each of my individual components. I figured out how to use the granite/ui/components/foundation/include to include multiple elements inside a dialog. After doing this, I thought about it some more and wondered if I can do the same thing to include a single granite component (a select with almost 40 options) in multiple dialogs. The answer to that is it includes it OK, but it does not seem to save the results ...

Views

2.5K

Likes

3

Replies

4
Likes given to
Likes from