Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Voon_Siong
Community profile Voon_Siong Level 4
Job title here
Location here
18 BADGES
Level 4

Level 4

Learn more
Joined the community 02-12-2013 12:13:39 PM
Offline
Top badges earned by Voon_Siong
Customize the badges you want to showcase on your profile
AEM 6.2 Author Clustering via MongoMK
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,Is it possible to achieve AEM 6.2 author clustering without using MongoDB? Based on http://jackrabbit.apache.org/oak/docs/clustering.html, it says Clustering is supported for MongoDB and RDBMS storage subsystems. The https://docs.adobe.com/docs/en/aem/6-2/deploy/platform/rdbms-support-in-aem.html page hints that relational databases can be used to replace MongoDB and the basis of this implementation is the extension made to the DocumentNodeStoreService OSGI service. Unfortunately, the https:/...

Views

288

Likes

0

Replies

1
LifeRay and CQ Portlet: SSO via cqpsso cookie
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,This is somewhat a long post. I try to provide as much details as possible and highlight questions in bold.With reference to https://docs.adobe.com/docs/en/aem/6-1/administer/integration/cq-as-portal.html, we were able to install the CQ Portlet to Liferay, add the portlet to a page in Liferay and get the geometrixx-outdoors and geometrixx site contents. We are trying to go one step further and use SSO. The documentation statesThe authenticator service can be configured to use SSO and transmit...

Views

176

Likes

0

Replies

0
Dispatcher Flush: Queue not cleared
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,Our Dispatcher Flush agent's queue is currently at 1000 items. We have tried to force retry the items but the queue does not budge. We notice though that the actual file on the dispatcher is actually flushed. The dispatcher agent's log also affirms that the file was successfully flushed. The question is: why does the queue report invalid items when they are indeed flushed? Where does CQ get the items from? We have tried restarting the replication bundle and also restarting the CQ instances, b...

Views

156

Likes

0

Replies

0
Question about AEM 6.1 Data Store Configuration
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,We would like to run a clustered AEM 6.1 environment, which is backed by a clustered Mongo DB. We are able to do so, but only with both AEM 6.1 sharing the same Data Store. Is it possible to have each instance of AEM 6.1 use it's own data store? Our repository.home value for org.apache.jackrabbit.oak.plugins.blob.datastore.FileDataStore.cfg is crx-quickstart/repository/repository/datastoreFor instance1, the above works.For instance2, if we point to the same datastore folder as instance1, inst...

Views

472

Likes

0

Replies

2
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Ok, finally, our CQ is upgraded to AEM 6.1 successfully. A couple of gotchas 1. Prior to upgrading to AEM 6.1, we had datastore consistency errors. We needed to make sure that those errors are resolved. They stemmed from -1 length cq:properties node in /var/audit and -1 length data node in CQ created versions for some dam assets. For versioning errors due to missing data, use the version manager tool in etc to purge old versions. For -1 cq:properties node in /var/audit, locate the path and remov...

Views

757

Likes

0

Replies

0
Modifying Toolbars with Sightly
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,In 5.6.1, we have a custom edit-bar component that is written in JSP. The edit-bar will obtain the corresponding title from the request object and set it as the first label of the edit bar. In JSP, the code looks like this<%@page import="com.day.cq.wcm.api.components.Toolbar.Label"%> <%@page import="com.day.cq.wcm.api.components.Toolbar"%> <%@page import="com.day.cq.wcm.api.components.EditConfig"%> <%@page import="com.day.cq.wcm.api.components.EditLayout"%> <%@page session="false" %> <% if(ed...

Views

226

Likes

0

Replies

0
Upgrading to AEM 6.1 from CQ 5.6.1
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,We referenced the upgrade article at https://docs.adobe.com/docs/en/aem/6-1/deploy/upgrade.htmlWe are trying to upgrade our CQ 5.6.1 to AEM 6.1 with MongoDB.We unpacked aem-quickstart-6.1.0.jar, we ran the -v -x crx2oak twice to generate the crx2oak.properties and OSGI configuration.We have a mongodb installed and running.We performed the migration and the upgrade.log showed CRX2Oak.java:358 Conversion to MongoDB took 18678314 msec We ran the actual AEM upgrade by specifying -r crx3,crx3mongo...

Views

475

Likes

0

Replies

1
Replication errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Cloud
Hi,We keep getting replication errors on our Publish instance whenever we tried to replicate content from Author. The socket timeouts is causing replication to move very slowly. Why does this happen? How can we fix this? Has anyone encountered this before?15.10.2014 22:53:40.716 *WARN* [137.57.216.124 [1413442398640] POST /bin/receive HTTP/1.1] servletengine socket timeout while finishing input after 2000 ms15.10.2014 22:53:40.717 *ERROR* [137.57.216.124 [1413442398640] POST /bin/receive HTTP/1....

Views

220

Likes

0

Replies

0
Understanding memoryMaxUsage
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,To avoid Java Out of Memory errors and to preserve the integrity of our repository, we elected to enforce -Dcrx.memoryMaxUsage=90 in our start script. This effectively shuts down the repository when the ResourceMonitor detects that the mean memory usage is over 90%. We wanted to find out what caused the memory usage to exceed 90% so we had a cron job scheduled at every half-hour to monitor the memory usage by querying the /system/console/memoryusage page and getting the total memory score. Su...

Views

202

Likes

0

Replies

1
Replication errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,We keep getting replication errors on our Publish instance whenever we tried to replicate content from Author. The socket timeouts is causing replication to move very slowly. Why does this happen? How can we fix this? Has anyone encountered this before?15.10.2014 22:53:40.716 *WARN* [137.57.216.124 [1413442398640] POST /bin/receive HTTP/1.1] servletengine socket timeout while finishing input after 2000 ms15.10.2014 22:53:40.717 *ERROR* [137.57.216.124 [1413442398640] POST /bin/receive HTTP/1....

Views

407

Likes

0

Replies

1
Re: Creating a mobile site via Live Copy and Mobile RolloutConfig: Bug?
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Apparently, in Step 5, when we include Standard rollout config and Geometrixx Mobile, the live copy site does not have pages created with the mobile template.In Sync Config, add Standard rollout config and Geometrixx MobileIf we take out Standard rollout config and use Geometrixx Mobile and Geometrixx Demo Mobile, the live copy pages end up getting created with the corresponding mobile template

Views

178

Likes

0

Replies

0
Re: Creating a mobile site via Live Copy and Mobile RolloutConfig: Bug?
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
The out-of-box Geometrixx Outdoors Mobile site contained Standard rollout config and Geometrixx Outdoors Mobile as rollout config. Unfortunately, trying to create a live copy based on the same rollout config did not result in a live copy site that has pages created with the mobile templates.

Views

172

Likes

0

Replies

0
Creating a mobile site via Live Copy and Mobile RolloutConfig: Bug?
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,I am trying to create a mobile site using MSM with Live Copy. The following describes the steps taken to create my mobile site.1. Browse to siteadmin2. Under Websites, click on New and select New Live Copy3. Enter a title, a name, and set Live Copy From to /content/geometrixx-outdoors/en4. Uncheck Exclude sub pages5. In Sync Config, add Standard rollout config and Geometrixx Mobile6. Click CreateThe resulting mobile site ended up to be an exact copy of the Geometrixx Outdoors site. The templa...

Views

293

Likes

0

Replies

3
SAML Error
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,We are trying to configure SSO on our CQ instance. Using the SAML Tracer, we see that the following assertion was posted myname CQ throws the following error even though we can see that the user ID is in the SAML assertion (eg. "myname")*ERROR* [127.0.0.1 [1397099483866] POST /saml_login HTTP/1.1] com.adobe.granite.auth.saml.SamlAuthenticationHandler Could not extract UserID from assertion.Can anyone help? What did we do wrong?Thank You.

Views

170

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Prior to upgrading our AEM, the data consistency check did complain about errors. Hence, we went back, restored the old backup, ran the data consistency check, fixed the errors, re-ran the data consistency check, confirmed that there were no more errors and executed the upgrade again.Now that the upgrade is done, AEM is still not starting up. There are no Lucene index errors and no missing blobs. Out of the 408 bundles, only 208 bundles were installed. System Bundle is stuck at Starting. There a...

Views

708

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,We are using java 1.7.Attached is the error.logThank You!p/s: I gotta hand it to you. You are even more responsive than daycare support

Views

704

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
I unchecked "Active by default" and I saw that the System Bundle (org.apache.felix.framework)'s Status is "Starting". The other bundles are all Resolved. I tried starting a couple of them but nothing happens. I checked the error.log file and nothing was logged.I went to : and no longer saw "Startup in progress". Instead, it is now showing Problem accessing /. Reason:Not Found

Views

714

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
I am not sure what is happening, but I see many queries in Mongo. With access to system/console, I boosted the log level for error.log to TRACE, but I do not see any new information. I triggered startPropertyIndexAsyncReindex and DataStoreGC via JMX. I am not sure if any of these will help...AEM is still saying "Startup in progress"

Views

709

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
kunal23 wrote... I think that will recreate the mongo collection index and not the OAK index. I am just guessing this but you can give it a try. Just rename the index folder under /crx-quickstart/repository folder and restart AEM. I did a db.nodes.reIndex() and AEM did not start. I restored the backup I created when I completed the upgrade the first time and renamed index to index_old. I tried to start AEM and I was able to get to system/console. I was still not able to get to crx/de because AEM...

Views

708

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
I read that you can do a reindex by adding a node to /oak:index ins crx/de, but unfortunately, I cannot get to crx/de, crx/explorer or any of the UIs...How about reindexing from the Mongo shell? For eg, db.collection.reIndex()?

Views

707

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
The pre-upgraded AEM 6.1 was based on a CQ 5.6.1 backup. The blob does not exist in the backup used to upgrade the CQ instance. The blob does not exist in the running CQ, from which the backup was taken. Thank You

Views

710

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,I have an existing daycare ticket, which is about missing authentication service. With help from the forums, I managed to get pass that error by creating a blob in the datastore folder. I kept the daycare ticket open because I wanted to know if daycare support has a better way to address the missing blob issue.Now that the repository can be started, AEM is complaining about Lucene errors. Disk space is not an issue.Thank you.

Views

707

Likes

0

Replies

0
Re: AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi Kunal,Do you know how we can rebuild the OAK indexes? I have tried lookup for instructions but failed to find any...Thank You

Views

706

Likes

0

Replies

0
AEM 6.1 not starting due to Lucene errors
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,Our AEM 6.1 is not starting. The error.log file has the following warning and error error *WARN* [pool-7-thread-16] org.apache.jackrabbit.oak.plugins.index.lucene.IndexCopier Error occurred while copying file [_sf.cfs] from OakDirectory@78da42b4 lockFactory=org.apache.lucene.store.NoLockFactory@41517568 to MMapDirectory@/build2/install/cq/migratedauthor/561Upgrade/author/crx-quickstart/repository/index/e5a943cdec3000bd8ce54924fd2070ab5d1d35b9ecf530963a3583d43bf28293/1 lockFactory=NativeFSLock...

Views

3.9K

Likes

0

Replies

18
Re: AEM 6.1 Startup Error: Missing Authentication Service due to missing blob
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,I created the dummy binary file and the log states that the CRX Repository is started. There were some additional errors related to oak:lucene and we are still unable to access the instance. I'll wait a bit and see if AEM ever comes up. I have a ticket open with Support. If they ever provide any "official" way to resolve blob related errors, I'll update here.Thanks for your fabulous help!

Views

334

Likes

0

Replies

0
Re: AEM 6.1 Startup Error: Missing Authentication Service due to missing blob
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,The AEM was started with root and the datastore folder has rwx rights for root. I updated the rights to the datastore folder and its contents to 777, just to test if it's permission issues. After restarting AEM, I still see the same error.The full warnings and exceptions logged in error.log are in the attached text file

Views

289

Likes

0

Replies

0
Re: AEM 6.1 Startup Error: Missing Authentication Service due to missing blob
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,The following shows the "java process" after we run our start scriptjava -server -Xmx4G -Xms4G -XX:MaxPermSize=2G -XX:PermSize=2G -Djava.awt.headless=true -Dsling.run.modes=author,crx3,crx3mongo -jar crx-quickstart/app/cq-quickstart-6.1.0-standalone-quickstart.jar start -c crx-quickstart -i launchpad -p 4502 -Dsling.properties=conf/sling.propertiesThe run modes are correctThe config files' contents are as follow-----------org.apache.jackrabbit.oak.plugins.blob.datastore.FileDataStore.cfg-----...

Views

287

Likes

0

Replies

0
AEM 6.1 Startup Error: Missing Authentication Service due to missing blob
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,We recently upgraded our CQ 5.6.1 to AEM 6.1 with Mongo DB. Our upgraded AEM 6.1 is throwing the "Missing Authentication Service" error. The error.log file is saying that a blob could not be found and a call was issued to shut down the repository. How do we delete the blob Id in Mongo DB (assuming that's where it is getting the Id and complaining that the blob could not be found in the file system at crx-quickstart/repository/repository/datastore)? Thanks in advance.

Views

1.3K

Likes

0

Replies

7
Re: CQ and LDAP integration
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
This is done. The fork settings was actually causing ldap-config not getting picked up. Setting nofork, we managed to get LDAP working. That is good enough, for now.

Views

263

Likes

0

Replies

0
CQ and LDAP integration
Avatar
Give Back 25
Level 4
Voon_Siong
Level 4

Likes

3 likes

Total Posts

60 posts

Correct reply

5 solutions
Top badges earned
Give Back 25
Ignite 20
Give Back 10
Give Back 5
Give Back 3
View profile
Voon_Siong
- Adobe Experience Manager
Hi,We are not able to successfully integrate CQ with LDAP. Based on the existing LDAP integration documentation, we are unable to get CQ to start when the following updates were done-updated repository.xml, per the steps outlined in the documentation-updated quickstart.bat to include the ldap config file-included the ldap config fileThe error logs have this error :31.03.2014 09:57:20.560 *ERROR* [FelixStartLevel] com.day.crx.sling.server [com.day.crx.sling.server.impl.jmx.ManagedRepository] The --> -->...

Views

675

Likes

0

Replies

3
Likes given to
Likes from