Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

FilipFiebiger
Community profile FilipFiebiger Level 1
Job title here
Location here
4 BADGES
Level 1

Level 1

Learn more
Joined the community 23-06-2021 7:40:06 AM
Online
Top badges earned by FilipFiebiger
Customize the badges you want to showcase on your profile
Re: Test activity - time condition not working correctly
Avatar
Affirm 1
Level 1
FilipFiebiger
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Affirm 1
Give Back
Ignite 1
Validate 1
View profile
FilipFiebiger
- Adobe Campaign Standard
The problem is that Test and Query are using different time zones and Adobe Engineering Team is not able to make them in alignment. So it seems on some clients they are misaligned, and If you have that issue as me they will not correct it - that's the answer I got after a month of back and forth with support. Great job Adobe!The workaround is to set time zones manually in both blocks then it should give proper results.

Views

87

Likes

0

Replies

0
Re: Test activity - time condition not working correctly
Avatar
Affirm 1
Level 1
FilipFiebiger
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Affirm 1
Give Back
Ignite 1
Validate 1
View profile
FilipFiebiger
- Adobe Campaign Standard
@taplondon_joshthanks for replying!Since writing the post I investigated the issue further and it turned out that the time for test activity is different than time for other blocks.So for example Hour(getDate()) executed in enrichment gives 13 and the same expressions Hour(getDate()) executed in test gives 11.It is now with Adobe support, they suspect it's discrepancy between application and database server... It is extremely frustrating how such a bug can happen?Where can I find my server time ...

Views

174

Likes

0

Replies

2
Test activity - time condition not working correctly
Avatar
Affirm 1
Level 1
FilipFiebiger
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Affirm 1
Give Back
Ignite 1
Validate 1
View profile
FilipFiebiger
- Adobe Campaign Standard
Hello everyone!I'm using below as a condition in my test activity:Hour(GetDate())>13Does anyone have any idea why this condition doesn't work correctly?I checked and when for example using enrichment with this function and I can see the data is populated correctly.But for some reason this test is giving me wrong results. I'm extremely confused about it, it this some Adobe bug?

Views

215

Likes

0

Replies

5