Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

mdp3
mdp3
Offline

Badges

Badges
3

Accepted Solutions

Accepted Solutions
0

Likes

Likes
0

Posts

Posts
3

Discussions

Discussions
0

Questions

Questions
3

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by mdp3
Customize the badges you want to showcase on your profile
Re: Custom xtype not retrieving stored values
Avatar
Give Back
Level 1
mdp3
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Validate 1
View profile
mdp3
- Adobe Experience Manager
Thanks for the response! I think I might not have been clear in my original email, so apologize for that. I have no problem getting CQ5 to manipulate the node values that I want. It actually works perfectly and I can retrieve values and place them on pages using my jsps. The issue is that once they are stored, I can't get my dialog to recognize that they're there. So the dialog just shows blank fields when there is in fact data stored in the underlying node. Except for when my xtype is part of a...

Views

68

Likes

0

Replies

0
Custom xtype not retrieving stored values
Avatar
Give Back
Level 1
mdp3
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Validate 1
View profile
mdp3
- Adobe Experience Manager
So, I'm encountering a weird problem with CQ5. One of the custom xtypes that I've created is correctly writing data to, but not pulling back saved data from, the repository. Just to be super clear, when I say pulling back saved data from, I mean when I refresh the page and then open the dialog again, all of the dialog fields for my xtype are blank. I can post the full code I'm working with if necessary but basically the custom xtype works in this way://pseudo code getValue() { return field1.getV...

Views

577

Likes

0

Replies

4
Selection in custom xtype not saving
Avatar
Give Back
Level 1
mdp3
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Validate 1
View profile
mdp3
- Adobe Experience Manager
Hey y'all,I have a custom xtype that I'm making that incorporates a selection of a document type as one of the fields. See code below. The problem is that this field's selection is not getting saved anywhere. I've debugged the js for my custom xtype and the "value" of typeField is never anything other than undefined or "", even when I make a selection. Any idea what could be going on here? Is selection somehow incompatible with custom xtypes or is there something else I need to do or is wrong. A...

Views

124

Likes

0

Replies

1