Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

vegardengen
vegardengen
Offline

Badges

Badges
3

Accepted Solutions

Accepted Solutions
0

Likes Received

Likes Received
0

Posts

Posts
4

Discussions

Discussions
4

Questions

Questions
0

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by vegardengen
Customize the badges you want to showcase on your profile
Re: DispatcherMaxAgeHeaderFilter. - Adobe Experience Manager 14-10-2019
It seems you are right?So, hardcoding these in dispatcher config is the only option for static content, but for dynamic content, OSGI config is also an option, then?

Views

5.1K

Likes

0

Replies

0
Re: DispatcherMaxAgeHeaderFilter. - Adobe Experience Manager 11-10-2019
It is getting cached in dispatcher, and I have also deleted the cache to see that this is not the problem.Nevertheless, for this testing I am bypassing dispatcher, and as described above, I have verified that the relevant configured actions are triggered on publish.

Views

5.1K

Likes

0

Replies

0
Re: DispatcherMaxAgeHeaderFilter. - Adobe Experience Manager 11-10-2019
[Wed Oct 09 14:10:11 2019] [I] [pid 1282 (tid 139690814244992)] Dispatcher initialized (build 4.3.2/apache2.4-linux-x86_64)We have several dispatcher farms, so this is my dispatcher.any:/farms { $include "enabled_farms/*_farm.any"}The relevant dispatcher farm, however, have enableTTL 1.I have debugged this directly towards my publish instance too, like this:curl -k -v --header "Server-Agent: Communique-Dispatcher" http://localhost:4503/content/dam/barn-dnb-no/page-images/article-pages/illustrati...

Views

5.1K

Likes

0

Replies

0
DispatcherMaxAgeHeaderFilter. - Adobe Experience Manager 11-10-2019
I am trying to add cache-control headers on publish, following this guide:Dispatcher TTL I have added a few configuration, and can see that the filter triggers - but the header is not on the response from publish.I have tried this directly to publish, remembering to add the Server-Agent header.Debug logs for com.adobe.acs states that the header is added, but the response does not contain this header.I am using AEM 6.5 and have ACS version 4.3.2

Views

5.3K

Likes

0

Replies

6