Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

uwej31223422
Community profile uwej31223422 Level 2
Job title here
Location here
2 BADGES
Level 2

Level 2

Learn more
Joined the community 13-06-2019 4:25:22 AM
Offline
Top badges earned by uwej31223422
Customize the badges you want to showcase on your profile
How to have socialconfig for Communities runmode specific (kind of like the OSGI configurations)
Avatar
Boost 1
Level 2
uwej31223422
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
uwej31223422
- Adobe Experience Manager
We have the storage configurations from Tools>Communities>Storage Configuration, which is stored under /etc/socialconfig/srpc/defaultconfiguration, in our code in order to be able to simply deploy it on an AEM instance without the need to configure it manually via the UI on every instance. The challenge is now that we need different configurations for different environments like author, publish, DEV, QA, PROD ...Is there a way to achieve that, just like it can be done with the OSGI configuration...

Views

215

Like

1

Replies

1
Re: Default srp - AEM Communities
Avatar
Boost 1
Level 2
uwej31223422
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
uwej31223422
- Adobe Experience Manager
Hello @kautuk_sahni are there any findings regarding this topic? I am having the very same challenge.

Views

57

Likes

0

Replies

0
Ordering ACL Permissions on a node only possible for admin User
Avatar
Boost 1
Level 2
uwej31223422
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
uwej31223422
- Adobe Experience Manager
In Touch UI when you view the properties of a node and click on "Permissions" you see a list of all ACLs that are defined on that node in the order they are evaluated (bottom to top).If you are logged in as the user with ID "admin", you can change the order per drag and drop.This user is in the groups "everyone" and "administrators".When I create a new user and give him the same groups, he can see the ACLs but can not change the order.So is the right to change the order of the ACL bound to that ...

Views

380

Likes

0

Replies

0
Re: AEM 6.3: created groups and users are not found in search after server restart
Avatar
Boost 1
Level 2
uwej31223422
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
uwej31223422
- Adobe Experience Manager
Hi everybody, I appreciate your answers and I learned quite a bit from it! Thank you!I finally was able to resolve issue but in a totally other way than I thought:Per coincident I found out that the corrupted authorizables-index that was unrepairable with all the measures mentioned above was caused by a corrupted content package. I have absolutely no idea what was wrong with it, but when I uninstalled that package, everything worked fine.So I installed a freshly built content package from a work...

Views

6.5K

Likes

0

Replies

0
Re: AEM 6.3: created groups and users are not found in search after server restart
Avatar
Boost 1
Level 2
uwej31223422
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
uwej31223422
- Adobe Experience Manager
Thanks for the help guys! I determined my Oak version is 1.6.9 and downloaded oak-run-1.6.9.jarI found the following command to start reindexing online:java -jar oak-run-1.6.9.jar index --reindex --index-paths=/oak:index/lucene --read-write --fds-path=/crx-quickstart/repository/datastore /crx-quickstart/repository/segmentstoreIt starts up and the gives me the following error stating it doesn't recognize the option "reindex":Apache Jackrabbit Oak 1.6.9Opening nodestore...Exception in thread "main...

Views

6.5K

Likes

0

Replies

2
Re: AEM 6.3: created groups and users are not found in search after server restart
Avatar
Boost 1
Level 2
uwej31223422
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
uwej31223422
- Adobe Experience Manager
Unfortunately oak-run gives me an error:08:07:22 - Error occurred while performing index tasksorg.apache.jackrabbit.oak.segment.file.InvalidFileStoreVersionException: Using a too recent version of oak-segment-tar at org.apache.jackrabbit.oak.segment.file.ManifestChecker.checkStoreVersion(ManifestChecker.java:81) ~[oak-run-1.8.2.jar:1.8.2]I tried using oak-run-1.6.6 instead but this version doesn't know the options "reindex" and "index-paths".Couldn't find any documentation.

Views

6.5K

Likes

0

Replies

4
Re: AEM 6.3: created groups and users are not found in search after server restart
Avatar
Boost 1
Level 2
uwej31223422
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
uwej31223422
- Adobe Experience Manager
I clicked hide users and Hide groups several times.Same behaviour on touch UI.There are traversal errors but not regarding users or groups but rather certain pages.For example04.07.2019 08:23:47.055 *INFO* [async-index-update-async] org.apache.jackrabbit.oak.plugins.index.IndexUpdate Reindexing Traversed #10000 /de/department-landing-info/Communication/germany/public/events/2017/54-jahre-ebm-in-mulfingenEdit:Now I probably found the problem in the error.log04.07.2019 09:07:35.445 *INFO* [async-i...

Views

6.5K

Likes

0

Replies

6
AEM 6.3: created groups and users are not found in search after server restart
Avatar
Boost 1
Level 2
uwej31223422
Level 2

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
uwej31223422
- Adobe Experience Manager
Hello,when I create a new group or user in /system/useradmin everything is fine as long as the server keeps running. When I only log out and back in again, still everything works fine.But as soon as I stop the instance and start it up again, the users and groups are still there but are not found in the search anymore.I always have to click through the pages until I find them, which is really annoying.I tried reindexing the authorisables, because I found that hint in the forum but it didn't solve...

Views

6.8K

Likes

0

Replies

8
Likes from