Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

kranthiv7238223
Community profile kranthiv7238223 Level 2
Job title here
Location here
5 BADGES
Level 2

Level 2

Learn more
Joined the community 06-04-2019 8:43:19 PM
Offline
Top badges earned by kranthiv7238223
Customize the badges you want to showcase on your profile
Upgrade AEM from 6.3 to 6.5, I see org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
I see the following in error.log file, please help me to fix this issue. org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingExceptionorg.apache.sling.scripting.sightly.SightlyException: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.slin...

Views

566

Likes

0

Replies

0
Re: com.day.cq.wcm.core.impl.components.ComponentCacheImpl Requested Path xxxxx.servlet is not in available search paths
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
me too facing same isue, any help is much appriciated. Thank you.

Views

2.3K

Like

1

Replies

0
com.day.cq.wcm.msm.impl.RolloutManagerImpl Failed to roll-out LiveRelationship
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
Hi Team,when we are publishing the article on our newly migrated AEM 6.3 instance. we see the publisher replication agent queue is getting flooded with same article again and again. for all locales. follwoing is the queue image.and we see the following eror in the error.log file. please find the attached file livecopy_error.log in the following link. Thank you. livecopy_error.log - Google Drive

Views

1.3K

Likes

2

Replies

1
Re: ResourceChangeListener onChange event not getting trigger
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
in my code, this statement is returning null , I mean I am not getting ResourceResolver object resolverFactory.getServiceResourceResolver(param)

Views

1.6K

Likes

0

Replies

0
Re: ResourceChangeListener onChange event not getting trigger
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
I still see org.apache.sling.resourceresolver FrameworkEvent ERROR (java.lang.NullPointerException) in error.log file.arunpatidar26​ here is my Apache Sling Service User Mapper Servicecom.xyz.help.content-engine-core-bundle:vulpe=vulpehere vulpe is the system user

Views

1.6K

Likes

0

Replies

1
Re: ResourceChangeListener onChange event not getting trigger
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
smacdonald2008​, yes we are using 6.3 Uber JAR file. onChange event is getting triggerd but I see problem in getting the ResourceResolverI created the system user tooCreate one system user from /crx/explorer console Give access permissions from /useradmin consoleGo to /system/console/configMgr and search for User Mapper ServiceAdd your bundles:systemUser:systemUsernow write a method to get the resolverpublic static final String CONTENT_ENGINE_SERVICE = "systemUser";@Referenceprivate ResourceReso...

Views

5.1K

Likes

0

Replies

4
Re: ResourceChangeListener onChange event not getting trigger
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
when I install the bundle, I see null pointer exception24.04.2019 09:49:34.993 *INFO* [Background Update com.xyz.help.content-engine-core-bundle (833)] com.xyz.help.conteenginecore.listener.GenerateArticleIdOnAddingArticleNumber activating ExampleObservation24.04.2019 09:49:35.162 *ERROR* [FelixDispatchQueue] org.apache.sling.resourceresolver FrameworkEvent ERROR (java.lang.NullPointerException)

Views

5.1K

Likes

0

Replies

7
Re: ResourceChangeListener onChange event not getting trigger
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
Hi smacdonald2008​ , this is what we are doing. so you suggest us to write @Activate to get the session & @Deactivate to destroy the session ?package com.xyz.help.conteenginecore.listener;import java.util.List;import java.util.Optional;import com.adobe.cq.social.community.api.CommunityConstants;import com.xyz.help.conteenginecore.Constants;import com.xyz.help.conteenginecore.ContentModel;import com.xyz.help.conteenginecore.ContentModelService;import com.google.common.annotations.VisibleForTestin...

Views

5.1K

Likes

0

Replies

8
Re: ResourceChangeListener onChange event not getting trigger
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
Hi Joerg Hoh, yes bundle & component both are active but still onChange event is not getting triggered in AEM 6.3 , but it works fine in AEM 6.2.

Views

5.1K

Likes

0

Replies

0
ResourceChangeListener onChange event not getting trigger
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
Hi All,the following code for onChange used to work in AEM 6.2 but after we migrated to 6.3 , I see onChange is not getting fired, not sure what is going wrong.@Component(immediate = true)@Service@Properties(value = { @Property(name = ResourceChangeListener.PATHS, value = { CommunityConstants.CONTENT_ROOT_PATH }), @Property(name = ResourceChangeListener.CHANGES, value = { "ADDED", "CHANGED" }, propertyPrivate = true) })public class xyz implements ResourceChangeListener {@Referenceprivate Resourc...

Views

5.7K

Like

1

Replies

12
AEM 6.2 to 6.3 inplace migration
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
Hi all,I am running the command java -Xmx2048m - jar cq6.3-author-p4502.jar -v -x crx2oak -xargs -- --load-profile segment-fds to do inplace migration, I see the following, any idea what is going wrong?. Thanks!!16.04.2019 14:46:08.884 INFO c.a.g.c.p.ProfileLoader: Reading migration profile: segment-fds16.04.2019 14:46:09.046 INFO c.a.g.c.p.ProfileHandler: Applying partly the command line (before loading a profile): [--load-profile, segment-fds]16.04.2019 14:46:09.175 INFO c.a.g.c.p.ProfileHandl...

Views

1.4K

Like

1

Replies

2
Re: Error upgrading from AEM6.1 to AEM6.3
Avatar
Validate 1
Level 2
kranthiv7238223
Level 2

Likes

5 likes

Total Posts

12 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
kranthiv7238223
- Adobe Experience Manager
I am also seeing the same issue. not sure what is going wrong. any idea? how to fix it. Thanks!16.04.2019 14:46:08.884 INFO c.a.g.c.p.ProfileLoader: Reading migration profile: segment-fds16.04.2019 14:46:09.046 INFO c.a.g.c.p.ProfileHandler: Applying partly the command line (before loading a profile): [--load-profile, segment-fds]16.04.2019 14:46:09.175 INFO c.a.g.c.p.ProfileHandler: The following template tags has been defined: {}16.04.2019 14:46:09.175 ERROR c.a.g.c.p.ProfileHandler: Tags: [da...

Views

2.7K

Likes

0

Replies

1