srinir44531418
Community profile srinir44531418 Level 2
Job title here
Location here
6 BADGES
Level 2

Level 2

Learn more
Joined the community 30-05-2017 8:07:02 AM
Offline
Top badges earned by srinir44531418
Customize the badges you want to showcase on your profile
Re: Cannot remove component with responsivegrid from editable template
Avatar
Validate 1
Level 2
srinir44531418
Level 2

Likes

2 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
srinir44531418
- Adobe Experience Manager
Thanks. I am trying to understand why it behaves the way it does. And a programmatic fix rather than having to ask Template Authors to go through the work of putting content in, just to remove the component they just added to the template.

Views

927

Like

1

Replies

5
Re: Cannot remove component with responsivegrid from editable template
Avatar
Validate 1
Level 2
srinir44531418
Level 2

Likes

2 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
srinir44531418
- Adobe Experience Manager
Perhaps I have to elaborate on the issue. Here is how to reproduce:1. Lets say we have two components - Component A and Component B.2. Component A has simple HTL, sayThis is Component A3. Component B has following HTLThis is Component B4. As "Template Author", edit a blank template and add Component A and Component B to the template in "Structure" mode.5. As "Template Author", try to delete Component A and Component B from the Template.Result:1. As Template Author, you will see "Delete" option f...

Views

927

Like

1

Replies

7
Cannot remove component with responsivegrid from editable template
Avatar
Validate 1
Level 2
srinir44531418
Level 2

Likes

2 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
srinir44531418
- Adobe Experience Manager
We have a component with a coded in responsive grid (code below). When we add this component to the editable template, template author could not delete any more. Search on forums turned up something that vaguely referenced Synthetic Resource and need to create content using cq:template.Appreciate if anyone can explain WHY this type of component, once added to the template, cannot be deleted. And any workaround without having to ask template authors to add content (to satisfy responsive grid) bef...

Views

1.4K

Likes

0

Replies

9
Re: AEM Custom Replication Agent on Publish - queue not found
Avatar
Validate 1
Level 2
srinir44531418
Level 2

Likes

2 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
srinir44531418
- Adobe Experience Manager
Figured it out. The solution was quite obvious (and silly). Agents (specially the ones used for flushing activity) on publish need "On Receive" checked on the Trigger tab of the agent configuration. And it also needs "Ignore Default" checked. Looking back, it makes complete sense.

Views

1.7K

Likes

0

Replies

0
Re: AEM Custom Replication Agent on Publish - queue not found
Avatar
Validate 1
Level 2
srinir44531418
Level 2

Likes

2 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
srinir44531418
- Adobe Experience Manager
We are using AEM 6.4 . Are there changes in replication agent component / api that results in this behavior only on Publish ? Thanks.

Views

1.7K

Likes

0

Replies

0
Re: AEM Custom Replication Agent on Publish - queue not found
Avatar
Validate 1
Level 2
srinir44531418
Level 2

Likes

2 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
srinir44531418
- Adobe Experience Manager
Thanks. I did review the other thread. That issue was result of space in the agent name (and on Author instance).In our case, I can confirm that there are no spaces in the agent name (akamai).Following scenario with works . on Author instance:1. New agent created with name "akamai"2. Content published3. QueueTopic gets created (from OSGI Jobs screen)4. Custom Transport Handler for the custom agent gets calledFollowing scenario does not work on Publish instance:1. New agent created with name "aka...

Views

1.7K

Likes

0

Replies

0
AEM Custom Replication Agent on Publish - queue not found
Avatar
Validate 1
Level 2
srinir44531418
Level 2

Likes

2 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
srinir44531418
- Adobe Experience Manager
We have need to flush akamai cache on replication and built a custom agent following an (older) project on Github. GitHub - nateyolles/aem-akamai-replication-agent: How to create custom replication agents in AEM using Akamai as an exam… Then we created agent under "Agents on author". UI shows up, we can set configuration etc and agent makes calls to Akmai, all good. However, same configuration when created on Publish instance, under "Agents on publish", does not work. UI shows up, we can set con...

Views

2.5K

Likes

0

Replies

5
AEM Cluster - Master node does not delete the clustered.txt if shutdown prior to all other slave nodes
Avatar
Validate 1
Level 2
srinir44531418
Level 2

Likes

2 likes

Total Posts

8 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
srinir44531418
- Adobe Experience Manager
AEM Cluster documentation mentions that only slave nodes does not delete the clustered.txt when shutdown normally.However, my observation with AEM/CQ 5.5 (and 5.6) is that master node will not delete the clustered.txt even if its shutdown normally (stop script)IF other slave nodes in that cluster are running.Is my understanding correct ? Appreciate clarification (and updates to documentation as appropriate).

Views

125

Likes

0

Replies

2
Likes from