Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

sdouglasmc
Community profile sdouglasmc Level 4
Job title here
Location here
20 BADGES
Level 4

Level 4

Learn more
Joined the community 21-11-2014 10:56:08 AM
Online
Top badges earned by sdouglasmc
Customize the badges you want to showcase on your profile
AEM 6.5 Upgrade to 6.5.7 CFP Causing Unresponsive Instances
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
We've recently upgraded AEM from 6.5.5 to 6.5.7 (didn't install 6.5.6) - running on Ubuntu 18.04.5, Java 11.We have been pretty consistent the last 8-9 months after making some performance adjustments in migrating from 6.3 windows to 6.5 Unbuntu. Rarely having to restart. However, since we've upgraded from SP 6.5.5 to 6.5.7 (we bipassed 6.5.6 - which SHOULDN'T matter), we've noticed really poor performance, author instance needing restarts nearly every 2-3 days and publish instances 5-6 days bec...

Views

3.9K

Likes

2

Replies

32
Re: component not displayed
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
These are custom components correct? Are all the pages you have configured in the Publish instance?I've seen cases where people create their own headers/footers and don't bother checking existence of the pages (bypassing linkchecker).

Views

375

Like

1

Replies

0
Re: Read SAML received from Okta
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
I don't believe you need to create a Post Processor as you can map the fields in the SAML Configuration as properties to the user profile node.

Views

413

Likes

0

Replies

0
Re: JavaScript USE api error - jdk.nashorn.internal.runti...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
6.5 definitely messed around with the Felix framework. This was another issue I found and have Adobe working on https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/aem-6-5-authentication-cipher-issue-with-bouncycastle-that-doesn/qaq-p/372889/comment-id/78427#M78427

Views

977

Likes

0

Replies

0
Re: JavaScript USE api error - jdk.nashorn.internal.runti...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
I put this in a while back:https://issues.apache.org/jira/browse/FELIX-6184 and things seem to be better. But we also put in a process to restart after deployments too because we found that is when we would run into this.

Views

984

Likes

0

Replies

0
Re: JavaScript USE api error - jdk.nashorn.internal.runti...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
I found this a while back:

Views

989

Likes

0

Replies

0
Re: How does AEM Cloud send users to correct the country?
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Thanks! I was wondering if the CDN would pass a header back that we can use in Apache. I wasn't sure how that is handled working with the cloud: something we have to do or already set up.

Views

347

Likes

0

Replies

0
How does AEM Cloud send users to correct the country?
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
I understand AEM Cloud services sits in front of a CDN. What is the preferred way to send a user to the correct country based on geo-location or IP. We have sites in many different countries and if their country doesn't have it's own country branch, default it to a base country. Can these rules be done at the CDN level in order to NOT have to involve a servlet/filter which would mean bypassing the dispatcher cache?

Views

370

Like

1

Replies

3
Re: Allow Activation but require Deactivation approval
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
I'll try that, but I wasn't aware that that is the same as Deactivate.

Views

321

Likes

0

Replies

0
Allow Activation but require Deactivation approval
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
I know replication privledges are tied to both Activation and Deactivation of content. Is there anyway OOTB to give an author the ability to activate content but require them to use an approval process for deactivation? Seems like it should be simple enough as an OOTB feature.

Views

336

Likes

0

Replies

3
Re: AEM 6.5 Authentication Cipher issue with BouncyCastle...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
The hack for this - for Java 8 and 11, in this case is to place the bouncycastle jar under crx-quickstart\launchpad\ext (you may have to create the directory),Add the folowing to the sling.properties: sling.bootdelegation.class.org.bouncycastle.jce.provider.BouncyCastleProvider=org.bouncycastle.*sling.bootdelegation.class.com.rsa.jsafe.provider.JsafeJCE=com.rsa.* (not really sure this one is needed)This is a complete hack as it breaks modularity which is the premise of OSGI. Versioning/restricti...

Views

709

Like

1

Replies

0
Re: AEM 6.5 Authentication Cipher issue with BouncyCastle...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
I found the actual issue. The issue is with the updated Felix Framework code. The BundleProtectionDomain has been updated since 6.4 and seems to be breaking in 6.5 because of the ProtectionDomain Code Source returning a different value. In 6.4 and below, it returns a jar input type in the CodeSource and location of:jar:bundle://546.0:0/!/Whereas in 6.5, although the Protection Domain is set the same (for the most part- [bcprov [583](R 583.0)]) as in 6.4 [bcprov [546](R 546.0)] - the CodeSource v...

Views

817

Like

1

Replies

0
Re: AEM 6.5 Authentication Cipher issue with BouncyCastle...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
This is definitely a bug with 6.5. In 6.3 AND 6.4 you don't have to do anything but install the bouncy castle jar file in OSGI. I didn't even have to add the sling bootleg delegation entries.

Views

829

Likes

0

Replies

0
Re: AEM 6.5 Authentication Cipher issue with BouncyCastle...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
my thought was to create a modular jar file from the jar and put it under jdk-11.0.4\jmods. But since I don't have the source it makes it pretty difficult.

Views

846

Likes

0

Replies

0
Re: AEM 6.5 Authentication Cipher issue with BouncyCastle...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Got it working with Java 8 because I can update the included JRE with the bc jar. Since Java 11 doesn't have this, and that's what we are actually using, I'm trying to figure out how to get it working in there.

Views

850

Likes

0

Replies

0
AEM 6.5 Authentication Cipher issue with BouncyCastle that doesn't appear in 6.3
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
We are migrating a site in AEM 6.3 to 6.5(6.5.5). During authentication, there is the use of PKCS7PADDING which is not working in 6.5 but does work in 6.3 with both environments having bcprov-bcprov- 1.66 installed: final Cipher decrypterWithPad = Cipher.getInstance("AES/CBC/PKCS7PADDING",BouncyCastleProvider.PROVIDER_NAME);--Provider Name being "BC" as seen in the error below---I've stripped out everything and created a small test package (with only slight changes needed for versions of 2 depen...

Views

1.1K

Likes

0

Replies

9
Betreff: Installed 6.5.4 SP RRD already closed Exception
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Seems once I restarted after the install, it has gone away. Odd because usually if a SP need a restart, it does it automatically.

Views

2.7K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
This is the same issue we are facing: https://issues.apache.org/jira/browse/FELIX-6184

Views

5.6K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
There was a code deployment. It failed activation when trying to register again.

Views

5.6K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
This seems to be the same thing I'm experiencing:

Views

7.8K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
04.05.2020 16:23:23.383 *INFO* [Adobe Granite Maintenance Scheduler Update Task] com.adobe.granite.maintenance.impl.MaintenanceJobsManagerImpl Name='com.day.cq.audit.impl.AuditLogMaintenanceTask', Status='UNSCHEDULED', Result='', Details='{"window":"granite_weekly"}'04.05.2020 16:23:23.383 *INFO* [Adobe Granite Maintenance Scheduler Update Task] com.adobe.granite.maintenance.impl.MaintenanceJobsManagerImpl Name='RevisionCleanupTask', Status='UNSCHEDULED', Result='', Details='{"window":"granite_d...

Views

5.6K

Like

1

Replies

5
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Finally got something worth while. If you have an email address, I can sent more to that but....

Views

7.8K

Likes

0

Replies

0
Re: Installed 6.5.4 SP RRD already closed Exception
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
True, but I would like to understand why it happens periodically. It seems to fail on the same thread over and over but the metrics still get written to. I've tried restarting a couple of related bundles but that doesn't seem to help. I also noticed the thread started having issues after some nightly maintenace jobs but that could be just a coincidence.

Views

4.0K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
I would open a ticket but I know the first thing they are going to ask is to send the recreation steps and I don't know them currently. I have confirmed this is the issue. It just so happens this was happening on a development server and restarting the org.apache.sling.scripting.core (549) bundle set things right without having to restart.

Views

7.8K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Looks like on a good instance, Rhino is being used: Caused by: org.apache.sling.scripting.sightly.SightlyException: org.mozilla.javascript.EcmaError: ReferenceError: "granite" is not defined. (/libs/wcm/foundation/components/parsys/parsys.js#24) when I blew away the values in Apache Sling Scripting HTL JavaScript Use-API Factories Configuration (it keeps sightly:/libs/sling/sightly/js/internal/sly.js in by default it appears - but that file doesn't seem to appear in the repository - odd in itsel...

Views

7.8K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Do you have a quick way to test for the scripting engine? I was just going to deactivate the rhino bundle..

Views

7.8K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Right, I didn't see the bundle in mine either. My thought is that it is defaulting back to the one in the JDK, which is Nashorn, when whatever is happening, is happening.

Views

7.8K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Should it be even using the Nashorn Engine or should it be using Rhino? It seems to happen after a deployment where there is moderate traffic. We have 3 publish nodes and keep 2 active. About 2 hours after a deployment, it happens on the 2 live instances.I'm still trying my best to reproduce.

Views

7.8K

Like

1

Replies

10
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Should it be even using the Nashorn Engine or should it be using Rhino? I'm going to do my best to try and replicate it. It seems to happen after a deployment where there is moderate traffic. We have 3 publish node

Views

2.9K

Likes

0

Replies

0
Re: HTL sites not displaying anymore jdk.nashorn.internal...
Avatar
Boost 25
Level 4
sdouglasmc
Level 4

Likes

29 likes

Total Posts

90 posts

Correct reply

4 solutions
Top badges earned
Boost 25
Ignite 20
Give Back 50
Ignite 10
Give Back 25
View profile
sdouglasmc
- Adobe Experience Manager
Should it be even using the Nashorn Engine or should it be using Rhino?

Views

2.9K

Likes

0

Replies

0