since ‎25-06-2014
‎19-03-2021
anjali_biddanda
Level 3
Re: AEM 6.2 to 6.5 Upgrade - dialogs missing value
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Raj, thank you for your response. I tried overlaying and setting CQ.PAGE_PROPERTIES_MAX_RECURSION_LEVEL to a larger value, unfortunately no luck!

Views

2.8K

Like

1

Replies

1
AEM 6.2 to 6.5 Upgrade - dialogs missing value
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Hi Guys, I'm doing an impact analysis of migrating from 6.2 to 6.5. I have updated the project to build our code successfully into a fresh instance of 6.5. Then I used the crx2oak migration tool (the latest crx2oak-1.8.6-all-in-one.jar) to migrate content to the new 6.5 instance with success. The pages on the site load successfully, but on opening components that use a multifield (granite/ui/components/foundation/form/multifield), the values of the multifield do not show in the dialog. The CRX h...

Views

3.2K

Like

1

Replies

4
Re: Empty attribute value stripped by Sightly
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Thanks Arun. That's right! And I found this after I developed a transformer that looks at a path, picks IMG tags to transform and update the alt attribute, only to find out that it's the Chrome browser dev tool that removes the empty attribute value! Chrome version 55/56 and Safari does this too. Firefox renders the alt="". I should've looked at view source instead of the Inspect element. I found the following posts and I knew this accessibility issue is not for me to fix. Would've saved you tim...

Views

1.8K

Likes

0

Replies

0
Empty attribute value stripped by Sightly
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
HI All,We have a scenario where we want the empty alt attribute to be preserved as alt="" instead of stripping the empty string. Screen readers skip the image when alt="" whereas if only alt is found, some screen readers like Jaws and NVDA do not skip the image.What we want: The issue we have now: This is with any attribute that has an empty literal string. Sightly strips them from the output. We're using AEM6.2 which uses Sightly version 1.2. I've tested on AEM6.4, which has Sightly 1.3 and we ...

Views

2.8K

Likes

2

Replies

3
Re: Custom Content Builder for Replication
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Hi krishnak30677142I'm facing the same issue with my custom replication agent. Can you share what you did to fix it?Thanks,Anjali

Views

877

Likes

0

Replies

0
Re: Dynamic vanity URLs in AEM
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
You'll need to use a sling servlet with a selector. Your selectors will be firstname, lastname. Your sling servlet annotation will look like this:@SlingServlet(resourceTypes = "myBrand/components/pages/myPeoplePageType", selectors ={firstname, lastname}, extensions = "html”, methods=”GET”)Your URL below:http://www.myhost.com/people.firstname.lastnamewill invoke your servlet and pass current page path along with other parameters. Servlet would be resolved through selectors & resource type.Then yo...

Views

2.4K

Likes

0

Replies

0
Re: How to implement pretty URLs in AEM? (URL parameters but without using ?parameter-here=xxx)
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
You'll need to use a sling servlet with a selector. Your selectors will be firstname, lastname. Your sling servlet annotation will look like this:@SlingServlet(resourceTypes = "myBrand/components/pages/myPeoplePageType", selectors ={firstname, lastname}, extensions = "html”, methods=”GET”)Your URL below:http://www.myhost.com/people.firstname.lastnamewill invoke your servlet and pass current page path along with other parameters. Servlet would be resolved through selectors & resource type.Then yo...

Views

3.4K

Likes

0

Replies

0
Simulation of Target experience not working in AEM (6.3)
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Hi, I'd really appreciate some help with the following. I've integrated to Adobe Target from my AEM instance and created experiences on a page, but I can't see them being simulated. These are the steps I took to integrate AEM with Target:1. Register with Adobe Target to create an account2. Add the following 2 entries to your page component's head section:2. Opt in to the integration with AEM (Using the opt-in wizard. Or manually as below. I've tried both.)3. Create a Target configuration in AEM4...

Views

593

Likes

0

Replies

0
Dynamic vanity URLs in AEM
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
How can we create Vanity URLs based on a query parameter to a page?We have a URL: http://www.myhost.com/my-page?name=..We want to pretty it up to look like this: http://www.myhost.com/my-page/..eg.http://www.myhost.com/my-page?name=john.smithshould show as http://www.myhost.com/my-page/john.smithAm I correct in saying this is not as simple as creating a rewrite rule on apache? Possibly an AEM servlet? A servlet that uses a request filter to fetch the query parameter and form the dynamic URL and ...

Views

3.2K

Likes

0

Replies

2
Re: *WARN* [Tar PM Optimization] com.day.crx.persistence.tar.ReentrantLockWithInfo Lock on tarJournal still held by Thread[Thread-6960,5,main]: 0
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Cloud
I see the same. And when this happens, memory and cpu consumption by CQ goes right up. Can someone shed some light as to when this might happen? I'm aware tar optimization runs overnight optimizing files, creating new optimized data files and deleting already processed files. It completes successfully most times, but I have seen the above warning many a times - it's as though tar optimisation process goes into a lock and can't stop successfully at 5am - and continues to show these warnings all d...

Views

1.3K

Likes

0

Replies

1
Responsive Previewer for media queries ignore css styles when calc() css3 syntax is used
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
There are certain styles on a page that don't get applied when viewing the page in Classic UI Responsive Previewer for iPad. However, they display as expected on the actual device AND on the browser window re-sized for the breakpoint. We have media queries for screen size mentioned below. We're using the following 2 lines that cause the styles that follow these lines to be ignored: width: -webkit-calc(100% - 30px);width: calc(100% - 30px); If above 2 lines are removed from our css, then the corr...

Views

540

Likes

0

Replies

1
Re: Tags being added into TagInputField in page properties are getting reordered when dialog is OK'ed
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Adding 2 additional attachments

Views

773

Likes

0

Replies

0
Tags being added into TagInputField in page properties are getting reordered when dialog is OK'ed
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Open any page in Geometrixx: http://localhost:4602/content/geometrixx/en/company/management.htmlIn sidekick, go to page properties and add any tags into Tags/Keywords. I've added the 3 tags as shown in the attachment.Hit OK. Now re-open the page properties dialog. The tags in the TagInputField has been re-ordered. It's not in Alphabetical order, or the order they were entered in the Tagging console when they were created. I do not want these to be re-ordered. They should keep the order in which ...

Views

930

Likes

0

Replies

2
Re: How to get href="tel:phonenumber" working?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
And thank you to Jorg and edubey too for your input. 

Views

1.2K

Likes

0

Replies

0
Re: How to get href="tel:phonenumber" working?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Attachments added here.

Views

1.2K

Likes

0

Replies

0
Re: How to get href="tel:phonenumber" working?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Hi Jorg,Thanks for trying on geometrixx. When I try it in Geometrixx, the href is not added for the because the href value entered could not be processed. (see logs below). But when i enter mailto: which is one of the prefixs, then it works as expected and the href is added to . See attachments. I've created a com.day.cq.rewriter.linkchecker.impl.LinkCheckerImpl under /apps//config.Log extract:03.08.2015 12:17:10.827 *INFO* [127.0.0.1 [1438568230824] GET /content/geometrixx/en/services/banking/jcr:content/par/text_1.html HTTP/1.1] com.adobe.granite.xss.impl.HtmlToHtmlContentContext AntiSamy warning: The a tag contained an attribute that we could not process. The adhocenable attribute has been filtered out, but the tag is still in place. The value of the attribute was "false".03.08.2015 12:17:10.827 *INFO* [127.0.0.1 [1438568230824] GET /content/geometrixx/en/services/banking/jcr:content/par/text_1.html HTTP/1.1] com.adobe.granite.xss.impl.HtmlToHtmlContentContext AntiSamy warning: The a tag contained an attribute that we could not process. The href attribute had a value of "tel:234324". This value could not be accepted for security reasons. We have chosen to remove this attribute from the tag and leave everything else in place so that we could process the input.03.08.2015 12:17:23.002 *INFO* [pool-9-thread-1] com.day.crx.security.token.impl.TokenCleanupTask TokenCleanupTask: Removed 0 token(s) in 2ms (3 token(s) still active)

Views

1.2K

Likes

0

Replies

0
Re: How to get href="tel:phonenumber" working?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
leeasling!!! Thank you thank you!!!! This hasn't been mentioned anywhere else. That worked like a charm.

Views

1.2K

Likes

0

Replies

0
Re: How to get href="tel:phonenumber" working?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
edubey, it's when I add a link to text inside a rich text editor (out of the box Text component). See my previous reply to Jorg.Thanks.

Views

1.2K

Likes

0

Replies

0
How to get href="tel:phonenumber" working?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Hi, I've seen your discussions in https://forums.adobe.com/thread/1127899 regarding the same. I'd already tried adding 'tel:' to 'Special Link Prefix' in CQ Link Checker Service configuration. I've also tried adding x-cq-linkchecker="skip" to the tags. I'm using AEM6. I'm using a sightly template - does this x-cq-linkchecker="skip" work in Sightly? I've followed your steps and added a com.day.cq.rewriter.linkchecker.impl.LinkCheckerImpl under /apps//config, and no luck! I've also tried turning off linkchecker entirely by disabling it in Day CQ Link Checker Transformer. And this has no effect! Any help will be appreciated. Thanks.

Views

3.9K

Like

1

Replies

11
Re: Can a column in the damadmin (title) be made readonly?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Hi Naveen, thanks for your reply. However, what you've suggested above is making the field disabled on the dam asset editor form itself, not in the right hand panel of the damadmin. In damadmin right panel you can add/remove columns. When the title column is added, the contents of it are editable - i don't want this to be the case. (see attachment)Appreciate your feedback though.

Views

686

Likes

0

Replies

0
Re: Can a column in the damadmin (title) be made readonly?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Hi Naveen, this question was not answered as per my reply to you. Please would you remove the "solved" status, so I can still get replies/suggestions?

Views

646

Likes

0

Replies

0
Re: Can a column in the damadmin (title) be made readonly?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
editable : false did the job.

Views

641

Likes

0

Replies

0
Can a column in the damadmin (title) be made readonly?
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Hi, In the damadmin, on the right hand pane, if you add the title column, it's editable. How can i make this readOnly? I've tried setting readOnly=true / disabled=true as property for the 'title' gridcolumn -> /apps/wcm/core/content/damadmin/grid/assets/columns/title to override /libs/wcm/core/content/damadmin/grid/assets/columns/title. No luck.

Views

1.6K

Likes

0

Replies

4
Re: dc:format and dam:MIMEtype
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Thanks for your reply Sham. As a workaround i've used a workflow to add the dam:MIMEtype property for any video assets added to the dam.

Views

379

Likes

0

Replies

0
dc:format and dam:MIMEtype
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
CQ5 uses dc:format to denote the mime-type of the asset. (http://docs.adobe.com/docs/en/cq/current/dam/metadata_for_digitalassetmanagement.html)I have a custom dc:format for a video : video/vnd.xxxx.brightcove. And i have a custom video dam asseteditor for this created under "/apps/dam/content/asseteditors/video/vnd/tvnz/brightcove/" to override "/libs/dam/content/asseteditors/video". In damadmin's search tab, if i search for videos and from the result of videos returned, when i click to open th...

Views

852

Likes

0

Replies

2
Re: Certain images block replication queue with "Repository error during node import: Access denied" error
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Thanks for taking the time to reply Sham. However, it only happens for 3-4 random images, all others replicate fine. p.s:We're using CQ5.6.1 which has a few replication bugs fixed since CQ5.5.

Views

597

Likes

0

Replies

0
Re: Certain images block replication queue with "Repository error during node import: Access denied" error
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Thanks smacdonald2008. Yes I have already raised a supportticket with Daycare: https://daycare.day.com/content/home/biztech/biztech_au/partner_services/67183.html#post0003.

Views

487

Likes

0

Replies

0
Certain images block replication queue with "Repository error during node import: Access denied" error
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Replication queue cannot process remaining items in queue when an image replication fails with "Repository node import error: access denied” error.This happens only with a few images, most get replicated. Could it be possible that it's these images are too big? We see a "HTTP/1.1 400 Bad Request" in the replication agent logs (pasted below).-------------------------------------------------------------------------------------------------------------------------------------------------------------...

Views

2.0K

Likes

0

Replies

4
Re: CQ5.6.1 Replication Queue gets stuck, no errors are seen - a manual refresh of adobe.cq.replication bundle is required to get it going
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Thanks again. I have raised a ticket: https://daycare.day.com/content/home/biztech/biztech_au/partner_services/67238.html#post0002

Views

92

Likes

0

Replies

0
Re: CQ5.6.1 Replication Queue gets stuck, no errors are seen - a manual refresh of adobe.cq.replication bundle is required to get it going
Avatar

anjali_biddanda

anjali_biddanda
- Adobe Experience Manager
Yes thanks - our replication agents are enabled and configured correctly as mentioned in that link. However mid-way through replications, the queue gets stuck. So say 5000 items in queue, for no reason when it's down to say 2100, the queue gets stuck and we see nothing in the logs; no errors, and no information when we force retry an entry in the queue. At this point doing a fresh of the bundle, gets the queue moving again. Nothing else does it.

Views

90

Likes

0

Replies

0