Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

shaheenas113483
Community profile shaheenas113483 Level 3
Job title here
Location here
13 BADGES
Level 3

Level 3

Learn more
Joined the community 06-02-2019 10:50:44 PM
Offline
Top badges earned by shaheenas113483
Customize the badges you want to showcase on your profile
Scaffolding re-structuring in 6.5
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
In the re-structuring document the below detail is mentioned: Need to understand if the existing scaffolding will still function in its old location and what is the new scaffolding framework that is mentioned here?

Views

910

Likes

0

Replies

1
Re: How to develop scaffolding in AEM 6.5?
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I have scaffolding which was developed in 6.3, and all of the scaffold templates exists under /etc path. Trying to under how to restructure it, since it has to be under /apps for 6.5. Do I have to just copy paste the nodes to the new location or do i have to build it from level zero, since in adobe document for repository restructuring its mentioned "re-develop". Not very clear how?

Views

1.9K

Likes

0

Replies

0
How to develop scaffolding in AEM 6.5?
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I am trying to understand how to create a scaffolding, its template etc, in AEM 6.5, since in the restructuring document it is mentioned, that it has to be re-developed instead of migrated [6.3-->6.5].

Views

1.9K

Likes

0

Replies

2
Migrated Workflow models and scripts fro 6.3 to 6.5 upgrade, Scripts are not getting picked up
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I migrated my aem instance from 6.3 to 6.5 and the model got migrated and are working well. But the workflow with scripts are not working because it is not able to pick up the script from the location (checked both before/after migrating scripts to new locations it was through same error). The OOTB scripts are also not getting picked for usage.Error:*DEBUG* org.apache.sling.jcr.resource.internal.helper.jcr.JcrItemResourceFactory createResource: No JCR Item exists at path '/apps/workflow/scripts/...

Views

720

Likes

0

Replies

1
Re: Migration of workflow from /etc to /var for 6.5 to 6.5 upgrade
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
Thanks Wasil and Vishu, that permission fixed the problem partially.The behaviour of my custom workflow seems to be a little peculiar. For some workflow models, the scripts are getting picked and complied correctly, whereas for some other, I am getting the above error that the script doesn't exist [even though it does]. Any help on that?

Views

1.6K

Likes

0

Replies

1
Re: Migration of workflow from /etc to /var for 6.5 to 6.5 upgrade
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
To /etc/workflow i have this:and to /etc/workflow/scripts i have this:This is post migration and I am still getting similar error:"... com.adobe.granite.workflow.core.rule.ScriptingRuleEngine Could not find script resource /etc/workflow/scripts/new.ecma. Workflow Scripts may need to be located in /libs or /apps to be executed ...."

Views

1.5K

Likes

0

Replies

0
Re: Migration of workflow from /etc to /var for 6.5 to 6.5 upgrade
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
Im following that document for the migration, and I had migrated all the workflow model and instances to the new location. But, when I migrated the scripts I got the error that I had mentioned.

Views

1.4K

Likes

0

Replies

0
Migration of workflow from /etc to /var for 6.5 to 6.5 upgrade
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I migrated my custom workflow model from /etc to /var and scripts from /etc to /apps. But on execution of the workflow I am getting the below error:"... com.adobe.granite.workflow.core.rule.ScriptingRuleEngine Could not find script resource /apps/workflow/scripts/new.ecma. Workflow Scripts may need to be located in /libs or /apps to be executed ...."I have crossed check my workflow. It refers to the script at path /apps/workflow/scripts/new.ecma but on execution it is not able to find the resour...

Views

3.8K

Likes

2

Replies

7
Re: Error in Siteadmin post AEM 6.3 Upgrade
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
Im working in 6.5 and I am getting the same error. What is the solution for this issue?

Views

920

Likes

0

Replies

0
Re: Can't create child on a synthetic root
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
Hi Srikanth,The issue was due to missing permissions at the node level. You can add permissions to the required node from the Access Control Tab. Suppose I needed to add permissions to root level and also some specific permissions to var node. In my case I needed to add system users to those node and give the users permissions.Regards,Shaheena

Views

7.6K

Likes

0

Replies

0
Re: Bundle issue
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
Im having one such scenario. I need to make the resource resolver activate first and only then my bundle should get activated. Im looking for some implementable ideas.

Views

7.8K

Likes

0

Replies

0
Re: Bundle issue
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
It just came to my knowledge that my bundle is dependent on the resource resolver bundle. So, if the resource resolver bundle is not active when my bundle tries to get activated, then my bundle fails to gets activated and stays in resolved state. And, when I manually activate it, by that time resource resolver is already in activated state and thus my bundle also moves to activate state without any error. Im trying to look for some kind of bundle listener implementation ideas, so that my bundle ...

Views

7.8K

Likes

0

Replies

0
Re: Bundle issue
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
How to grep the bundle?

Views

7.8K

Likes

0

Replies

1
Bundle issue
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I have an OSGI Bundle installed in AEM 6.3, that gets in resolved state on its own time and again without any error and I have to activate it manually every time. What might be the issue?

Views

7.9K

Likes

0

Replies

7
Re: Client Proxy Issue
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I have verified the javax.xml.ws and apache serviceMix as well. It looks same as your screenshot. And, the latest version of the uber jar for 6.5 was also used. Still no luck.

Views

11.6K

Likes

0

Replies

0
Client Proxy Issue
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
In 6.3 instance, the client proxy has: javax.xml.ws,version=2.1.0 from org.apache.felix.framework (0)javax.xml.ws.handler,version=2.1.0 from org.apache.felix.framework (0)while in 6.5 instance for the same pom.xml file the client proxy is showing: javax.xml.ws,version=2.2.0 from org.apache.servicemix.specs.jaxws-api-2.2 (23)javax.xml.ws.handler,version=2.2.0 from org.apache.servicemix.specs.jaxws-api-2.2 (23).and while performing the same functionlity in both the instance, im getting the error i...

Views

12.1K

Likes

2

Replies

11
Groups missing from access control list tab in CRX
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I can't see any groups in the access control list tab of the root node in CRX, which is available in the attached screenshot. I have checked Administrators and Everyone groups in Users page. What to do?

Views

784

Like

1

Replies

1
Re: Can't create child on a synthetic root
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
Earlier it was happening only during roll out, now its happening for anything that I do, which requires node creation. Error: *ERROR* [sling-default-3-Registered Service.5742] org.apache.sling.commons.scheduler.impl.QuartzScheduler Exception during job execution of job 'org.apache.sling.distribution.packaging.impl.ResourceDistributionPackageCleanup@2dad6271' with name 'Registered Service.5742' : Can't create child on a synthetic rootjava.lang.IllegalArgumentException: Can't create child on a syn...

Views

7.6K

Likes

0

Replies

0
Re: Parsys Missing
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
There is no error related to it. Is it because of the upgrade that the parsys is missing, because I haven't uploaded a much needed file which is related to the upgrade for the parsys to appear?

Views

2.4K

Likes

0

Replies

0
Can't create child on a synthetic root
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I have recently upgrade my AEM instance from 6.3 to 6.5 and when I try to do Roll Out as admin, I get the Error: Can't create child on a synthetic root. What does this error imply?

Views

8.0K

Like

1

Replies

6
Re: Parsys Missing
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
The same piece of code has been deployed to another instance (6.3), where parsys works fine. 2 newly created instances within the same packages are having parsys issues (6.3 and 6.5 instances). So is it some configuration issue or some api/file import issue?

Views

2.4K

Likes

0

Replies

2
Parsys Missing
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I added the line: to my jsp page, but the parsys is still not seen in the page. I am not sure what might be the issue.

Views

2.6K

Like

1

Replies

4
checkbox Issue (classic ui)
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I have added a checkbox to my dialog. First time clicking on the button to open the dialog, i can see the checkbox, but on next click on the button to open the dialog, i cant see the checkbox. though i can see the field description and field label 3/4 times, one after the other.When I remove the ID from the code of checkbox, everything works fine, but when i add the line of code which has ID, i face the same issue again.Code:"fish": { "xtype": "checkbox", "fieldLabel": CQ.I18n.getMessage("fishes...

Views

750

Likes

0

Replies

0
Servlet code for both 6.1 and 6.3
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I need to write servlet code which can run in AEM 6.1 as well as in 6.3. But, as we use Felix in 6.1 and SCR in 6.3 how to write a common piece of code that works for both?

Views

645

Likes

0

Replies

1
Re: get resource from session
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
yes, I am getting null

Views

1.4K

Like

1

Replies

0
Re: get resource from session
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
the requirement is that i make use of value map

Views

1.4K

Like

1

Replies

0
get resource from session
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
i made a connection to repository using JCRUtils and got session. Next, I need the resource but, when I am trying to fetch resource using resourceResolver, I am getting null. Whereas, if I use session.getNode, i am getting the node (not null). I also tried to use AdaptManager to convert the node to resource, but I am getting null in this case also.How do I get the resource from the node? or How do I fetch resource directly from session?[I need to use valueMap, thus I need resource]

Views

3.5K

Likes

0

Replies

9
Re: Package download and upload
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I have checked, it's not there.Infact, the problem is really peculiar. At times when I download a package, I get zipped file, which I can upload. But, at other times when I download, I get unzipped file, which on compressing doesn't gets uploaded!

Views

1.5K

Likes

0

Replies

0
Re: Package download and upload
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I use Mac.When I get the downloaded folder I created a zip using the jcr_root and meta_inf folders, only that zip get uploaded successfully. But if I try to zip the folder itself, which contains the jcr_root and meta_inf, that doesn't get uploaded.

Views

1.3K

Likes

0

Replies

0
Re: Package download and upload
Avatar
Validate 1
Level 3
shaheenas113483
Level 3

Likes

9 likes

Total Posts

57 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
shaheenas113483
- Adobe Experience Manager
I have cropped the area including content foldr in the provided image. I have restarted and created instance several times, but it doesn't help me.

Views

1.3K

Likes

0

Replies

0