Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Who Me Too'd this topic

Avatar

Level 2

Hi all,

I just started a new local env with SDK 2021.9.5800.20210903T095431Z (released on 6 sep 2021) on Windows 10 but I'm facing an issue during some packages upload on CRX.

With some packages I get the failure message "package file parameter missing".

Stochino_1-1631631284631.png

 

But these package are not corrupted, they are the same ones I used to upload on a local server using a previous version of the SDK, without any problem.

 

Reading on other questions, I found out that this problem could be related to the lack of space of the java temp folder, so I figured out how to change the Java temp path with a custom folder but still I get the same error message.

I just added properly these configuration on the start bat and on my starting command:

-XX:+HeapDumpOnOutOfMemoryError
-XX:HeapDumpPath=absPathOfMyNewJavaTemp
-Djava.io.tmpdir=absPathOfMyNewJavaTemp

Checking on System Properties of the server, java temp folder was changed successfully, but the issue persists and packages cannot be uploaded with the same failure message.

 

I tried to increase also "Xmx" and "MaxPermSize" parameters size on the running command, but it didn't work.

 

Can someone help me to solve this issue?

 

Thanks in advance,

 

Luca

 

----------------------------------

EDIT:

I tried out to build up an older instance of an AEM SDK (dec 2021), and I still have the same issue.

 

So I think no more this could be an issue related to the SDK.

By the way, I noticed that on the Java temp directory (already customized as explained before), every upload creates a "dat" file related to each "big" package I try to upload via crx.

 

This dat file increases its size as long as the package is uploading on crx, but it just reaches the limit of 45,7 MB and then the upload crashes with always that same error dialog.

 

Could anyone help me? 

Could this be related to my temp folder?

 

Thanks in advance,

Luca

 

Who Me Too'd this topic