Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Multiple Page Tags firing for a single Page load.(Using DTM)

Avatar

Avatar
Boost 1
Level 1
nischithrd
Level 1

Like

1 like

Total Posts

2 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
nischithrd
Level 1

Like

1 like

Total Posts

2 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
nischithrd
Level 1

19-06-2017

Hi,

We noticed that there are multiple Omniture tags firing for a single page load in our Dev Environment. (can't share the URL)

  • 3 similar tags are firing for a single page load (All 3 tags have same page name & variables).
  • I can see DTM rules are fired thrice in the console.

I just wanted to check if you guys are aware of this and please share in case you have any insights on this.

PFA Screenshot.Capture.PNG

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Contributor
Level 4
mikethompson
Level 4

Likes

62 likes

Total Posts

102 posts

Correct Reply

14 solutions
Top badges earned
Contributor
Give Back 10
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Contributor
Level 4
mikethompson
Level 4

Likes

62 likes

Total Posts

102 posts

Correct Reply

14 solutions
Top badges earned
Contributor
Give Back 10
Give Back 5
Give Back 3
Give Back
View profile
mikethompson
Level 4

20-06-2017

Check to make sure you don't have multiple DTM headers or footers output to the page.  Also, are there any iframes which may also have DTM installed?

Answers (4)

Answers (4)

Avatar

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,331 posts

Correct Reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,331 posts

Correct Reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile
jantzen_belliston-Adobe
Community Manager

21-07-2017

Were you able to find a solution to this issue? If so, is there an answer that we can mark as correct in case others have a similar issue?

Avatar

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,331 posts

Correct Reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,331 posts

Correct Reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile
jantzen_belliston-Adobe
Community Manager

20-06-2017

As Mike said, check to make sure you don't have multiple _satillite objects on the page as a result of multiple embeds codes being injected into the page.

Technically, dynamically inserting the embed codes isn't a supported deployment method. With that said, I'm not saying it can't work.

Avatar

Avatar
Boost 1
Level 1
nischithrd
Level 1

Like

1 like

Total Posts

2 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
nischithrd
Level 1

Like

1 like

Total Posts

2 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
nischithrd
Level 1

19-06-2017

Yes Jantzen, We are using Akamai staging for deployment. And we are dynamically injecting the embed codes.

Thanks,

Nischith.

Avatar

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,331 posts

Correct Reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,331 posts

Correct Reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile
jantzen_belliston-Adobe
Community Manager

19-06-2017

How are you deploying your DTM embed codes? Are you using Akamai? Also, are you dynamically injecting the embed codes or are they loaded statically with the page?

Thanks,
Jantzen