Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Why Scene 7 pushing images through 'http' and not 'https'?

PratheepArunRaj
Moderator
Moderator

Dear Everyone,

We have configured Scene 7 Settings for our company so that we can use 'Replace Image' option in VEC. The configuration was done by Adobe Support Team as we didn't have existing Scene 7 Account.

Now we are able to replace the images uploaded to Target, but the image in rendering via 'http' and not 'https'. We cannot have this conflict because our site loads only in 'https'.

Error : Your site was loaded over HTTPS, but requested an insecure image 'http://s7ap1.scene7.com/is/content/TargetCelcomaxiata/icon_cart_V1?tm=1554255797357&fit=constrain&he...'. This content should also be served over HTTPS.

Kindly let us know how to arrest this gap.

Thank You!

Arun

1 Accepted Solution
surebee
Correct answer by
Employee
Employee

Hi PratheepArunRaj​- please submit a Client Care ticket by emailing us at clientcare@adobe.com and we will take a look into it for you.

Thank you,
Surbhi

View solution in original post

2 Replies
surebee
Correct answer by
Employee
Employee

Hi PratheepArunRaj​- please submit a Client Care ticket by emailing us at clientcare@adobe.com and we will take a look into it for you.

Thank you,
Surbhi

View solution in original post

eldhov19157560
Level 3
Level 3

workaround to handle the mixed content issue

  1. Create an activity with “swap image”. Save and preview.
  2. Run a preview page and check what S7 URL has been generated.
  3. Open the activity, remove the swap image modification and rather do an “edit – source” modification with the S7 URL from step 2 – but without the “http:”

Save and preview, test, then activate.