Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Linked Clicked - Target

Avatar

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
PhilipR
Level 2

09-04-2019

I've added two links using VEC, I'd like to be able to track if either link was tracked as part of my test (main reason for the test is to see if we can get more clicks on this link).  So I've added the links in VEC and then in "Goals & Settings" I've set a conversion metric to "clicked on an element" and then I selected the two links.  Problem is I'm not seeing the link clicks being recorded.  I'm seeing page loads, but not link clicks, in the Experience Cloud Debugger, I'm seeing something fire when I follow a link, it's of "Request Type" "delivery", but I'm not seeing anything screams to me that a link click is being recorded.

Replies

Avatar

Avatar
Springboard
Level 8
gaureshk3014423
Level 8

Likes

193 likes

Total Posts

161 posts

Correct Reply

31 solutions
Top badges earned
Springboard
Validate 1
Contributor
Coach
Shape 10
View profile

Avatar
Springboard
Level 8
gaureshk3014423
Level 8

Likes

193 likes

Total Posts

161 posts

Correct Reply

31 solutions
Top badges earned
Springboard
Validate 1
Contributor
Coach
Shape 10
View profile
gaureshk3014423
Level 8

09-04-2019

hi Philip,

There are several things to consider when selecting elements:

  • You can browse to a different page to track clicks on a page where you might not be changing content. This different page must be included in the activity using the multipage feature and at.js or mbox.js must be implemented on it.
  • If you select more than one element, if an entrant clicks on any one of the chosen elements, the click is counted. To count each item separately, set up individual success metrics for each element.
  • Make sure you select the level of element you want to track. For example, when specifying a button, make sure you select the link and not the button text.
  • Click events are sent to Target on the same page as the click.
  • If the click-tracking metric is the Goal metric of an A4T activity, the visitor must click this element within 60 seconds of the page loading in order for the metric to track.
  • Click tracking does not work on elements that include escaped characters in their selectors, including the following:
    CharacterDescription
    #Number sign or Hash
    :Colon
    .Period
    $Dollar sign
    #Square brackets

You can check whether your click is getting tracked or no in developer's tool by following below steps,

1. Go to your page and press ctrl + shift + i (on the page where you have added the links)

2. Go to Network Tab

3. Filter your mbox file and click on it

4. Go to preview section

5. There you can see numbers of offers getting fired on your page, click on the last offer > actions > where you can see all the elements which are getting tracked.

If you find your links(i.e. element selector for your links) in that list that means it is getting tracked properly, otherwise you need to check whether your goal and metric selection is properly defined .

1729978_pastedImage_0.png

Thanks,

Gauresh.

Avatar

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
PhilipR
Level 2

10-04-2019

Gauresh,

Thanks for the reply, what I'm seeing is:

notifications: [{id: "xxxxxxxxxxxxxx", type "click", timestamp: xxxxxxxxxx....

In the adobe debugger I'm seeing the same thing (but part of a longer string).  So the click is being sent back.  I'm not seeing an "actions" section.  I'm not seeing the "click" notification for any other link, just the links I've marked.

I'm not seeing any of the reserved characters in my selectors, so I don't think that's the issues either.  I've gone through the snippet from the documentation you provided several times (including making sure I follow the link within 60 seconds).

Philip

Avatar

Avatar
Validate 1
Level 2
Erkee
Level 2

Likes

3 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 2
Erkee
Level 2

Likes

3 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
Erkee
Level 2

20-05-2019

Hi gaureshk30144236​ -  I have a similar ask - but with one element. I am seeing the click track, but only seeing the reports populate in A4T for an experience similar to the element in the VEC. We are using the click on the container since we just want to see how much engagement increases or decreases on the container regardless of how many links it might have.

The click is id'd and tracking per the tools as you stated above for all of the pages - but the reporting only logs the VEC experience or those similar. Any suggestions?

Example:

The section tracked is the "Related Links" section lower on the page.

Shows proper reporting:

Incorrect reporting - doesnt send impressions or conversions for a4t, but click is firing in dev tools:

any guidance is appreciated.

Avatar

Avatar
Springboard
Level 8
gaureshk3014423
Level 8

Likes

193 likes

Total Posts

161 posts

Correct Reply

31 solutions
Top badges earned
Springboard
Validate 1
Contributor
Coach
Shape 10
View profile

Avatar
Springboard
Level 8
gaureshk3014423
Level 8

Likes

193 likes

Total Posts

161 posts

Correct Reply

31 solutions
Top badges earned
Springboard
Validate 1
Contributor
Coach
Shape 10
View profile
gaureshk3014423
Level 8

21-05-2019

hi Erkee,

Sorry, I can't help you in this as I don't have much idea about A4T tracking, maybe PratheepArunRaj​ can help you in this.

Thanks,

Gauresh Kodag

Avatar

Avatar
Boost 50
Employee
tanvia28417128
Employee

Likes

73 likes

Total Posts

61 posts

Correct Reply

8 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Boost 50
Employee
tanvia28417128
Employee

Likes

73 likes

Total Posts

61 posts

Correct Reply

8 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile
tanvia28417128
Employee

22-05-2019

Hi PhilipR​,

When you click on the link, you should be able to view a new target call with the mbox name as '<activity-mbox-name>-clicked'

If this happens, you click should be tracked in reports.

You would be able to view the reports in Target activity Conversion report of the success metric. Are you receiving any count here?

However, if you want to view the click tracks in the experience cloud debugger, you would need to enable the mbox trace and view the achieved success metric.

Hope that helps.

Avatar

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
PhilipR
Level 2

22-05-2019

Tanvia,

It was all working as it should, I saw the click in the debugger, but target itself wasn't recording it.  I went to Adobe support, they took a while to get back, by then we had to remove target from that application since it was causing issues with different parts of the application and IE 11.  We're working to get it reinstalled.

Philip

Avatar

Avatar
Validate 1
Level 2
Erkee
Level 2

Likes

3 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 2
Erkee
Level 2

Likes

3 likes

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
View profile
Erkee
Level 2

22-05-2019

gaureshk30144236​ - thanks.

PratheepArunRaj​ - any guidance will help.

tanvia28417128​ - have you experienced where the <mbox>-clicked fires but it isn't logged? That is what we are experiencing after going in and setting usecase query parameters and logging what we should see in terms of impressions and clicks. The mbox-clicked fires as expected and we see a clickid in the headers as well, but it doesn't track through except on an experience where the page is the exact same as the VEC experience. 

example values:
mbox:  target-global-mbox-clicked

clickTrackId: 32767.286695

Not sure why. The click is definitely firing though. Are there other values I can look at to see if it is working properly - e.g. post vs. get in the Request method or something? 

Thanks in advance.

Avatar

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
PhilipR
Level 2

22-05-2019

I was able to show the adobe tech who was working with me the issue and they were confused about why it would show it's firing, but not record the event.

Avatar

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
PhilipR
Level 2

Likes

12 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
PhilipR
Level 2

06-06-2019

I'm unsure why this was marked as "Assumed Answered".