Expand my Community achievements bar.

Join us for an upcoming in-person Adobe Target Skill Builders event ~~> We're hosting these live learning opportunities to equip you with the knowledge and skills to leverage Target successfully. Learn more to see if we'll be coming to a city near you!

Adobe Target Activity LocalHost Invalid Domain Error


Level 2

Hi Team,

I have created 2 XF's in aem 6.4.3 and they got synced with the adobe target from my local. when i tried to give my local publish URL in the adobe target activity i am getting below error. I am able to create target activities using the dev/qa/stage/prod URLs.  Please let me know if i have to make any changes in the adobe target to accept localhost URLs ?

I have tried to turn off the Enhanced Composer but no luck.

Error: Invalid internal Domain in request: http://localhost:4503/content/we-retail/us/en.html at Object.exports.getUrlToProxy (/var/www/node_modules/vizproxy/modules/utils/proxy_url.js:74:13) at new RequestHelper (/var/www/node_modules/vizproxy/modules/proxy_request_handler.js:21:34) at exports.helperFactory (/var/www/node_modules/vizproxy/modules/proxy_request_handler.js:12:10) at new ProxyExecutor (/var/www/node_modules/vizproxy/modules/core.js:27:17) at /var/www/node_modules/vizproxy/modules/core.js:13:27 at /var/www/node_modules/vizproxy/modules/auth/ims.js:55:11 at validateTokenStoreEntry (/var/www/node_modules/vizproxy/modules/auth/ims.js:233:5) at /var/www/node_modules/vizproxy/modules/auth/ims.js:151:7 at /var/www/node_modules/vizproxy/modules/auth/ims.js:202:7 at Proto.apply (/var/www/node_modules/vizproxy/node_modules/dnode/node_modules/dnode-protocol/index.js:123:13)

1 Reply


Employee Advisor


When you are trying to load your local instance within the Visual Experience Composer [EEC turned off] are you seeing any console errors relation to

  • X-Frame-Options
  • Content-Security-Policy

When I was testing AEM via localhost in my own sandbox I noticed console errors relating to X-Frame-Options [more info].

Nevertheless, I would recommend installing the VEC Helper Extension [Chrome] which will bypass both the console error when editing within the VEC.

Hope this solves the problem for you.


Joshua Eisikovits | Global Lead, Platform Support | Customer Experience | Adobe