Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Upgrading LiveCycle 8.0.1 SP3 to 8.2

Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

12-11-2008

Hi,



I need to upgrade my Live Cycle ES version 8.0.1 SP3 to LiveCycle ES v8.2.



There is my environment :



- JBoss v4.0.3SP1



- SQL Server 2005 SP1



- Windows Server Standard Edition 2003 R2 SP1



So, my issue is that in the prepareupgrade_8x.pdf they said :



" Platforms that are supported in LiveCycle ES version 8.0 continue to be supported in LiveCycle ES

version 8.2."



But in the same pdf they said :



"LiveCycle ES supports the following Microsoft Windows operating system:

● Standard Server 2003 SP2 and later

● Enterprise Edition SP2 and later

● Standard Server R2 SP2 and later

● Enterprise Edition R2 SP2 and later running on 32-bit, 64-bit, and VMWare ESX/GSX architectures"



So I want to know if I could do the upgrading without trouble because my windows server 2003 is SP1 and not SP2 and my sql server 2005 is SP1 to.



Thanks.

Replies

Avatar

12-11-2008

Hi,

You do need Windows Server 2003 SP2 to be on a supported platform. LiveCycle ES supports SQL Server 2005 SP1 (English and Japanese) with JBoss 4.0.3 SP1 and JBoss 4.2.0.

Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

13-11-2008

Ok, I'll see if I can apply SP2 on my Windows Server 2003.



LiveCycle 8.0 will continue to run correctly on SP2 I guess ?



Thanks for the answers

Avatar

13-11-2008

I have been running LC 8.0 on SP2, but I believe it is not officially supported by Adobe.

Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

13-11-2008

Ok thank you :).

Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

14-11-2008


Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

14-11-2008

Hi,



I configured LiveCycle ES.

I copied the ear from the export file to the Jboss/server/all/deploy file.

I tried the connection to the database witout issue.



The connection to the Livecycle doesn't work.



In the jboss server log file, I found this :



--- Incompletely deployed packages ---

org.jboss.deployment.DeploymentInfo@afc2c503 { url=file:/F:/Program Files/jboss/server/all/deploy/adobe-livecycle-jboss.ear }

deployer: org.jboss.deployment.EARDeployer@1b17d49

status: Deployment FAILED reason: URL file:/F:/Program Files/jboss/server/all/tmp/deploy/tmp6874adobe-livecycle-jboss.ear-contents/adobe-wkf-scheduler-exp.war/ deployment failed

state: FAILED

watch: file:/F:/Program Files/jboss/server/all/deploy/adobe-livecycle-jboss.ear

altDD: null

lastDeployed: 1226674468297

lastModified: 1226674358945

mbeans:



Any help would be appreciated.



Thanks

Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

17-11-2008

There is the first error in the jboss log :



2008-11-17 09:48:37,116 ERROR [org.jboss.ejb.plugins.LogInterceptor] EJBException in method: public abstract java.util.Map com.adobe.idp.config.PreferencesSPI.getSystemRoot() throws com.adobe.idp.common.errors.exception.IDPException,com.adobe.idp.common.errors.exception.IDPSystemException:

com.adobe.idp.common.errors.exception.IDPSystemException: nullorigin: | [com.adobe.idp.storeprovider.jdbc.DBStoreFactory] errorCode:12290 errorCodeHEX:0x3002 message:initialization failure| [com.adobe.idp.storeprovider.jdbc.DBStoreFactory] errorCode:12290 errorCodeHEX:0x3002 message:no setup for com.adobe.edc.server.spi.storage.entity.PrincipalDomainEntity



Any ideas please 😞