Highlighted

PDF XDP data caching in IE 6

Ryan_M__Jacobs

11-12-2008

The following situation we have encountered using the following client software:

Browser:IE6

Reader version: 7.?



1. We have a process that renders an xdp as PDF. A servlet was written to invoke the render service and return the rendered PDF in the browser. This works fine.

2. Next, the user changes some of the text in the data fields which have been merged. The user doesn't save the document, but closes the browser.

3. Open the browser and invoke the servlet again with the same data as on the first go around, and we momentarily see the rendered form with the original data, then it quickly changes to the edits the user made in step 2.



We identified that what happens is IE actually is creating a temp file of the XFA xml data when the user changes some value in the field, and that it appears this temp file is being used in some sort of caching scheme whereby it takes priority over the data originally coming back in the xfa based PDF servlet response.

What we haven't figured out is how to bust the cache. We have tried several parameters on the response header of the servlet. We have forced IE to always ask for new versions of resources. We have disabled server caching on the render process, turned off client rendering on the render process. Nothing seems to work.



This behavior does not occur when opening the rendered PDF's directly from the filesystem, so it seems browser/servlet specific.



Has anyone come across this and know of a solution?



Thanks!

Ryan M. Jacobs

Replies

Highlighted

pguerett

12-12-2008

In Acrobat/Reader 8 there is a setting under the Edit/Preferences/Forms area - called Keep forms data temporarly available on disk. Set this off and try again.



Not sure where this setting is in version 9. Which version are you running?
Highlighted

Ryan_M__Jacobs

12-12-2008

Thanks. I will try to find a similar setting on version 7, which is what our client is using. It still seems strange that this only happens when the document is loaded from the browser plugin and not in standalone reader, but we will try it out.

Thanks again!

Ryan