Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Error ALC-WKS-007-040 when Running Process

Not applicable

I am trying to run a process which I have imported as an archive from another developer.

The archive seems to have imported correctly (all the components show up correctly in Workbench), however when I run it, I get the following error:

An error occurred creating the form (task 402, form 0). (ALC-WKS-007-040).

Any help would be appreciated.
9 Replies
Not applicable
Make sure you set the RenderPDFForm service to render the form if it is an xdp. Can you let me know how you are configuring the xfa form variable in the workflow? Also did this workflow ever work from where ever you got the LCA from?
Not applicable
Also - make sure that the process has only 1 form variable as "input". Otherwise when you try to start the process, it will not know which form to render.
Not applicable
Many thanks for your reply.

Since I made the post, I have realised that I have an issue with one of the processes which runs an ldap query, and is called (as a web service), by the form in another process.

I have successfully installed Active Directory, and am assuming that there is nothing else I need to do to support the use of the ldap query.

Following the documentation at, I have made a guess at what settings I actually need, as follows:

Initial Context Factory: com.sun.jndl.ldap.LdapCtxFactory (the default).

Provider Url: ldap://kananga:389 (kananga is the name of my computer).

Username: Administrator (the name of the user I log in with).

Password: evenlogic (the password on the Administrator account).

Other Properties: (blank).

This has resolved my original issue (i.e. the form now runs), however the ldap query itself still does not work. When I try and open it in design mode, I get the following error:

ALC-DSC-000-000: com.adobe.idp.dsc.DSCRuntimeException: Internal error.

Any advice would be most appreciated.
Level 10
Level 10
The username and password are the credential to connect to the LDAP system and not to LiveCycle.

Are you sure you have a Administrator/evenlogic account in your Sun LDAP system.

Is there an error in the server.log file?

Not applicable

Thanks for your quick response.

My apologies for not making myself clear in my earlier post. The Administrator and evenlogic user name and password combination I am trying is the user name and password to log into my PC, rather than to Livecycle. I am trying this because

I am unclear what terms such as credentials to connect to the LDAP system actually mean. In the installation of Active Directory, I did not specify a particular user name at any stage, and the only password I entered was evenlogic, which is the password I entered when asked for the Directory Services Restore Mode Administrator Password. I am able to manage Active Directory without having to supply any credentials.

There is an account called Administrator in Active Directory (I am running Windows Server 2003), which corresponds to the account I log into my PC with (with the password evenlogic).

The following is the error in server.log:

2008-09-17 11:30:29,375 INFO [STDOUT] javax.naming.AuthenticationException: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C090334, comment: AcceptSecurityContext error, data 525, vece ]

It looks as though this is an authentication issue, i.e. I cant connect to the ldap server with the credentials I supply, however I dont know what the UserName field in the ldap service configuration dialog is expecting.


Geoff Olding
Level 10
Level 10
if you arr comnnecting to AD then you must login with a user that has the LDAP directory. AD does not support an anonymous user out of the box. So you must supply the Distinguished Name DN of a user that has those rights. Administrator will have thos rights but the id must be in the form of a DN.
Not applicable

Still no luck I'm afraid.

I have now changed the Username to the following:

cn=John Smith, ou=Users, dc=evenlogic, dc=co

I have given the Administrator the first name "John" and the last name "Smith" in Active Directory.

In Active Directory, the Administrator user is under the node "Users", which is under the node "" (representing the Domain).

I have restarted the ldap service, but am still getting the same error.


Geoff Olding
Level 10
Level 10
In ny AD the DN for Administrator is cn=Administrator,cn=Users,dn=severname,dc=adobe,dc=com

Note that the Users is a cn and not an ou. The terminalogy in Microsoft is slightly different than other LDAP servers.

I use an LDAP browser to access the LDAP server and validate the DNs etc...there are plenty of freeware ones out there. This will allow you to get access to the LDAP server and get immeadiate feedback.
Not applicable
Many thanks.

In the end I got the correct string from Softerra LDap Administrator.

For the record, it is:

cn=Administrator, cn=Users, dc=evenlogic, dc=co

It doesn't work if I add dn=kananga (my server name). I got stuck since the web page I found got the cn bit wrong.

Anyway, many tanks for your help

Geoff Olding