Highlighted

ALC-LCM-999-032 during turnkey install

Avatar

04-08-2008

Hello,



I am currently trying to install the LiveCycle ES Update 1 evaluation version (LiveCycle 8.2), using the turnkey install mode. However, when using the LiveCycle Configuration Manager, using the express configuration option, I get the error ALC-LCM-999-032 mentioning that the JBoss service could not be started.



I have searched the internet for information related to this issue. I have found the following resources:



b A.

My reference document is the PDF for a turnkey install:

http://help.adobe.com/en_US/livecycle/8.2/installturnkey.pdf



I have made sure that all the prerequisites are verified:

- The server is a Windows 2003 Server (Enterprise x64)

- I have downloaded and installed the JDK1.5.0_16-b02

- Both JAVA_HOME and PATH are correctly configured



I have also disabled any existing web servers and SQL servers running on the target computer.



The 'troubleshooting' section of the PDF mentions that the JBoss log files are found in the jboss\server\all\log directory. I tried looking for them, but the directory 'log' does not exist in 'jboss\server\all'. Why? Searching for '*.log' files on the computer does not yield any matching result either.



b B.

The thread http://www.adobeforums.com/cgi-bin/webx/.3bc420e3/6 reports the exact same error that I encountered. However, it's for an older version (8.2), and it also has slightly different symptoms: when the author attempts to run the service from the Windows service manager, it creates the error 1930xc1, whereas when I attempt to run the service from the Windows service manager, the service starts then ends immediately without an error notice (and Windows tells me that some services tend to do that when they have no work to do). Attempting to run the service application directly (\jboss\JBossService.exe) of course does nothing (shuts down immediately).



I have nonetheless attempted the solution proposed in that thread by Jasmin Charbonneau, but the service was already set up to run under "local system".



b C.

The thread http://www.adobeforums.com/cgi-bin/webx/.3bc420e3/6 is similar to the previous one, and mentions the message detail. The corresponding lines in my own output are:

[2008-08-04 14:38:10,859], INFO, Thread-17, com.adobe.livecycle.lcm.feature.expressTurnkey.ExpressModeDialog, Sub Task Progress: [55%, Verifying JBoss for Adobe LiveCycle ES service is running]

[2008-08-04 14:38:10,859], INFO, Thread-17, com.adobe.livecycle.lcm.util.process.ProcessExecutor, Running: sc query "JBoss for Adobe LiveCycle ES"

[2008-08-04 14:38:10,937], INFO, Thread-17, com.adobe.livecycle.lcm.util.process.ProcessExecutor, Return value: 0

[2008-08-04 14:38:10,937], INFO, Thread-17, com.adobe.livecycle.lcm.util.ServiceUtils, State: 1,STOPPED



This is the only information that I have managed to obtain so far. Also, I have tried to solve the problem manually by running the jboss server directly (jboss\bin\run.bat). This successfully runs the jboss server, which becomes accessible on port 8080 as expected. However, the configuration of LiveCycle is not done, and it is therefore no surprise that http://server:8080/adminui is a 404.



Do you have any suggestions about how to solve this issue?

Replies

Highlighted

Avatar

04-08-2008

When the Configuration Manager is waiting for jboss, have you tried to manually start jboss then? Did you try to restart the server and run the configuration manager from the bat file?



You can also try with the custom mode. It worked better for me than express.
Highlighted

Avatar

04-08-2008

The Configuration Manager seems to be expecting the service to run, and I cannot run the service either (I can only launch the server itself, without going through Windows services). I have also tried to use the custom configuration mode, but the same error appears during deployment.



Thank you for your reply
Highlighted

Avatar

04-08-2008

Sounds quite strange. I would suggest that you uninstall LC, clean up things that might not be removed, like the service, restart the server and try to install once more. Unfortunately, I don't know about any other solution.
Highlighted

Avatar

04-08-2008

I have already done several uninstall-cleanup-reboot-reinstall cycles so far, all of them unsuccessful. I have settled for the WebLogic turnkey install instead of the JBoss one, and it appears to work correctly so far. Still don't know what was wrong with the JBoss version.