Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error in creating dataset in AEP

vipinfkumar
Level 2
Level 2

Hi,

 

I am following the below link and at the step 6 (create dataset) am getting an error.

 

https://experienceleague.adobe.com/docs/platform-learn/getting-started-for-data-architects-and-data-...

 

Can someone please help, is something is missed or how do I solve it?

 

Many Thanks in Advance.

 

Vipin

 

vipinfkumar_0-1619789712762.png

 

 

 

1 Accepted Solution
dwright
Correct answer by
Employee
Employee

@vipinfkumar ,

Are you still stuck? Were you able to create the dataset? If you are still getting these messages, i would open a support ticket.

View solution in original post

6 Replies
AtulChavan
Level 2
Level 2

Vipin, this is due to may be a dataset already exists with same name. Try creating dataset with different name. A guess just , mark ans correct if it helps.

vipinfkumar
Level 2
Level 2
Actually, I have tried with other dataset name and for other schema's as well however every time the same error message is displayed. I checked in other temporary sandbox with some other schema to create dataset and there I don't see this issue. Not sure what is missing here, any permission, mapping or something else... Any other lead pls?
StewSchilling
Community Advisor
Community Advisor

It's hard to say what the cause is here.  There are a couple things that I find strange.

1) The error code is 500. This generally means that the issue is going unhandled.  Unhandled issues tend to not give very much guidance about the cause or what actions you can take to resolve.

2) The API endpoint that is producing the 500 error code (based on the message) is the "Discovery" endpoint.  It doesn't make sense to me that /discovery/me would be called in this context as (in my experience) it is part of the Analytics 2.0 API.  For the AA 2.0 API this endpoint is used when trying to determine who you are, what company you belong to, etc. 

 

What I would do next.  

1) Open your dev console on the browser and switch to the network tab.  

2) Reproduce the error and watch the network tab for the request/response with the 500 status code. 

3) Dig into the response body to see if there is more detailed information. (post the details of the request/ response back here). 

also, 

Check the list of datasets in this sandbox just to see if any already exist.  Avoid creating new ones with the same name as existing ones (just to rule out the dataset name conflict as the cause of error). 

 

Since you said that this issue does not happen in other sandboxes, you might want to check your permissions specific to this sandbox. Specifically, make sure that you have the "Manage Datasets" permission. 

vipinfkumar
Level 2
Level 2
Thanks Stew for detailed feedback. I had all the permissions added already. Am not sure what was triggering those error messages, however I restarted my laptop and it worked. Could be a cache or session issue. But Many Thanks for your comments and support.
dwright
Correct answer by
Employee
Employee

@vipinfkumar ,

Are you still stuck? Were you able to create the dataset? If you are still getting these messages, i would open a support ticket.

View solution in original post

vipinfkumar
Level 2
Level 2
This issue is resolved. I didn't do anything and could be a cache or session issue. However when I create the dataset via CSV file, it creates the schema by it with some name of "Adhoc schemaxxxx" but when I tried to find this schema to change the fields I couldn't find this schema. Where can I find the schema when the dataset gets created via CSV file and how we can control the dataset, schema and profile in this case. Please advise.