Yellow Coloring of Images

Avatar

Avatar

Jai1122

Avatar

Jai1122

Jai1122

14-02-2017

Hi Experts,

  We are experinencing a weird issue. Images in our websites turns yellow. There is no particular order or something just some images become yellow randomly.

We could not find anything in logs as well. We tried to delete the image and re-upload it to dam. It resolves issue for few images but not for all. Infact images uploaded into dam months ago have now started to appear yellow. We have field a daycare as well but since there is no way to reproduce the issue we are not sure how to proceed. 

 

Has anyone experienced similar issue? Can someone suggest us a wayout for this?

We are using AEM6.0 with SP2 on it.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

6.0K

Likes

1.1K

Correct Reply

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

6.0K

Likes

1.1K

Correct Reply

1.1K
kautuk_sahni
Community Manager

03-07-2017

Would request you to log Support ticket for this.

~kautuk

Answers (12)

Answers (12)

Avatar

Avatar

Jai1122

Avatar

Jai1122

Jai1122

15-02-2017

It happens on random images. The challenge is there is no real logic/ connection between the images that turn yellow and nothing in logs as well. 

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

15-02-2017

Does this happen on all images or random - looks like some sort of bug. I recommend working with support on this. They may need to investigate this much deeper than community members can. 

Avatar

Avatar

Jai1122

Avatar

Jai1122

Jai1122

15-02-2017

edubey wrote...

Do you have any workflow which act upon these images when they are uploaded to DAM.?

sometime back, I saw a similar issue with ACS named transformation servlet but it was not affecting image in DAM.

thanks

 

No workflow acted upon these images. We do have a ACS Named Transformation Servlet but nothing is configured to it  and so i believe that servlet will not cause any harm.

 

Thanks.

Avatar

Avatar

Jai1122

Avatar

Jai1122

Jai1122

15-02-2017

smacdonald2008 wrote...

Support team replied: 

  • There were a couple similar cases (with blue color instead) that were fixed by upgrading Java 8 to u77 or higher
  • One other thing you may want to investigate is the source and destination color spaces. Conversion from four color often results in color shift, color and direction determine s by source color space and profile.

Can you tell us how to check the the source and destination color specs?

 


 

 

 

 

Avatar

Avatar

edubey

Avatar

edubey

edubey

14-02-2017

Do you have any workflow which act upon these images when they are uploaded to DAM.?

sometime back, I saw a similar issue with ACS named transformation servlet but it was not affecting image in DAM.

thanks

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

14-02-2017

Support team replied: 

  • There were a couple similar cases (with blue color instead) that were fixed by upgrading Java 8 to u77 or higher
  • One other thing you may want to investigate is the source and destination color spaces. Conversion from four color often results in color shift, color and direction determine s by source color space and profile.


 

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

14-02-2017

In 5 years - i have never seen this or heard about AEM modifying an image making it yellow. I will run this by the support team. 

Avatar

Avatar

Jai1122

Avatar

Jai1122

Jai1122

14-02-2017

smacdonald2008 wrote...

Is this occur on 1 server or you have seen this on multiple servers. Certainly there is no feature in AEM that turns images yellow. If you download the images - are the modified. 

 

It is happening in author itself. And we have only one author. If we download the colored images, it still looks colored. 

Avatar

Avatar

Jai1122

Avatar

Jai1122

Jai1122

14-02-2017

adobecquser cq wrote...

Hi Jai1122,

Is it something like the images turn yellow while in DAM or when they show up on the page?

    It looks yellow in dam as well as on the page

Is it specific to certain formats?

  Does not seem to be specific for format. We observe it to happen for jpeg, png and even for thumbnails in pdf.

The images are created making use of any 3rd party systems?

  We use photoshop basically. 

Basically is there any sort of additional info, which sets those images apart from rest.

  We could not identify any info like that. The coloring is happening only for the rendition images and not for the original images. Also not all the rendition generated images got colored. So few non-colored rendition images are available.

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

14-02-2017

If possible - post a screen shot please. 

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

14-02-2017

Is this occur on 1 server or you have seen this on multiple servers. Certainly there is no feature in AEM that turns images yellow. If you download the images - are the modified. 

Avatar

Avatar

cquser1

Avatar

cquser1

cquser1

14-02-2017

Hi Jai1122,

Is it something like the images turn yellow while in DAM or when they show up on the page?

Is it specific to certain formats? The images are created making use of any 3rd party systems? Basically is there any sort of additional info, which sets those images apart from rest.