Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

When i try to run the Junit test i got the error in ui-content

Avatar

Level 4

Error:

jackrabbit-accesscontrol: Found no access control list, but there is supposed to be one contained as the property 'acHandling' is set to 'MERGE'! (org.apache.jackrabbit:filevault-package-maven-plugin:1.1.6:validate-files:default-validate-files:process-classes)

 

Can anyone solve the issue?

4 Replies

Avatar

Community Advisor

Hi @Nandheswara ,

Please check your ui-content pom file and add the property under the "filevault-package-maven-plugin" configuration.

acHandling options: - ignore - overwrite - merge - merge_preserve - clear

Hope that helps!
Regards,
Santosh

 

Avatar

Level 4

By Default Having this what i need to change can tell please

<plugin>
                <groupId>org.apache.jackrabbit</groupId>
                <artifactId>filevault-package-maven-plugin</artifactId>
                <configuration>
                    <properties>
                        <cloudManagerTarget>none</cloudManagerTarget>
                    </properties>
                    <group>com.genc.core</group>
                    <name>genc-aem-training.ui.content</name>
                    <packageType>content</packageType>
                    <accessControlHandling>merge</accessControlHandling>
                    <validatorsSettings>
                        <jackrabbit-filter>
                            <options>
                                <validRoots>/conf,/content,/content/experience-fragments,/content/dam</validRoots>
                            </options>
                        </jackrabbit-filter>
                    </validatorsSettings>
                    <dependencies>
                        <dependency>
                            <groupId>com.genc.core</groupId>
                            <artifactId>genc-aem-training.ui.apps</artifactId>
                            <version>${project.version}</version>
                        </dependency>
                    </dependencies>
                </configuration>
            </plugin>

 

Avatar

Level 2

Hi,

I get exactly the same error with the aem-guides-wknd project. What is the resolution? It says: "Found no access control list...", where would that list be found? Thanks for any ideas.

 

Update: The error goes away, when I change the value in the ui.content pom.XML to merge_preserve:

<accessControlHandling>merge_preserve</accessControlHandling>
I'm not sure what that means. But it solves the issue.

 

Avatar

Level 3
<plugin>
                <groupId>org.apache.jackrabbit</groupId>
                <artifactId>filevault-package-maven-plugin</artifactId>
                <configuration>
                    <properties>
                        <cloudManagerTarget>none</cloudManagerTarget>
                    </properties>
                    <group>com.genc.core</group>
                    <name>genc-aem-training.ui.content</name>
                    <packageType>content</packageType>
                    <accessControlHandling>merge</accessControlHandling>
                    <validatorsSettings>
                        <jackrabbit-filter>
                            <options>
                                <validRoots>/conf,/content,/content/experience-fragments,/content/dam</validRoots>
                            </options>
                        </jackrabbit-filter>
                    </validatorsSettings>
                    <dependencies>
                        <dependency>
                            <groupId>com.genc.core</groupId>
                            <artifactId>genc-aem-training.ui.apps</artifactId>
                            <version>${project.version}</version>
                        </dependency>
                    </dependencies>
                </configuration>
            </plugin>