Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

Unable to perform operation. Node is protected.

Avatar

Level 2

Hi,

 

  I created package for version storage and trying to install in 5.6.1. It's throwing Constrain violation error: Unable to perform operation. Node is protected.

I am also trying to install same package in 5.4 even it's throwing same error. Is there any other way to install.

Error:

 

Caused by: javax.jcr.nodetype.ConstraintViolationException: Unable to perform operation. Node is protected. at org.apache.jackrabbit.core.ItemValidator.checkCondition(ItemValidator.java:276) at org.apache.jackrabbit.core.ItemValidator.checkRemove(ItemValidator.java:254) at org.apache.jackrabbit.core.ItemRemoveOperation.perform(ItemRemoveOperation.java:63) at org.apache.jackrabbit.core.session.SessionState.perform(SessionState.java:200) at org.apache.jackrabbit.core.ItemImpl.perform(ItemImpl.java:91) at org.apache.jackrabbit.core.ItemImpl.remove(ItemImpl.java:322) at com.day.jcr.vault.fs.impl.io.FolderArtifactHandler.accept(FolderArtifactHandler.java:107) at com.day.jcr.vault.fs.io.Importer.commit(Importer.java:633) at com.day.jcr.vault.fs.io.Importer.commit(Importer.java:724) at com.day.jcr.vault.fs.io.Importer.commit(Importer.java:724) at com.day.jcr.vault.fs.io.Importer.run(Importer.java:288) at com.day.jcr.vault.packaging.impl.ZipVaultPackage.extract(ZipVaultPackage.java:353) ... 16 more

regards

Rajesh Karka

0 Replies